Geneste functies gebruiken in een formule

Opmerking:  We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

Een functie gebruiken als een van de argumenten in een formule waarin een functie nesten heet en we naar die functie als een geneste functie verwijzen. Bijvoorbeeld, door het nesten van de functie gemiddelde en som in de argumenten van de functie als, de volgende formule wordt een reeks getallen (G2:G5) alleen als het gemiddelde van een andere reeks getallen (F2: F5) groter dan 50 is. Anders is het resultaat 0.

geneste functies

De functies gemiddelde en som worden genest binnen de functie als.

U kunt maximaal 64 niveaus met functies nesten in een formule.

  1. Klik op de cel waarin u de formule wilt invoeren.

  2. De formule te beginnen met de functie, klikt u op Functie invoegen, Bijschrift 4 op de formule Bijschrift 4 staaf.

    Het gelijkteken (=) is al voor u ingevoegd.

  3. Selecteer in het vak Of selecteer een categorie de optie Alles.

    Als u de functiecategorieën kent, kunt u ook een categorie selecteren.

    Als u niet zeker weet welke functie u moet gebruiken, kunt u in het vak Zoek een functie een vraag typen waarmee u beschrijft wat u wilt doen ('getallen optellen' geeft bijvoorbeeld de functie SOM als resultaat).

  4. Als u een andere functie wilt opgeven als argument, geeft u de functie op in het gewenste argumentvak.

    De onderdelen van de formule in het dialoogvenster Functieargumenten komen overeen met de functie die u hebt geselecteerd in de vorige stap.

    Nadat u op ALS hebt geklikt, worden in het dialoogvenster Functieargumenten de argumenten voor de functie ALS weergegeven. U kunt een andere functie nesten door deze in het argumentvak op te geven. Geef bijvoorbeeld SOM(G2:G5) op in het vak waarde-als-waar van de functie ALS.

  5. Geef eventuele aanvullende argumenten op die noodzakelijk zijn om de formule te voltooien.

    In plaats van een celverwijzing te typen kunt u ook de cellen selecteren waarnaar u wilt verwijzen. Klik op Bijschrift 4 om het dialoogvenster te minimaliseren, selecteer de cellen waarnaar u wilt verwijzen en klik vervolgens op Knopafbeelding om het dialoogvenster opnieuw uit te vouwen.

    Tip: Klik op Help-informatie over deze functie voor meer informatie over de functie en zijn argumenten.

  6. Nadat u alle argumenten voor de functie hebt ingevoerd, klikt u op OK.

  1. Klik op de cel waarin u de formule wilt invoeren.

  2. De formule te beginnen met de functie, klikt u op Functie invoegen, Bijschrift 4 op de formule Bijschrift 4 staaf.

  3. Selecteer Allesin het dialoogvenster functie invoegen in het vak Kies een categorie .

    Als u de functiecategorieën kent, kunt u ook een categorie selecteren.

  4. Als u wilt een andere functie opgeven als argument, geeft u de functie in het argumentvak van de rechtstreeks in de cel of in de opbouwfunctie voor formules.

  5. Geef eventuele aanvullende argumenten op die noodzakelijk zijn om de formule te voltooien.

  6. Nadat u de argumenten voor de formule hebt voltooid, drukt u op ENTER.

Voorbeelden

Hieronder ziet u een voorbeeld van het gebruik van geneste als functies een letter toewijzen aan een numerieke score testen.

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. U kunt de resultaten van formules weergeven door de formules te selecteren en op F2 en vervolgens op Enter te drukken. Desgewenst kunt u de kolombreedte wijzigen om alle gegevens te zien.

Score

45

90

78

Formule

Beschrijving

Resultaat

'=ALS(A2>89;"A";ALS(A2>79;"B"; ALS(A2>69;"C";ALS(A2>59;"D";"F"))))

Hier worden geneste ALS-voorwaarden gebruikt om een letter toe te wijzen als score in cel A2.

=ALS(A2>89;"A";ALS(A2>79;"B";ALS(A2>69;"C";ALS(A2>59;"D";"F"))))

'=ALS(A3>89;"A";ALS(A3>79;"B"; ALS(A3>69;"C";ALS(A3>59;"D";"F"))))

Hier worden geneste ALS-voorwaarden gebruikt om een letter toe te wijzen als score in cel A3.

=ALS(A3>89;"A";ALS(A3>79;"B";ALS(A3>69;"C";ALS(A3>59;"D";"F"))))

'=ALS(A4>89,"A";ALS(A4>79;"B"; ALS(A4>69;"C";ALS(A4>59;"D";"F"))))

Hier worden geneste ALS-voorwaarden gebruikt om een letter toe te wijzen als score in cel A4.

=ALS(A4>89;"A";ALS(A4>79;"B";ALS(A4>69;"C";ALS(A4>59;"D";"F"))))

Tips: 

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Video: Geneste als-functies

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×