Functies en geneste functies in Excel-formules gebruiken

Functies zijn vooraf gedefinieerde formules waarmee berekeningen worden uitgevoerd met specifieke waarden (argumenten) in een specifieke volgorde of structuur. U kunt functies gebruiken voor het uitvoeren van eenvoudige of complexe berekeningen. U kunt alle Excel-functies vinden op het tabblad Formules op het lint:

Het tabblad Formules op het lint in Excel
  • Excel-functiesyntaxis

    Het volgende voorbeeld van de functie AFRONDEN, waarmee het getal in cel A10 wordt afgerond, toont de syntaxis van een functie.

    Structuur van een functie

    1. Structuur. Een functie begint altijd met een gelijkteken (=), gevolgd door de functienaam, een haakje openen, de argumenten voor de functie gescheiden door puntkomma's, en een haakje sluiten.

    2. Functienaam. Klik op een cel en druk op Shift+F3 om het dialoogvenster Functie invoegen weer te geven, waarin u een lijst met beschikbare functies kunt vinden.

    Excel-formules - Dialoogvenster Functie invoegen

    3. Argumenten. Argumenten kunnen bestaan uit getallen, tekst, logische waarden zoals WAAR of ONWAAR, matrices, foutwaarden zoals #N/B of celverwijzingen. Het opgegeven argument moet een geldige waarde voor dit argument opleveren. U kunt ook constanten, formules of andere functies als argumenten gebruiken.

    4. Knopinfo voor argumenten. Een kader met de syntaxis en argumenten van de functie dat verschijnt tijdens het typen van de functie. Als u bijvoorbeeld =AFRONDEN( typt, verschijnt een kader met informatie over deze functie. De knopinfo wordt alleen weergegeven voor ingebouwde functies.

    Opmerking: U hoeft de functies niet volledig in hoofdletters te typen, zoals =AFRONDEN. De naam van de functie wordt in Excel automatisch in hoofdletters weergegeven wanneer u op enter drukt. Als u de naam van een functie verkeerd spelt, zoals =SIM(A1:A10) in plaats van =SOM(A1:A10) dan wordt in Excel de fout #NAAM? weergeven.

  • Excel-functies invoeren

    Wanneer u een formule met een functie maakt, kunt u het dialoogvenster Functie invoegen gebruiken bij het invoeren van werkbladfuncties. Als u een functie selecteert in het dialoogvenster Functie invoegen, wordt in Excel de wizard Functie gestart, waarin de naam van de functie, de verschillende argumenten, een beschrijving van de functie en de argumenten, het huidige resultaat van de functie en het huidige resultaat van de gehele formule worden weergegeven.

    Wizard Functie in Excel

    Gebruik de functie Formule automatisch aanvullen om het invoeren en bewerken van formules te vereenvoudigen en het aantal invoer- en syntaxisfouten tot een minimum te beperken. Nadat u een gelijkteken (=) en de beginletters van een functie hebt getypt, verschijnt er in Excel een dynamische vervolgkeuzelijst met geldige functies, argumenten en namen die met de letters overeenkomen. Vervolgens kunt u er een in de vervolgkeuzelijst selecteren, waarna Excel deze voor u invoert.

    Excel-formule automatisch aanvullen

  • Excel-functies nesten

    In bepaalde gevallen hebt u mogelijk een functie nodig als een van de argumenten van een andere functie. In de volgende formule wordt bijvoorbeeld een geneste functie GEMIDDELDE gebruikt en wordt het resultaat vergeleken met de waarde 50.

    Geneste functies

    1. De functies GEMIDDELDE en SOM zijn genest in de functie ALS.

    Geldige resultaten    Wanneer een geneste functie als argument wordt gebruikt, moet de geneste functie resulteren in het waardetype van het argument. Als het argument bijvoorbeeld resulteert in de waarde WAAR of ONWAAR, moet de geneste functie eveneens de waarde WAAR of ONWAAR opleveren. Als dat niet het geval is, wordt de foutwaarde #WAARDE! weergegeven.

    Beperkingen bij het nesten van functies    Een formule kan maximaal zeven niveaus van geneste functies bevatten. Wanneer een functie (we noemen deze functie B) als argument wordt gebruikt in een andere functie (die we functie A noemen), is functie B een functie op het tweede niveau. Zo zijn GEMIDDELDE en SOM beide functies op het tweede niveau als ze worden gebruikt als argumenten van de functie ALS. Een geneste functie binnen de geneste functie GEMIDDELDE is dan een functie op het derde niveau, enzovoort.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×