Formules en functies

Functie SOM

Functie SOM

Opmerking: We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

De functie som , een van de wiskundige en trigonometrische functies, voegt waarden. U kunt afzonderlijke waarden, celverwijzingen of bereiken of een combinatie van alle drie toevoegen.

Bijvoorbeeld:

  • =SOM(A2:A10)

  • =SOM(A2:A10;C2:C10)

Uw browser biedt geen ondersteuning voor video. Installeer Microsoft Silverlight, Adobe Flash Player of Internet Explorer 9.

SOM(getal1;[getal2];...)

Naam argument

Beschrijving

getal1    (vereist)

Het eerste getal dat u wilt optellen. Het getal kan een cijfer zijn zoals 4, een celverwijzing zoals B6 of een celbereik zoals B2:B8.

getal2-255    (optioneel)

Dit is het tweede getal dat u wilt optellen. U kunt op deze manier maximaal 255 getallen opgeven.

In deze sectie wordt uitgelegd hoe enkele aanbevolen procedures voor het werken met de functie SOM gebruiken. Veel van deze kan worden toegepast op het werken met andere functies ook.

De methode =1+2 of =A+B. Hoewel =1+2+3 of =A1+B1+C2 in veel gevallen het juiste resultaat zal opleveren, zijn deze methoden om verschillende redenen foutgevoelig:

  1. Typfouten. Stel dat u meer en/of langere waarden moet invoeren zoals deze:

    • =14598,93+65437,90+78496,23

    Probeer te valideren of de fragmenten juist zijn. Het is veel gemakkelijker deze waarden in afzonderlijke cellen hebt opgeslagen en gebruiken van een somformule. Bovendien kunt u de waarden opmaken wanneer ze in de cellen, deze veel beter leesbaar maken en vervolgens als ze in een formule.

    Gebruik de functie SOM in plaats van letterlijke waarden op te nemen in formules.  Formule in cel D5 is =SOM(D2:D4)
  2. De fout #WAARDE! omdat er wordt verwezen naar tekst in plaats van getallen

    Stel dat u deze formule gebruikt:

    • =A1+B1+C1 of =A1+A2+A3

    Voorbeeld van een slechte formule.  Formule in cel D2 is =A2+B2+C2

    De formule kunt verbreken als er geen niet-numerieke (tekst)-waarden in de cellen waarnaar wordt verwezen, die aangeven #VALUE! fout. SOM wordt tekstwaarden negeren en geeft u de som van alleen de numerieke waarden.

    Juiste samenstelling van formule.  In plaats van =A2+B2+C2, is de formule van cel D2 =SOM(A2:C2)
  3. De fout #VERW! door het verwijderen van rijen of kolommen

    #VERW!-fout veroorzaakt doordat er een kolom is verwijderd.  Formule is gewijzigd in =A2+#VERW!+B2

    Als u een rij of kolom verwijdert, wordt de formule niet automatisch bijgewerkt met als gevolg dat de fout #VERW! wordt geretourneerd. Als u de functie SOM gebruikt, wordt de functie wel automatisch aangepast.

    In de functie SOM wordt automatisch rekening gehouden met ingevoegde of verwijderde rijen en kolommen
  4. Verwijzingen in formules worden niet bijgewerkt als u rijen of kolommen invoegt

    Formules met =A+B+C worden niet bijgewerkt als u rijen toevoegt

    Als u een rij of kolom invoegt, wordt de formule worden niet bijgewerkt om het opnemen van de rij met toegevoegde, waarbij een functie SOM automatisch bijgewerkt wordt (zo lang maken als u niet buiten het bereik waarnaar wordt verwezen in de formule bent). Dit is vooral belangrijk als u verwacht de formule dat wilt bijwerken en dit niet het geval is, zoals deze betekent dat u met onvolledige resultaten die u mogelijk niet onderschept.

    In het voorbeeld ziet u een formule met SOM die automatisch wordt uitgebreid van =SOM(A2:C2) naar =SOM(A2:D2) als er een kolom wordt ingevoegd
  5. De functie SOM gebruiken met afzonderlijke celverwijzingen of bereiken

    Stel dat u deze formule gebruikt:

    • =SOM(A1;A2;A3;B1;B2;B3)

    Gelijkmatig is fout vatbaar wanneer invoegen of verwijderen van rijen in het bereik waarnaar wordt verwezen om dezelfde redenen. Het is veel beter gebruik van afzonderlijke bereiken, zoals:

    • =SOM(A1:A3;B1:B3)

    Deze worden namelijk bijgewerkt als u rijen toevoegt of verwijdert.

Probleem

Wat is er fout gegaan

In mijn functie SOM wordt ##### weergegeven in plaats van het resultaat.

Controleer uw kolombreedten. ### betekent meestal dat de kolom is te klein is om het formuleresultaat weer te geven.

In mijn functie SOM wordt de formule zelf weergegeven als tekst in plaats van het resultaat.

Controleer of de cel niet is ingedeeld als tekst. Selecteer de cel of bereik betrokken en gebruikt u Ctrl + 1 naar het dialoogvenster Celeigenschappen weer, klik op het tabblad getal en selecteer de gewenste indeling. Als de cel is opgemaakt als tekst en wordt niet gewijzigd nadat u de opmaak wijzigen, moet u mogelijk gebruiken F2 > Enter afdwingen van de indeling wijzigen.

Mijn functie SOM wordt niet bijgewerkt.

Zorg dat de berekening is ingesteld op automatisch. Ga op het tabblad formules naar Berekeningsopties. U kunt ook F9 afdwingen van het werkblad om te berekenen.

Zorg ervoor dat Berekening is ingesteld op Automatisch.  Ga op het tabblad Formule naar Berekeningsopties.

Sommige waarden worden niet opgeteld.

Alleen numerieke waarden in de functieverwijzing of het functiebereik worden opgeteld. Lege cellen, logische waarden, zoals WAAR, of tekst worden genegeerd.

De foutwaarde #NAAM? wordt weergegeven in plaats van het verwachte resultaat.

Dit betekent meestal dat de formule verkeerd is gespeld, zoals =some(A1:A10) in plaats van =SOM(A1:A10).

In mijn functie SOM wordt een geheel getal weergegeven terwijl er decimalen moeten worden weergegeven

Controleer de celopmaak om na te gaan of er decimalen worden weergegeven. Selecteer de cel of het celbereik en gebruik Ctrl+1 om het dialoogvenster Celeigenschappen weer te geven. Klik op het tabblad Getal en selecteer de gewenste notatie.Geef het gewenste aantal decimalen op.

  1. Ik wil alleen getallen optellen/aftrekken/vermenigvuldigen/delen Bekijk deze videoreeks over het uitvoeren van basisberekeningen in Excel of gebruik van Excel als rekenmachine.

  2. Hoe kan ik meer/minder decimalen weergeven? U kunt uw getalnotatie wijzigen. Selecteer de cel of bereik betrokken en Ctrl + 1 naar het dialoogvenster Celeigenschappen weer, klik op het tabblad getal en selecteer de gewenste notatie, ervoor te zorgen dat om aan te geven van het aantal decimalen dat u wilt gebruiken.

  3. Hoe kan ik tijden optellen of aftrekken? U kunt tijden op verschillende manieren optellen en aftrekken. Als u bijvoorbeeld voor de salarisadministratie het verschil tussen 8:00 uur en 24:00 uur wilt weergeven, gebruikt u: =("24:00"-"8:00")*24, de eindtijd minus de starttijd. Omdat tijden in Excel als dagdeel worden berekend, moet u de waarde vermenigvuldigen met 24 om het totaal aantal uren als resultaat weer te geven. In het eerste voorbeeld gebruiken we =((B2-A2)+(D2-C2))*24 om de som van het aantal uren van het begin tot het einde als resultaat weer te geven, minus de lunchpauze. (8,5 uur in totaal).

    Als u alleen uren en minuten wilt optellen en op die manier wilt weergeven, hoeft u niet met 24 te vermenigvuldigen. In het tweede voorbeeld gebruiken we daarom =SOM(A6:C6) omdat we alleen het totaal aantal uren en minuten willen voor toegewezen taken (5:36, ofwel 5 uren, 36 minuten).

    Tijden berekenen

    Zie voor meer informatie: Tijden optellen of aftrekken.

  4. Hoe kom ik aan het verschil tussen datums? Als u met de tijden, kunt u optellen en aftrekken van datums. Hier is een zeer algemene voorbeeld van het aantal dagen tussen twee datums tellen. Het is eenvoudig = B2-A2. Het belangrijkste voor het werken met zowel datums en tijden is dat u bent met de einddatum /-tijd begonnen en aftrekken van datum/tijd starten.

    Verschillen tussen datums berekenen

    Zie het volgende artikel voor meer informatie over het werken met datums: Het aantal dagen tussen twee datums berekenen

  5. Hoe ik alleen zichtbare cellen optellen? Soms wanneer u handmatig rijen verbergt of AutoFilter gebruikt om alleen bepaalde gegevens weer te geven, wilt u ook alleen de zichtbare cellen optellen. U kunt daarvoor de functie SUBTOTAAL gebruiken. Als u een rij met totalen in een Excel-tabel gebruikt, wordt een functie die u in de vervolgkeuzelijst Totalen selecteert automatisch ingevoerd als een subtotaal. Zie meer informatie over het optellen van gegevens in een Excel-tabel.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Meer informatie over som

De functie SOM.Als worden alleen de waarden die voldoen aan één criterium toegevoegd

Het sommen.Als, functie voegt alleen de waarden die voldoen aan meerdere criteria

De aantal.als-functie telt alleen de waarden die voldoen aan één criterium

Het aantallen.Als worden geteld alleen de waarden die voldoen aan meerdere criteria

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Zoeken en corrigeren van fouten in formules

Sneltoetsen in Excel voor Windows

Sneltoetsen in Excel voor Mac

Wiskundige en trigonometrische functies

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×