Fouten opsporen in formules

Opmerking: We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

Formules kunnen soms foutwaarden of onbedoelde resultaten opleveren. Hieronder vindt u enkele hulpmiddelen waarmee u de oorzaken van deze fouten kunt onderzoeken en oplossingen kunt bepalen.

Opmerking: In dit onderwerp worden technieken behandeld waarmee u fouten in formules kunt corrigeren. In het overzicht zijn niet alle methoden voor het corrigeren van alle mogelijk fouten opgenomen. Voor hulp bij specifieke fouten kunt u naar vragen zoals die van u zoeken in het forum van de Excel-community. U kunt ook zelf een vraag posten.

Koppeling naar het forum van de Excel-community

Een eenvoudige formule invoeren

Formules zijn vergelijkingen waarmee berekeningen worden uitgevoerd op waarden in het werkblad. Een formule begint met een gelijkteken (=). In het onderstaande voorbeeld worden 3 en 1 bij elkaar opgeteld.

=3+1

Een formule kan ook een of meer van de volgende items bevatten: functies, verwijzingen, operatoren en constanten.

onderdelen van een formule

Onderdelen van een formule

  1. Functies: die zijn opgenomen in Excel, functies zijn ontworpen formules waarin specifieke berekeningen worden uitgevoerd. Bijvoorbeeld: de functie pi () geeft als resultaat de waarde van pi: 3,142...

  2. Verwijzingen: verwijzen naar afzonderlijke cellen of celbereiken. A2 geeft als resultaat de waarde in cel a2.

  3. Constanten: cijfers of tekstwaarden die rechtstreeks worden ingevoerd in een formule, zoals 2.

  4. Operatoren: De operator ^ (caret-teken) wordt gebruikt om een getal tot een macht te verheffen en de operator * (sterretje) wordt gebruikt om te vermenigvuldigen. Gebruik + en - om waarden op te tellen en af te trekken. Gebruik / om te delen.

    Opmerking: Voor sommige functies is vereist dat argumentenworden genoemd. Argumenten zijn de waarden die door bepaalde functies worden gebruikt om de berekeningen uit te voeren. Indien nodig worden argumenten tussen de haakjes van de functie geplaatst (). De functie pi heeft geen argumenten nodig, wat betekent dat het leeg is. Voor sommige functies zijn een of meer argumenten vereist, en kan ruimte achterblijven voor aanvullende argumenten. U moet een komma gebruiken om argumenten te scheiden, of een punt komma (;) afhankelijk van uw locatie-instellingen.

Voor de functie SOM is slechts één argument nodig, maar de functie heeft ruimte voor 255 argumenten.

Functie SOM

=SOM(A1:A10) is een voorbeeld van één argument.

=SOM(A1:A10;C1:C10) is een voorbeeld van meerdere argumenten.

In de volgende tabel vindt u een overzicht van enkele veelvoorkomende fouten die een gebruiker tijdens het typen van een formule kan maken. En wordt uitgelegd hoe die fouten kunnen worden gecorrigeerd:

Let op het volgende

Meer informatie

Begin elke functie met een gelijkteken (=) 

Als u het gelijkteken weglaat, kunnen de gegevens die u typt, worden weergegeven als tekst of als een datum. Als u bijvoorbeeld SOM(A1:A10) typt, wordt in Excel de tekenreeks SOM(A1:A10) weergegeven en wordt de berekening niet uitgevoerd. Als u 11/2 typt, wordt in Excel de datum als 2 nov weergegeven (als de celopmaak Algemeen is, in plaats van de uitkomst 11 door 2 te delen.

Zorg ervoor dat de haakjes openen en sluiten overeenkomen

Controleer of elk haakje openen een bijbehorend haakje sluiten heeft. Wanneer u een functie in een formule gebruikt, moet elk haakje op de juiste plaats staan, omdat de functie anders niet goed werkt. De formule =ALS(B5<0),'Niet geldig',B5*1,05) werkt niet, omdat er twee haakjes sluiten zijn en slechts één haakje openen, terwijl er van elk een moet zijn. De juiste formule is: =ALS(B5<0,'Niet geldig',B5*1,05).

Gebruik een dubbele punt om een bereik aan te geven 

Als u naar een cellenbereik verwijst, moet u een dubbele punt (:) plaatsen als scheidingsteken tussen de verwijzing naar eerste en de verwijzing naar de laatste cel in het bereik. Bijvoorbeeld: =SOM(A1:A5), en niet =SOM(A1 A5), waardoor de fout #LEEG! zou worden geretourneerd.

Typ alle vereiste argumenten

Sommige functies hebben verplichte argumenten. Controleer ook of u niet te veel argumenten hebt opgegeven.

Voer het juiste type argumenten in

Voor sommige functies, zoals SOM, zijn alleen numerieke argumenten vereist, terwijl voor andere functies, zoals VERVANGEN, een tekstwaarde nodig is voor ten minste één van de argumenten. Als u het verkeerde gegevenstype gebruikt, kunnen in Excel sommige functies onverwachte resultaten of een fout opleveren.

Nest niet meer dan 64 functies 

U mag maximaal 64 niveaus met functies binnen een functie invoeren (nesten).

Plaats namen van andere werkbladen tussen enkele aanhalingstekens 

Als een formule verwijzingen naar waarden of cellen op andere werkbladen of in andere werkmappen bevat, en de naam van het andere werkblad of de andere werkmap spaties of niet-alfabetische tekens bevat, moet u deze naam tussen enkele aanhalingstekens (') plaatsen, bijvoorbeeld ='Kwartaalcijfers'!D3, of =‘123’!A1.

Gebruik een uitroepteken (!) na de naam van het werkblad wanneer u er in een formule naar verwijst

Als u bijvoorbeeld de waarde van cel D3 in een werkblad met de naam Kwartaalgegevens in dezelfde werkmap wilt weergeven, gebruikt u de volgende formule: ='Kwartaalgegevens'!D3.

Neem het pad naar externe werkmappen op 

Zorg dat alle externe referenties de naam van een werkmap en het pad naar de werkmap bevatten.

Een verwijzing naar een werkmap bevat de naam van de werkmap en moet tussen haakjes staan (Werkbladnaam.xlsx). De verwijzing moet ook de naam van het werkblad in de werkmap bevatten.

Als de werkmap waar u naar wilt verwijzen, niet openstaat in Excel, kunt u toch een verwijzing in een formule opnemen. Geef het volledige pad naar het bestand op, zoals in het volgende voorbeeld: =RIJEN('C:\Mijn documenten\[K2 activiteiten.xlsx]Verkoop'!A1:A8). Door deze formule wordt het aantal rijen gegeven in het bereik van cel A1 tot en met A8 in de andere werkmap (8).

Opmerking: Als het volledige pad spaties bevat, zoals in het voorgaande voorbeeld, moet u het pad tussen enkele aanhalingstekens zetten (aan het begin van het pad en na de naam van de werkmap, vóór het uitroepteken).

Typ getallen zonder opmaak 

Gebruik geen opmaak voor getallen die u in formules opgeeft. Als u 1000 euro wilt invoeren als waarde, voert u 1000 in de formule in. Als u een komma als deel van een getal invoert, interpreteert Excel de komma als scheidingsteken. Als u getallen met scheidingstekens voor duizendtallen of valutatekens wilt weergeven, maakt u de cellen op nadat u de waarden hebt ingevoerd.

Als u bijvoorbeeld 3100 wilt optellen bij de waarde in cel A3 en u de formule =SOM(3;100;A3) invoert, telt Excel de getallen 3 en 100 op en wordt dat totaal opgeteld bij de waarde in A3, in plaats van dat 3100 bij A3 wordt opgeteld, dus als =SOM(3100;A3). Als u bijvoorbeeld de formule =ABS(-2,134) invoert, wordt er in Excel een foutbericht weergegeven omdat de functie ABS slechts één argument accepteert: =ABS(-2134).

U kunt bepaalde regels instellen om te controleren op fouten in formules. Deze regels leveren geen gegarandeerd foutloos werkblad op, maar ze zorgen er wel voor dat de meest gangbare fouten worden achterhaald. U kunt elk van deze regels afzonderlijk in- of uitschakelen.

Fouten kunnen op twee manieren worden gemarkeerd en gecorrigeerd: één fout tegelijk (zoals bij een spellingcontrole) of direct tijdens het invoeren van gegevens in het werkblad.

U kunt een fout oplossen met de opties die in Excel worden weergegeven. U kunt een fout ook negeren door op Fout negeren te klikken. Als u een fout in een bepaalde cel negeert, wordt de fout in die cel bij verdere foutcontroles niet meer weergegeven. U kunt eerder genegeerde fouten echter wel opnieuw laten weergeven.

  1. Voor Excel in Windows: Klik op bestand > Opties > formulesof
    voor Excel op Mac klikt u op het menu Excel > voor keuren > fout controle.

    Klik in Excel 2007 op de Microsoft Office-knop afbeelding office-knop > Opties voor Excel > Formules.

  2. Schakel onder fout controle het selectie vakje fout controle op de achtergrond inschakelen in. Alle gevonden fouten worden gemarkeerd met een drie hoekje in de linkerbovenhoek van de cel.

    cel met een formuleprobleem
  3. Als u de kleur wilt wijzigen van de driehoek waarmee wordt aangegeven waar een fout is opgetreden, selecteert u de gewenste kleur in het vak Fouten aangeven met deze kleur.

  4. Schakel onder Controleregels van Excel de selectievakjes voor de volgende regels in of uit:

    • Cellen met formules die een fout als resultaat geven: In de formule worden niet de verwachte syntaxis, argumenten of gegevenstypen gebruikt. Mogelijke foutwaarden zijn: #DEEL/0!, #N/B, #NAAM?, #LEEG!, #GETAL!, #VERW! en #WAARDE!. Deze foutwaarden hebben elk verschillende oorzaken en worden op verschillende manieren opgelost.

      Opmerking: Als u een foutwaarde rechtstreeks in een cel invoert, wordt deze opgeslagen als die foutwaarde, maar niet gemarkeerd als een fout. Als een formule in een andere cel echter naar die cel verwijst, is het resultaat van de formule de foutwaarde uit die cel.

    • Tabellen bevatten inconsistent berekende formules: een berekende kolom kan afzonderlijke formules bevatten die afwijken van de hoofdkolomformule, waardoor een uitzondering ontstaat. Uitzonderingen in berekende kolommen ontstaan in de volgende gevallen:

      • Wanneer u andere gegevens dan een formule in een cel in een berekende kolom typt.

      • Typ een formule in een cel in de berekende kolom en druk op CTRL + Z of klik op Knop Ongedaan maken ongedaan maken op de werk balk snelle toegang.

      • Wanneer u een nieuwe formule typt in een berekende kolom die al een of meer uitzonderingen bevat.

      • Wanneer u gegevens naar de berekende kolom kopieert die niet overeenkomen met de formule voor de berekende kolom. Als de gekopieerde gegevens een formule bevatten, worden met deze formule de gegevens in de berekende kolom overschreven.

      • Wanneer u een cel in een ander werkbladgebied verwijdert of verplaatst terwijl naar deze cel wordt verwezen vanuit een van de rijen in de berekende kolom.

    • In cellen worden jaartallen weergegeven met twee cijfers: De cel bevat een datum met tekstnotatie die bij gebruik in formules verkeerd kan worden geïnterpreteerd. De datum in de formule =JAAR("1/1/31") zou bijvoorbeeld 1931 of 2031 kunnen zijn. Gebruik deze regel om formules te controleren op datums met tekstnotatie.

    • Getallen zijn opgemaakt als tekst of worden voorafgegaan door een apostrof: De cel bevat getallen die zijn opgeslagen als tekst. Dit gebeurt gewoonlijk wanneer gegevens uit andere bronnen worden geïmporteerd. Getallen die zijn opgeslagen als tekst kunnen onverwachte problemen veroorzaken tijdens sorteerbewerkingen en kunnen daarom het beste naar getallen worden geconverteerd. ‘=SOM(A1:A10) wordt als tekst gezien.

    • Formules zijn inconsistent met andere formules in het gebied: De formule komt niet overeen met het patroon van andere formules in hetzelfde gebied. Vaak verschillen formules alleen van aangrenzende formules in de gebruikte verwijzingen. In het volgende voorbeeld met vier aangrenzende formules wordt naast de formule =SOM(A10:C10) in cel D4 een fout weergegeven omdat de aangrenzende formules met één rij worden verhoogd en er één met acht rijen wordt verhoogd, terwijl de formule =SOM(A4:C4) wordt verwacht.

      Er wordt een fout weergegeven als een fout niet overeenkomt met het patroon van aangrenzende formules

      Als de verwijzingen in een formule niet consistent zijn met de verwijzingen in aangrenzende formules, wordt in Excel een fout weergegeven.

    • Formules slaan cellen in een gebied over: In een formule worden mogelijk niet automatisch verwijzingen opgenomen naar gegevens die u invoegt tussen het oorspronkelijke gegevensbereik en de cel met de formule. Met deze regel wordt de verwijzing in een formule vergeleken met het werkelijke celbereik dat grenst aan de cel met de formule. Als de aangrenzende cellen extra waarden bevatten en niet leeg zijn, wordt naast de formule een fout weergegeven.

      Wanneer deze regel wordt toegepast, wordt bijvoorbeeld een fout naast de formule =SOM(D2:D4) weergegeven omdat de cellen D5, D6 en D7 grenzen aan de cellen waarnaar wordt verwezen in de formule en de cel met formule (D8), en omdat deze cellen gegevens bevatten waarnaar in de formule zou moeten worden verwezen.

      Er wordt een fout weergegeven als een formule cellen in een bereik overslaat
    • niet-vergrendelde cellen met formules: de formule is niet beveiligd tegen beveiliging. Standaard worden alle cellen in een werk blad vergrendeld, zodat deze niet kunnen worden gewijzigd wanneer het werk blad is beveiligd. Dit kan helpen voor komen dat u per ongeluk formules verwijdert of wijzigt. Deze fout geeft aan dat de cel is ingesteld op ontgrendeld, maar dat het blad niet is beveiligd. Controleer of u de cel niet wilt vergren delen.

    • Formules die naar lege cellen verwijzen: de formule bevat een verwijzing naar een lege cel. Dit kan onjuiste resultaten opleveren, zoals in het volgende voorbeeld is weergegeven.

      Stel dat u het gemiddelde wilt berekenen van de getallen in de volgende kolommen met cellen. Als de derde cel leeg is, wordt deze niet opgenomen in de berekening en is het resultaat 22,75. Als de derde cel 0 bevat, is het resultaat 18,2.

      Er wordt een fout weergegeven als een formule naar lege cellen verwijst
    • De ingevoerde tabelgegevens zijn ongeldig: er is een validatiefout aanwezig in een tabel. Controleer de validatie-instelling voor de cel via het tabblad Gegevens > groep Hulpmiddelen voor gegevens > Gegevensvalidatie.

  1. Selecteer het werkblad dat u op fouten wilt controleren.

  2. Als het werkblad handmatig wordt berekend, drukt u nu op F9 om een herberekening uit te voeren.

    Als het dialoogvenster Foutcontrole niet wordt weergegeven, klikt u op het tabblad Formules > Formules controleren > knop Foutcontrole.

  3. Als u eerder fouten hebt genegeerd, kunt u als volgt opnieuw op die fouten controleren: Klik op bestand > Opties > formules. Voor Excel op Mac klikt u op het menu Excel > voor keuren > fout controle.

    Klik in de sectie Foutcontrole op Beginwaarden van genegeerde fouten > OK.

    Foutcontrole

    Opmerking: Als u genegeerde fouten opnieuw instelt, worden alle fouten op alle bladen van de actieve werkmap opnieuw ingesteld.

    Tip: Het scheelt als u het dialoogvenster Foutcontrole onder de formulebalk plaatst.

    Verplaats het vak Foutcontrole onder de formulebalk
  4. Klik rechts in het dialoogvenster op een van de actieknoppen. De beschikbare acties zijn voor elk type fout verschillend.

  5. Klik op Volgende.

Opmerking: Als u op Fout negeren klikt, wordt de fout bij elke volgende controle genegeerd.

  1. Klik naast de cel op de knop Foutcontrole Pictogram Foutcontrole en klik op de gewenste optie. De beschikbare opdrachten zijn per type fout verschillend en het eerste item in de lijst bevat de beschrijving van de fout.

    Als u op Fout negeren klikt, wordt de fout bij elke volgende controle genegeerd.

    Verplaats het vak Foutcontrole onder de formulebalk

Als het resultaat van een formule niet correct kan worden bepaald, wordt een foutwaarde weergegeven, zoals #####, #DEEL/0!, #N/B, #NAAM?, #LEEG!, #GETAL!, #VERW! en #WAARDE!. Elk type fout heeft verschillende oorzaken en ook verschillende oplossingen.

De volgende tabel bevat koppelingen naar artikelen waarin deze fouten uitgebreid worden beschreven en een korte beschrijving, zodat u aan de slag kunt.

Onderwerp

Omschrijving

De fout ##### corrigeren

Deze fout wordt weergegeven als een kolom niet breed genoeg is om alle tekens in een cel weer te geven of als een cel negatieve datum- of tijdwaarden bevat.

Een formule waarmee een datum in de toekomst wordt afgetrokken van een datum in het verleden, zoals =06/15/2008-07/01/2008, resulteert bijvoorbeeld in een negatieve datumwaarde.

Tip: U kunt de cel automatisch aanpassen door te dubbel klikken tussen de kolom koppen. Als # # # wordt weer gegeven omdat niet alle tekens worden weer gegeven die door Excel worden gecorrigeerd.

foutnummer

De fout #DEEL/0! corrigeren

Deze fout wordt weergegeven wanneer een getal wordt gedeeld door nul (0) of door een cel die geen waarde bevat.

Tip: Voeg een foutafhandeling toe zoals in het volgend voorbeeld: =ALS(C2;B2/C2;0)

Met een foutafhandelingsfunctie als ALS kunnen fouten worden tegengegaan

De fout #N/B corrigeren

Deze fout wordt weergegeven wanneer een waarde niet beschikbaar is voor een functie of formule.

Als u een functie als VERT. zoeken gebruikt, heeft wat u zoekt in het opzoek bereik een resultaat? Dit is meestal niet het geval.

Gebruik fout om het #N/a. te onderdrukken. In dit geval kunt u het volgende doen:

=ALS.FOUT(VERT.ZOEKEN(D2;$D$6:$E$8;2;WAAR);0)

De fout #N/B

De fout #NAAM? corrigeren

Deze fout wordt weergegeven wanneer tekst in een formule niet wordt herkend. Bijvoorbeeld wanneer de naam van een bereik of van een functie onjuist is gespeld.

Opmerking: Als u een functie gebruikt, controleert u of de naam van de functie juist is gespeld. In dit geval is de som onjuist gespeld. De ' e ' verwijderen, waarna Excel wordt gecorrigeerd.

De fout #NAAM? wordt weergegeven als een functienaam een typefout bevat

De fout #LEEG! corrigeren

Deze fout wordt weergegeven wanneer u een snijpunt opgeeft van twee gebieden die elkaar niet overlappen. De snijpuntoperator is een spatie die de verwijzingen in een formule van elkaar scheidt.

Opmerking: Zorg ervoor dat uw bereiken op de juiste manier van elkaar zijn gescheiden: de gebieden C2: C3 en E4: E6 worden dus niet doorsnijden, dus als u de formule = som (C2: C3 E4: E6) invoert, wordt het #NULL. fout. Als u een komma tussen de C-en E-bereiken plaatst, wordt deze gecorrigeerd = som (C2: C3, E4: E6)

Fout #LEEG!

De fout #GETAL! corrigeren

Deze fout wordt weergegeven wanneer een formule of functie ongeldige numerieke waarden bevat.

Gebruikt u een functie die wordt herhaald, zoals IR of rente? Als dit het geval is, is de #NUM! fout is waarschijnlijk omdat de functie geen resultaat kan vinden. Raadpleeg het Help-onderwerp voor de oplossings stappen.

De fout #VERW! corrigeren

Deze fout wordt weergegeven wanneer een celverwijzing niet geldig is. U hebt bijvoorbeeld cellen verwijderd waarnaar in andere formules wordt verwezen of u hebt cellen geplakt over cellen waarnaar in andere formules wordt verwezen.

Hebt u per ongeluk een rij of kolom verwijderd? Kolom B in deze formule is verwijderd, = som (a2, B2, C2) en kijk wat er is gebeurd.

Gebruik Ongedaan maken (Ctrl+Z) om de verwijdering ongedaan te maken en maak de formule opnieuw, of gebruik een doorlopende bereikverwijzing, bijvoorbeeld =SOM(A2:C2). Deze wordt automatisch bijgewerkt als kolom B wordt verwijderd.

De fout #VERW! wordt weergegeven wanneer een celverwijzing niet geldig is

De fout #WAARDE! corrigeren

Deze fout kan optreden als de formule verwijst naar cellen die verschillende gegevenstypen bevatten.

Gebruikt u reken kundige opera toren (+,-, *,/, ^) met verschillende gegevens typen? Als dit het geval is, probeert u een functie te gebruiken. In dit geval is som (F2: F5) het probleem opgelost.

De fout #WAARDE!

Als cellen niet zichtbaar zijn in een werkblad, kunt u die cellen en de formule daarin bekijken in de werkbalk Venster Controle. Met Venster Controle kunt u berekeningen en resultaten van formules in grote werkbladen gemakkelijk controleren, evalueren of bevestigen. Als u Venster Controle gebruikt, hoeft u niet telkens naar de verschillende delen van het werkblad te schuiven.

In Venster Controle kunt u makkelijk formules volgen die in een werkblad worden gebruikt

Deze werkbalk kan net als alle andere werkbalken worden verplaatst of vastgezet. U kunt de werkbalk bijvoorbeeld onder aan het venster vastzetten. In de werkbalk worden de volgende celeigenschappen bijgehouden: 1) Werkmap, 2) Blad, 3) Naam (als de cel een overeenkomend benoemd bereik heeft), 4) Celadres, 5) Waarde en 6) Formule.

Opmerking: U kunt per cel slechts één controle uitvoeren.

Cellen toevoegen aan Venster Controle

  1. Selecteer de cellen die u wilt bekijken.

    Als u alle cellen in een werkblad met formules wilt selecteren, gaat u naar het tabblad Start en klikt u in de groep Bewerken op Zoeken en selecteren (of gebruik Ctrl+G, of Control+G op de Mac). Ga naar Speciaal > Formules.

    Ga naar het dialoogvenster Speciaal
  2. Klik op het tabblad Formules in de groep Formules controleren op Venster Controle.

  3. Klik op Controle toevoegen.

    Klik op Controle toevoegen om een controle aan uw spreadsheet toe te voegen
  4. Bevestig dat u alle cellen hebt geselecteerd die u wilt controleren en klik op Toevoegen.

    Voer in Controle toevoegen het te controleren celbereik in
  5. Als u de breedte van een Venster Controle-kolom wilt wijzigen, versleept u de rand rechts van de kolomkop.

  6. Als u een cel wilt weergeven waarnaar door een item op de werkbalk Venster Controle wordt verwezen, dubbelklikt u op dit item.

    Opmerking: Cellen met externe verwijzing naar andere werkmappen worden alleen op de werkbalk Venster Controle weergegeven als de andere werkmappen geopend zijn.

Cellen verwijderen uit Venster Controle

  1. Als de werkbalk Venster Controle niet wordt weergegeven, klikt u op het tabblad Formules, in de groep Formules controleren, op Venster Controle.

  2. Selecteer de cellen die u wilt verwijderen.

    Als u meerdere cellen wilt selecteren, houdt u Ctrl ingedrukt en klikt u op de gewenste cellen.

  3. Klik op Controle verwijderen.

    Controle verwijderen

Soms is het moeilijk om duidelijk te zien hoe een geneste formule het uiteindelijke resultaat berekent, omdat er meerdere tussenliggende berekeningen en logische tests plaatsvinden. Als u het dialoogvenster Formule evalueren gebruikt, kunt u de verschillende onderdelen van een geneste formule echter bekijken in de volgorde waarin de formule wordt berekend. De formule =ALS(GEMIDDELDE(D2:D5)>50;SOM(E2:E5);0) is gemakkelijker te begrijpen wanneer u de volgende tussenliggende resultaten kunt bekijken:

Met Formule evalueren kunt u zien hoe verschillende onderdelen van een geneste formule worden geëvalueerd

In het dialoogvenster Formule evalueren

Beschrijving

=ALS(GEMIDDELDE(D2:D5)>50;SOM(E2:E5);0)

De geneste formule wordt eerst weergegeven. De functies GEMIDDELDE en SOM zijn genest in de functie ALS.

Het celbereik D2:D5 bevat de waarden 55, 35, 45 en 25, en het resultaat van de functie GEMIDDELDE(D2:D5) is dus 40.

=ALS(40>50;SOM(E2:E5);0)

Het celbereik D2:D5 bevat de waarden 55, 35, 45 en 25, en het resultaat van de functie GEMIDDELDE(D2:D5) is dus 40.

=ALS(Onwaar;SOM(E2:E5);0)

40 is niet groter dan 50, dus de expressie in het eerste argument van de functie ALS (het argument logische_test) is onwaar.

De functie ALS retourneert de waarde van het derde argument (het argument waarde-als-onwaar). De functie SOM wordt niet geëvalueerd, omdat deze functie het tweede argument voor de functie ALS is (het argument waarde-als-waar) en alleen wordt geretourneerd als de expressie waar is.

  1. Selecteer de cel die u wilt evalueren. U kunt slechts één cel tegelijk evalueren.

  2. Selecteer het tabblad Formules > Formules controleren > Formule evalueren.

  3. Klik op Evalueren om de waarde van de onderstreepte verwijzing te bekijken. Het resultaat van de evaluatie wordt cursief weergegeven.

    Als het onderstreepte deel van de formule een verwijzing naar een andere formule is, klikt u op Overstappen om de andere formule weer te geven in het vak Evaluatie. Klik op Terugstappen om terug te gaan naar de vorige cel en formule.

    De knop Overstappen is niet beschikbaar voor een verwijzing als de verwijzing een tweede keer in de formule voorkomt of als de formule verwijst naar een cel in een afzonderlijke werkmap.

  4. Klik net zolang op Evalueren totdat elk onderdeel van de formule is geëvalueerd.

  5. Als u de evaluatie opnieuw wilt bekijken, klikt u op Opnieuw starten.

  6. Als u de evaluatie wilt beëindigen, klikt u op Sluiten.

Notities: 

  • Sommige delen van formules waarin de functies ALS en KIEZEN worden gebruikt, worden niet geëvalueerd. In dat geval wordt de foutwaarde #N/B weergegeven in het vak Evaluatie.

  • Als een verwijzing leeg is, wordt de waarde nul (0) weergegeven in het vak Evaluatie.

  • De volgende functies worden bij wijzigingen in het werkblad telkens herberekend. Dit kan ertoe leiden dat in het dialoogvenster Formule evalueren resultaten worden weergegeven die verschillen met wat er in de cel verschijnt: ASELECT, BEREIKEN, INDEX, VERSCHUIVING, CEL, INDIRECT, RIJEN, KOLOMMEN, NU, VANDAAG, ASELECTTUSSEN.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

De relaties tussen formules en cellen weergeven

Niet-werkende formules voorkomen

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×