FIELDVALUE, functie

U kunt de functie FIELDVALUE gebruiken om veldgegevens op te halen uit gekoppelde gegevenstypen zoals Aandelen of Geografie. Er zijn eenvoudigere methoden voor het schrijven van formules die verwijzen naar gegevenstypen. Gebruik de functie FIELDVALUE daarom voornamelijk voor het maken van voorwaardelijke berekeningen op basis van gekoppelde gegevenstypen.

Opmerking: 27 november 2018. Gegevenstypen zijn nu beschikbaar voor alle Office 365-abonnees die Windows gebruiken, met uitzondering van een aantal geopolitieke locaties (gegevenstypen komen daar binnenkort beschikbaar). Controleer als u een Office 365-abonnement hebt of u de nieuwste versie van Office hebt.

Technische informatie

Syntaxis

= FIELDVALUE(waarde; veldnaam)

De syntaxis van de functie FIELDVALUE heeft de volgende argumenten:

Argument

Beschrijving

waarde

Deze functie retourneert alle overeenkomstige velden van het gekoppelde gegevenstype dat is opgegeven in het argument 'waarde'.

veldnaam

De naam van het veld of de namen van de velden waarvan u de waarde uit het gekoppelde gegevenstype wilt ophalen.

Beschrijving

  • De functie FIELDVALUE retourneert alle overeenkomstige velden van het gekoppelde gegevenstype dat is opgegeven in het argument ‘waarde’.

  • De functie FIELDVALUE hoort in de categorie Zoeken en verwijzen van functies.

Voorbeelden

In het volgende eenvoudige voorbeeld haalt u met de formule =FIELDVALUE(A2;"Prijs") de waarde van het veld Prijs op met het gegevenstype Aandelen voor JM Smucker Co.

De aandelenkoers van een bedrijf ophalen met =FIELDVALUE(A2;"Prijs")

Het volgende voorbeeld is een meer typisch voorbeeld voor de functie FIELDVALUE. Hier gebruiken we de functie ALS.FOUT om te controleren op fouten. Als er geen bedrijfsnaam in cel A2 staat en de formule FIELDVALUE een fout oplevert, willen we dat er niets wordt weergegeven (""). Maar als er wel een bedrijfsnaam staat, willen we de prijs van het gegevenstype in A2 ophalen met =ALS.FOUT(FIELDVALUE($A2;B$1);"").

De aandelenkoers van een bedrijf ophalen en fouten negeren met =ALS.FOUT(FIELDVALUE($A2;B$1);"")

U kunt de functie FIELDVALUE gebruiken om via het argument ‘veldnaam’ te verwijzen naar werkbladcellen, wat betekent dat in de bovenstaande formule wordt verwezen naar cel B1 voor Prijs, in plaats van handmatig ‘Prijs’ in te voeren in de formule. 

Opmerkingen

Als u probeert gegevens op te halen uit een niet-bestaand gegevenstypeveld, retourneert de functie FIELDVALUE de fout #VELD!. Dit is bijvoorbeeld het geval als u 'Prijzen' hebt u opgegeven wanneer de werkelijke veldnaam 'Prijs' is. Controleer uw formule om er zeker van te zijn dat u een bestaande veldnaam gebruikt. U kunt een lijst met namen van velden voor een record bekijken door de cel voor de record te selecteren en op Alt+Shift+F10 te drukken.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Gekoppelde records in Excel

Formules schrijven die naar gegevenstypen verwijzen

#VELD!, fout

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×