Externe verwijzingen (koppelingen) naar een celbereik in een andere werkmap maken

U kunt naar de inhoud van cellen in een andere werkmap verwijzen door een externe verwijzing te maken. Een externe verwijzing (ook wel koppeling genoemd) is een verwijzing naar een cel of bereik in een werkblad in een andere Excel-werkmap, of een verwijzing naar een gedefinieerde naam in een andere werkmap. U kunt naar het specifieke celbereik of een gedefinieerde naam voor het celbereik verwijzen, of een naam voor de externe verwijzing definiëren.

Wat wilt u doen?

Meer informatie over externe verwijzingen

Verwijzingen tussen cellen in verschillende werkbladen maken

Externe verwijzingen naar gedefinieerde namen in andere werkmappen maken

Namen definiëren die externe verwijzingen naar cellen in andere werkmappen bevatten

Meer informatie over externe verwijzingen

Externe verwijzingen lijken veel op celverwijzingen, maar er zijn toch een aantal belangrijke verschillen. U gebruikt externe verwijzingen wanneer u met grote hoeveelheden gegevens of complexe formules werkt die over meerdere werkmappen verspreid staan. Externe verwijzingen maakt u op een andere manier dan celverwijzingen. Bovendien worden externe verwijzingen op een andere manier dan celverwijzingen in een cel of op de formulebalk weergegeven.

Waar kunnen externe verwijzingen effectief worden gebruikt?

Externe verwijzingen zijn bijzonder handig wanneer het niet praktisch is om grote werkbladmodellen samen in dezelfde werkmap te bewaren.

  • Gegevens uit verschillende werkmappen samenvoegen      U kunt werkmappen van verschillende gebruikers of afdelingen koppelen en de relevante gegevens in een samenvattingswerkmap integreren. Op die manier hoeft u de samenvattingswerkmap niet handmatig te wijzigen wanneer de bronwerkmappen worden gewijzigd.

  • Verschillende weergaven van uw gegevens maken    U kunt alle gegevens in een of meer bronwerkmappen invoeren en vervolgens een rapportwerkmap maken die alleen externe verwijzingen naar de belangrijke gegevens bevat.

  • Grote, complexe modellen stroomlijnen      Door een gecompliceerd model in een reeks onafhankelijke werkmappen te verdelen, kunt u aan het model werken zonder telkens alle betrokken bladen te openen. Kleinere werkmappen zijn gemakkelijker te wijzigen, worden sneller geopend, opgeslagen en berekend, en nemen bovendien minder geheugen in beslag.

Manieren om externe verwijzingen te maken

Als u een externe verwijzing maakt via een celverwijzing, kunt u vervolgens ook formules toepassen op de gegevens. Door te schakelen tussen de diverse typen celverwijzingen kunt u ook instellen naar welke cellen wordt verwezen wanneer u de externe verwijzing verplaatst. Als u bijvoorbeeld de externe verwijzing verplaatst via een relatieve verwijzing, wordt de gekoppelde cel (of cellen) aangepast aan de nieuwe positie van de koppeling in het werkblad.

Als u een externe verwijzing maakt tussen cellen in verschillende werkmappen, moet u met een naam verwijzen naar de cellen die u wilt koppelen. U kunt een externe verwijzing maken met behulp van een naam die al is gedefinieerd of u kunt de naam definiëren wanneer u de externe verwijzing maakt. Met een naam kunt u de inhoud van de cellen die u koppelt, gemakkelijker onthouden. Externe verwijzingen die gebruikmaken van gedefinieerde namen, worden bij het verplaatsen niet gewijzigd omdat een naam verwijst naar een specifieke cel of een specifiek celbereik. Als u wilt dat een externe verwijzing die gebruikmaakt van een gedefinieerde naam, bij het verplaatsen wordt gewijzigd, kunt u de naam van de externe verwijzing wijzigen of de cellen wijzigen waarnaar de naam verwijst.

Hoe ziet een externe verwijzing naar een andere werkmap er uit?

Formules met externe verwijzingen naar andere werkmappen worden op twee verschillende manieren weergegeven, al naargelang de bronwerkmap (de werkmap die de gegevens voor een formule levert) geopend of gesloten is.

Wanneer de bron geopend is, bevat de externe verwijzing de naam van de werkmap tussen vierkante haakjes ([ ]), gevolgd door de naam van het werkblad, een uitroepteken (!) en de cellen waarvan de formule afhankelijk is. In de volgende formule worden bijvoorbeeld de cellen C10:C25 uit een werkmap met de naam Budget.xls opgeteld.

Externe verwijzing

=SOM([Budget.xlsx]Jaar!C10:C25)

Als de bron niet geopend is, bevat de externe verwijzing het hele pad.

Externe verwijzing

=SOM('C:\Reports\[Budget.xlsx]Jaar'!C10:C25)

Opmerking: Als de naam van het andere werkblad of de andere werkmap niet-alfabetische tekens bevat, moet u de naam (of het pad) tussen enkele aanhalingstekens plaatsen.

In formules met een koppeling naar een gedefinieerde naam in een andere werkmap wordt de naam van deze werkmap gebruikt, gevolgd door een uitroepteken (!) en de gedefinieerde naam. In de volgende formule worden bijvoorbeeld de cellen in een bereik genaamd Verkoop uit een werkmap met de naam Budget.xls opgeteld.

Externe verwijzing

=SOM(Budget.xlsx!Verkoop)

Naar boven

Een externe verwijzing maken tussen cellen in verschillende werkbladen

  1. Open de werkmap waarin de externe verwijzing komt te staan (de doelwerkmap) en de werkmap met de gegevens die u wilt koppelen (de bronwerkmap).

  2. Klik in de bronwerkmap op Opslaan Knopafbeelding op de werkbalk Snelle toegang.

  3. Selecteer de cel of cellen waarin u de externe verwijzing wilt plaatsen.

  4. Typ een gelijkteken (=). Als u berekeningen of functies wilt uitvoeren op de waarde van de externe verwijzing, typt u de operator of functie die vóór de externe verwijzing moet komen.

  5. Schakel over naar de bronwerkmap en klik vervolgens op het werkblad met de cellen die u wilt koppelen.

  6. Selecteer de cel of cellen die u wilt koppelen.

  7. Ga terug naar de doelwerkmap. De verwijzing is toegevoegd aan de bronwerkmap en de cellen die u in de vorige stap hebt geselecteerd.

  8. In het doelwerkblad kunt u zo nodig de formule wijzigen.

  9. Druk op Ctrl+Shift+Enter.

Naar boven

Externe verwijzingen naar gedefinieerde namen in andere werkmappen maken

  1. Open de werkmap waarin de externe verwijzing komt te staan (de doelwerkmap) en de werkmap met de gegevens die u wilt koppelen (de bronwerkmap).

  2. Klik in de bronwerkmap op Opslaan Knopafbeelding op de werkbalk Snelle toegang.

  3. Selecteer de cel of cellen waarin u de externe verwijzing wilt plaatsen.

  4. Typ een gelijkteken (=). Als u berekeningen of functies wilt uitvoeren op de waarde van de externe verwijzing, typt u de operator of functie die vóór de externe verwijzing moet komen.

  5. Klik op het tabblad Beeld, in de groep Venster, op Ander venster. Klik op de bronwerkmap en vervolgens op het werkblad met de gegevens die u wilt koppelen.

    Knopafbeelding

  6. Druk op F3 en selecteer vervolgens de naam die u wilt koppelen.

Naar boven

Namen definiëren die externe verwijzingen naar cellen in andere werkmappen bevatten

  1. Open de doelwerkmap en de bronwerkmap.

  2. Klik op het tabblad Formules in de doelwerkmap in de groep Gedefinieerde namen op Naam bepalen.

    Afbeelding van Excel-lint

  3. Typ in het dialoogvenster Nieuwe naam in het vak Naam een naam voor het bereik.

  4. Verwijder de inhoud van het vak Verwijst naar en laat de cursor in het vak staan.

    Als de naam een formule is, geeft u de formule op en plaatst u vervolgens de cursor op de gewenste plaats voor de externe verwijzing. Typ bijvoorbeeld =SOM() en plaats vervolgens de cursor tussen de haakjes.

  5. Klik op het tabblad Beeld, in de groep Venster, op Ander venster. Klik op de bronwerkmap en vervolgens op het werkblad met de gegevens die u wilt koppelen.

    Knopafbeelding

  6. Selecteer de cel of het celbereik dat u wilt koppelen.

  7. Klik in het dialoogvenster Nieuwe naam op OK.

Naar boven

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×