Een fout #VERW! corrigeren

Een fout #VERW! corrigeren

Opmerking:  We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

De #REF! fout wordt weergegeven wanneer een formule verwijst naar een cel die ongeldig is. Dit gebeurt meestal wanneer cellen die zijn waarnaar wordt verwezen door formules ophalen verwijderd of geplakt op.

Voorbeeld: een #VERW!-fout veroorzaakt doordat er een kolom is verwijderd

In het volgende voorbeeld wordt de formule=SOM(B2;C2;D2) in kolom E gebruikt.

Een formule waarin naar expliciete cellen wordt verwezen zoals =SOM(B2,C2,D2) kan een fout #VERW! veroorzaken als een kolom wordt verwijderd.

Als u wilt verwijderen van kolom B, C of D treedt er een #REF! fout. In dit geval we de kolom C wordt verwijderd (2007 verkoop), en de formule nu leest =SUM(B2,#REF!,C2). Wanneer u expliciete celverwijzingen als volgt gebruiken (waarin u afzonderlijk naar elke cel verwijst, gescheiden door komma's) en verwijderen van een waarnaar wordt verwezen rij of kolom-, Excel kan niet worden omgezet, zodat deze geeft als resultaat de #REF! fout. Dit is de primaire reden waarom expliciete celverwijzingen gebruiken in functies wordt niet aanbevolen.

Voorbeeld van een fout #VERW! veroorzaakt doordat er een kolom is verwijderd

Oplossing

  • Als u rijen of kolommen per ongeluk verwijdert, kunt u direct op de knop Ongedaan maken op de werkbalk Snelle toegang klikken (of op Ctrl+Z drukken) om ze te herstellen.

  • De formule aanpassen zodat deze verwijzing naar een bereik in plaats van afzonderlijke cellen, zoals =SUM(B2:D2) gebruikt. Nu u een kolom in het bereik som kan verwijderen en de formule wordt automatisch aanpassen door Excel. U kunt ook =SUM(B2:B5) voor een som van rijen.

Voorbeeld: VERT.ZOEKEN met onjuiste bereikverwijzingen

In het volgende voorbeeld geeft =VERT.ZOEKEN(A8;A2:D5;5;ONWAAR) als resultaat een #VERW!-fout omdat er wordt gezocht naar een waarde uit kolom 5 die als resultaat kan worden geretourneerd, maar het bereik van de verwijzing is A:D, die uit slechts 4 kolommen bestaat.

Voorbeeld van een formule VERT.ZOEKEN met een ongeldig bereik.  Formule is =VERT.ZOEKEN(A8,A2:D5,5,ONWAAR).  Er is geen vijfde kolom in het bereik VERT.ZOEKEN dus 5 veroorzaakt een fout #VERW!.

Oplossing

Het bereik groter aanpassen of verkleinen van de zoekwaarde kolom zodat deze overeenkomen met het bereik van de verwijzing. =VLOOKUP(a8,a2:E5,5,False) zou een bereik van geldige verwijzing, evenals = VLOOKUP(A8,A2:D5,4,FALSE).

Voorbeeld: INDEX met onjuiste verwijzing voor rijen of kolommen

In dit voorbeeld geeft de formule =INDEX(B2:E5;5;5) een #VERW!-fout als resultaat omdat het bereik van de INDEX uit 4 rijen bij 4 kolommen bestaat, maar de formule vereist dat er een waarde wordt geretourneerd die zich in de vijfde rij en de vijfde kolom bevindt.

Voorbeeld van een INDEX-formule met een verwijzing naar een ongeldig bereik.  Formule is =INDEX(B2:E5,5,5) maar het bereik is alleen 4 rijen bij 4 kolommen.

Oplossing

De rij of kolom verwijzingen aanpassen zodat u in het bereik van INDEX opzoeken. =Index(B2:E5,4,4) zou het resultaat van een geldige retourneren.

Voorbeeld: naar een gesloten werkmap verwijzen met INDIRECT

In het volgende voorbeeld verwijst een INDIRECT-functie naar een werkmap die gesloten is en zo een #VERW!-fout veroorzaakt.

Voorbeeld van een fout #VERW! veroorzaakt omdat INDIRECT verwijst naar een gesloten werkmap.

Oplossing

Open de werkmap waarnaar wordt verwezen

OLE-problemen

Als u een OLE-koppeling (Object Linking and Embedding) hebt gebruikt die een #VERW!-fout veroorzaakt, moet u het programma starten dat door de koppeling wordt aangeroepen.

Opmerking: OLE is een technologie die u kunt gebruiken om gegevens tussen programma's te delen.

DDE-problemen

Als u een onderwerp Exchange DDE (Dynamic Data) hebt gebruikt als resultaat die een #REF! fout, eerste controleren om te controleren of u bent verwijst naar het juiste onderwerp. Als u nog steeds een #REF! fout en controleer de Instellingen voor het Vertrouwenscentrum voor externe inhoud, zoals beschreven in blokkeren of deblokkeren externe inhoud in Office-documenten.

Notitie: Exchange DDE (Dynamic Data)is een gangbaar protocol voor uitwisseling van gegevens tussen Microsoft Windows-programma's.

Problemen met macro 's

Als een functie in een macro wordt ingevoerd in het werkblad die naar een cel boven de functie verwijst en de cel met de functie in rij 1 is, retourneert de functie #REF! omdat er geen cellen boven rij 1. Controleer de functie om te zien als een argument verwijst naar een cel of een bereik van cellen dat ongeldig is. Dit kan vragen om de macro in de Visual Basic Editor (VBE) moet uitvoeren die situatie rekening bewerken.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Foutcontrole gebruiken om fouten in formules te detecteren

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×