Een fout #VERW! corrigeren

Een fout #VERW! corrigeren

Opmerking: We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

In de #REF! -fout wordt aangegeven wanneer een formule naar een ongeldige cel verwijst. Dit gebeurt meestal wanneer cellen waarnaar door formules wordt verwezen, worden verwijderd of worden geplakt.

Voorbeeld: een #VERW!-fout veroorzaakt doordat er een kolom is verwijderd

In het volgende voorbeeld wordt de formule=SOM(B2;C2;D2) in kolom E gebruikt.

Een formule waarin naar expliciete cellen wordt verwezen zoals =SOM(B2,C2,D2) kan een fout #VERW! veroorzaken als een kolom wordt verwijderd.

Als u kolom B, C of D zou verwijderen, zou het een #REF! fouten. In dit geval wordt kolom C (2007 verkoop) verwijderd en wordt de formule nu gelezen = som (B2, #REF!, C2). Wanneer u expliciete celverwijzingen zoals deze gebruikt (waarbij u naar elke cel afzonderlijk verwijst, gescheiden door een komma) en een rij of kolom waarnaar wordt verwezen, verwijdert, kan deze niet worden opgelost, dus wordt de #REF als resultaat gegeven. fouten. Dit is de belangrijkste reden waarom het gebruik van expliciete celverwijzingen in functies niet wordt aanbevolen.

Voorbeeld van een fout #VERW! veroorzaakt doordat er een kolom is verwijderd

Oplossing

  • Als u rijen of kolommen per ongeluk verwijdert, kunt u direct op de knop Ongedaan maken op de werkbalk Snelle toegang klikken (of op Ctrl+Z drukken) om ze te herstellen.

  • Pas de formule zo aan dat er een bereik verwijzing wordt gebruikt in plaats van afzonderlijke cellen, zoals = som (B2: D2). U kunt nu een kolom binnen het bereik van de som verwijderen, waarna de formule automatisch wordt aangepast. U kunt ook = Sum (B2: B5) gebruiken voor een som van rijen.

Voorbeeld: VERT.ZOEKEN met onjuiste bereikverwijzingen

In het volgende voorbeeld geeft =VERT.ZOEKEN(A8;A2:D5;5;ONWAAR) als resultaat een #VERW!-fout omdat er wordt gezocht naar een waarde uit kolom 5 die als resultaat kan worden geretourneerd, maar het bereik van de verwijzing is A:D, die uit slechts 4 kolommen bestaat.

Voorbeeld van een formule VERT.ZOEKEN met een ongeldig bereik.  Formule is =VERT.ZOEKEN(A8,A2:D5,5,ONWAAR).  Er is geen vijfde kolom in het bereik VERT.ZOEKEN dus 5 veroorzaakt een fout #VERW!.

Oplossing

Pas het bereik groter aan of verklein de opzoek waarde van de kolom zodat deze overeenkomt met het verwijzings bereik. = VERT. zoeken (A8; a2: E5; 5; onwaar) is een geldig referentie bereik, zoals = VERT. zoeken (A8; a2: D5; 4; onwaar).

Voorbeeld: INDEX met onjuiste verwijzing voor rijen of kolommen

In dit voorbeeld geeft de formule =INDEX(B2:E5;5;5) een #VERW!-fout als resultaat omdat het bereik van de INDEX uit 4 rijen bij 4 kolommen bestaat, maar de formule vereist dat er een waarde wordt geretourneerd die zich in de vijfde rij en de vijfde kolom bevindt.

Voorbeeld van een INDEX-formule met een verwijzing naar een ongeldig bereik.  Formule is =INDEX(B2:E5,5,5) maar het bereik is alleen 4 rijen bij 4 kolommen.

Oplossing

Pas de rij-of kolom verwijzingen aan, zodat deze zich in het opzoek bereik van de INDEX bevinden. = Index (B2: E5, 4, 4) zou een geldig resultaat retour neren.

Voorbeeld: naar een gesloten werkmap verwijzen met INDIRECT

In het volgende voorbeeld verwijst een INDIRECT-functie naar een werkmap die gesloten is en zo een #VERW!-fout veroorzaakt.

Voorbeeld van een fout #VERW! veroorzaakt omdat INDIRECT verwijst naar een gesloten werkmap.

Oplossing

Open de werkmap waarnaar wordt verwezen. Er treedt dezelfde fout op als u verwijst naar een gesloten werkmap met een dynamische matrix functie.

Problemen met OLE

Als u een OLE-koppeling (Object Linking and Embedding) hebt gebruikt die een #VERW!-fout veroorzaakt, moet u het programma starten dat door de koppeling wordt aangeroepen.

Opmerking: OLE is een technologie die u kunt gebruiken om gegevens tussen programma's te delen.

DDE-problemen

Als u een DDE-onderwerp (Dynamic Data Exchange) hebt gebruikt dat een #REF retourneert! fout, eerst controleren om te controleren of u naar het juiste onderwerp verwijst. Als u nog steeds een #REF ontvangt! fout: Controleer de instellingen van het vertrouwens centrum voor externe inhoud, zoals wordt beschreven in externe inhoud blok keren of deblokkeren in Office-documenten.

Opmerking: DDE (Dynamic Data Exchange)is een vastgesteld protocol voor het uitwisselen van gegevens tussen micro soft Windows-Program ma's.

Problemen met macro 's

Als een macro een functie op het werk blad invoert die verwijst naar een cel boven de functie en de cel met de functie zich in rij 1 bevindt, wordt #REF als resultaat gegeven. omdat er geen cellen boven rij 1 staan. Controleer de functie om te zien of een argument verwijst naar een cel of een cellen bereik dat niet geldig is. Mogelijk moet u de macro bewerken in de Visual Basic Editor (VBE) om deze situatie bij te houden.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×