Een fout #VERW! corrigeren

Een fout #VERW! corrigeren

Opmerking: We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

De fout #VERW! wordt weergegeven wanneer een formule verwijst naar een cel die niet geldig is. Dit gebeurt meestal wanneer cellen zijn verwijderd waarnaar door formules wordt verwezen, of als er andere celinhoud overheen is geplakt.

Bijvoorbeeld: #REF! fout veroorzaakt door het verwijderen van een kolom

In het volgende voorbeeld wordt de formule=SOM(B2;C2;D2) in kolom E gebruikt.

Een formule waarin naar expliciete cellen wordt verwezen zoals =SOM(B2,C2,D2) kan een fout #VERW! veroorzaken als een kolom wordt verwijderd.

Als u kolom B, C of D zou verwijderen, treedt er een #VERW!-fout op. In dit geval verwijderen we kolom C (Verkoop 2007). De formule ziet er nu als volgt uit =SOM(B2;#VERW!;C2). Wanneer u expliciete celverwijzingen zoals deze gebruikt (waarin u naar elke cel afzonderlijk verwijst, gescheiden door een komma) en vervolgens een rij of kolom verwijdert, kan Excel de formule niet toepassen, zodat de fout #VERW! optreedt. Dit is de belangrijkste reden waarom expliciete celverwijzingen in functies niet worden aanbevolen.

Voorbeeld van een fout #VERW! veroorzaakt doordat er een kolom is verwijderd

Oplossing

  • Als u rijen of kolommen per ongeluk verwijdert, kunt u direct op de knop Ongedaan maken op de werkbalk Snelle toegang klikken (of op Ctrl+Z drukken) om ze te herstellen.

  • De formule aanpassen zodat deze verwijzing naar een bereik in plaats van afzonderlijke cellen, zoals =SUM(B2:D2) gebruikt. Nu u een kolom in het bereik som kan verwijderen en de formule wordt automatisch aanpassen door Excel. U kunt ook =SUM(B2:B5) voor een som van rijen.

Voorbeeld: VERT.ZOEKEN met onjuiste bereikverwijzingen

In het volgende voorbeeld retourneert =VLOOKUP(A8,A2:D5,5,FALSE) een #REF! fout is omdat deze een waarde wordt gezocht naar return uit kolom 5, maar het bereik van de verwijzing A:D, dat wil alleen 4 kolommen zeggen.

Voorbeeld van een formule met VERT.zoeken met een onjuiste bereik.  Formule = VLOOKU(A8,A2:D5,5,FALSE).  Is er geen vijfde kolom in het bereik van VERT.zoeken, dus 5 een #REF treedt! als resultaat.

Oplossing

Maak het bereik groter of verlaag de kolomzoekwaarde zodat deze overeenkomt met het bereik van de verwijzing. =VERT.ZOEKEN(A8;A2:E5;5;ONWAAR) zou een geldig bereik kunnen zijn, evenals = VERT.ZOEKEN(A8;A2:D5;4;ONWAAR).

Voorbeeld: INDEX met onjuiste verwijzing voor rijen of kolommen

In dit voorbeeld wordt de formule =INDEX(B2:E5,5,5) een #REF! fout omdat het bereik INDEX 4 rijen en kolommen 4 is, maar de formule wordt gevraagd om terug te keren wat staat er in de 5e rij- en 5th kolom.

Voorbeeld van een INDEX-formule met een verwijzing naar een ongeldig bereik.  Formule is =INDEX(B2:E5,5,5) maar het bereik is alleen 4 rijen bij 4 kolommen.

Oplossing

Pas de verwijzingen naar de rij of kolom aan zodat ze in het opzoekbereik INDEX vallen. =INDEX(B2:E5;4;4) zou een geldig resultaat opleveren.

Voorbeeld: naar een gesloten werkmap verwijzen met INDIRECT

Klik in het volgende voorbeeld wordt probeert een functie INDIRECT te verwijzen naar een werkmap die gesloten, veroorzaakt door een #REF! als resultaat.

Voorbeeld van een fout #VERW! veroorzaakt omdat INDIRECT verwijst naar een gesloten werkmap.

Oplossing

Open de werkmap waarnaar wordt verwezen. U zult dezelfde fout tegenkomen als u verwijst naar een gesloten werkmap met een dynamische Matrixfunctie.

OLE-problemen

Als u een koppeling Object Linking and Embedding (OLE) hebt gebruikt als resultaat die een #REF! fout en klik op start het programma waarmee het bellen van de koppeling.

Opmerking: OLE is een technologie die u kunt gebruiken om gegevens tussen programma's te delen.

DDE-problemen

Als u een onderwerp Exchange DDE (Dynamic Data) hebt gebruikt als resultaat die een #REF! fout, eerste controleren om te controleren of u bent verwijst naar het juiste onderwerp. Als u nog steeds een #REF! fout en controleer de Instellingen voor het Vertrouwenscentrum voor externe inhoud, zoals beschreven in blokkeren of deblokkeren externe inhoud in Office-documenten.

Notitie: Exchange DDE (Dynamic Data)is een gangbaar protocol voor uitwisseling van gegevens tussen Microsoft Windows-programma's.

Problemen met macro 's

Als met een macro een functie wordt toegevoegd aan het werkblad die naar een cel boven de functie verwijst en de cel met de functie in rij 1 staat, geeft de functie de fout #VERW! als resultaat omdat boven rij 1 geen cellen staan. Controleer of de functie een argument bevat dat verwijst naar een ongeldige cel of een ongeldig cellenbereik. Wellicht moet de macro dan in VBE (Visual Basic Editor) worden bewerkt, zodat er met deze situatie rekening wordt gehouden.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×