Een databasemodel maken (ook entiteitsrelatiediagram genoemd) in Visio

Een databasemodel maken (ook entiteitsrelatiediagram genoemd) in Visio

Met de sjabloon Databasemodeldiagram kunt u in Visio een nieuw model maken of een bestaande database reverse-engineeren naar een model.

Databasepictogram, pijl en Visio-diagram dat de database voorstelt

In dit artikel wordt beschreven hoe u een databasemodel kunt maken en wat u kunt doen met het model nadat u het hebt gemaakt.

Opmerking: Het databasemodeldiagram is alleen beschikbaar in bepaalde versies van Visio. Zie U kunt de database databasemodelleringsfuncties niet vinden? voor meer informatie.

1: Een databasemodeldiagram starten

Als u geen bestaande database hebt die u als startpunt wilt gebruiken, kunt u beginnen met een leeg databasemodel en uw eigen tabellen en relaties toevoegen.

  1. Selecteer Bestand > Nieuw.

  2. Typ databasemodel in het zoekvak en druk op Enter.

  3. Dubbelklik in de lijst met zoekresultaten op databasemodeldiagram.

    Sjabloon voor databasemodeldiagram.
  4. Selecteer metrische eenheden of Amerikaanse eenhedenen selecteer vervolgens maken.

    De wizard Reverse-engineering wordt meestal automatisch geopend.

  5. Selecteer annuleren om de wizard te sluiten.

  6. Klik op het tabblad Database, in de groep Beheren, op Weergaveopties.

  7. Selecteer in het dialoogvenster Opties voor databasedocumenten de symboolset die u wilt gebruiken en andere opties voor tabel en relaties. Klik vervolgens op OK. Klik op de knop Help in het dialoogvenster voor meer informatie over de verschillende opties.

Als u een database hebt die u wilt modelleren, zodat u deze beter begrijpt of kunt gebruiken als uitgangspunt voor een nieuw model, kunt u de wizard Reverse-engineering toepassen gebruiken om het schema of de structuur van de database op te halen en een nieuw model te bouwen.

Voordat u de wizard start:

  • Als u reverse-engineering wilt toepassen op een Excel, opent u eerst de werkmap en geeft u de groep (of het bereik) van cellen die de kolomkoppen bevat een naam. Als u meer werkbladen wilt gebruiken, hoeft u alleen de groep kolomcellen in elk werkblad te benoemen. Deze bereiken worden in de wizard Reverse-engineering behandeld als tabellen. Zie Namen definiëren en gebruiken in formules voor informatie over het benoemen van een celbereik.

  • Voor de beste resultaten stelt u, voordat u de wizard Reverse-engineering toepassen uitvoert, het standaardstuurprogramma in op de doeldatabase waarop u reverse-engineering wilt toepassen. Deze stap zorgt ervoor dat de wizard de oorspronkelijke gegevenstypen correct toewijst en dat alle code die door de wizard wordt opgehaald, juist wordt weergegeven in het venster Programmacode.

Start de wizard:

  1. Selecteer Bestand > Nieuw.

  2. Typ databasemodel in het zoekvak en druk op Enter.

  3. Dubbelklik in de lijst met zoekresultaten op databasemodeldiagram. Selecteer Maken.

    De wizard Reverse-engineering wordt automatisch geopend.

    Als de wizard niet wordt geopend: Ga naar het tabblad database op het lint van de werkbalk en klik in de groep model op reverse-engineer.

  4. In het eerste scherm van de wizard Reverse-engineering toepassen doet u het volgende:

    1. Selecteer het databasestuurprogramma voor uw databasebeheersysteem (DBMS). Als u het databasestuurprogramma van Visio nog niet hebt gekoppeld aan een bepaalde ODBC-gegevensbron, klikt u op Instellen.

      Opmerking: Als u reverse-engineering toepast op een Excel-werkblad, kiest u het Algemeen ODBC-stuurprogramma.

    2. Selecteer de gegevensbron van de database die u bijwerkt. Als u nog geen gegevensbron voor de bestaande database hebt gemaakt, klikt u op Nieuw om dit nu te doen.

      Wanneer u een nieuwe bron maakt, wordt de naam ervan toegevoegd aan de lijst Gegevensbronnen.

    3. Wanneer u tevreden bent over de instellingen, klikt u op Volgende.

  5. Volg de instructies in alle dialoogvensters met betrekking tot het specifieke stuurprogramma.

    Typ bijvoorbeeld in het dialoogvenster Gegevensbron verbinden de gebruikersnaam en het wachtwoord, en klik vervolgens op OK.

    Opmerking: Als u het algemene ODBC-stuurprogramma gebruikt, wordt mogelijk het foutbericht weergegeven dat de gegevens waarop reverse-engineering is toegepast onvolledig zijn. In de meeste gevallen is dit geen probleem. Klik gewoon op OK en ga verder met de wizard.

  6. Schakel de selectievakjes in voor het type informatie dat u wilt ophalen. Klik vervolgens op Volgende.

    Opmerking: Sommige items zijn mogelijk niet beschikbaar (deze worden grijs weergegeven) omdat niet alle databasebeheersystemen ondersteuning bieden voor alle soorten elementen die met de wizard kunnen worden opgehaald.

  7. Schakel de selectievakjes in voor de tabellen (en weergaven, indien aanwezig) die u wilt ophalen, of klik op Alles selecteren als u ze allemaal wilt ophalen. Klik tot slot op Volgende.

    Opmerking: Als u reverse-engineering toepast op een Excel-werkblad en niets in deze lijst ziet, moet u waarschijnlijk het bereik met cellen opgeven dat de kolomkoppen in uw werkblad bevat. Zie Namen definiëren en gebruiken in formules voor meer informatie.

  8. Als u het selectievakje Opgeslagen procedures hebt ingeschakeld, selecteert u de procedures die u wilt ophalen, of klikt u op Alles selecteren als u ze allemaal wilt ophalen. Klik vervolgens op Volgende.

  9. Selecteer of u de items waarop reverse-engineering is toegepast, automatisch wilt toevoegen aan de huidige pagina.

    Opmerking: De items waarop reverse-engineering is toegepast, worden weergegeven in het venster Tabellen en Weergaven. Als u de tekening niet automatisch wilt laten maken, kunt u de items van het venster Tabellen en Weergaven naar de tekenpagina slepen om het databasemodel handmatig samen te stellen.

  10. Controleer uw selecties om na te gaan of hiermee de gewenste gegevens worden opgehaald. Klik vervolgens op Voltooien.

    Met de wizard worden de geselecteerde gegevens opgehaald en worden in het venster Uitvoer opmerkingen weergegeven over het ophaalproces.

Als u een bestaand VisioModeler-model PLATINUM ERwin-model hebt, kunt u deze mogelijk importeren om een Visio-databasemodeldiagram te maken. Deze mogelijkheid is beperkt tot modelbestanden (.imd) voor woordenlijsten in VisioModeler 2.0 of later en .erx-bestanden in PLATINUM ERwin 2.6, 3.0 en 3.52.

  1. Selecteer Bestand > Nieuw.

  2. Typ databasemodel in het zoekvak en druk op Enter.

  3. Dubbelklik in de lijst met zoekresultaten op databasemodeldiagram. Selecteer Maken.

    De wizard Reverse-engineering wordt automatisch geopend. Selecteer annuleren om de wizard te sluiten.

  4. Klik op het tabblad Database, in de groep Model, op Importeren. Klik vervolgens op het modeltype.

  5. Typ het pad en de bestandsnaam voor het model dat u wilt importeren, of klik op de knop Bladeren om het modelbestand te zoeken. Klik vervolgens op Openen.

  6. Klik in het dialoogvenster Importeren op OK.

    Het bestand wordt geïmporteerd in Visio en de voortgang wordt weergegeven in het venster Uitvoer. De geïmporteerde tabellen worden weergegeven in het venster Tabellen en weergaven.

  7. Selecteer in het venster Tabellen en weergaven de geselecteerde tabellen waarvoor u een model wilt maken, en sleep deze vervolgens naar de tekenpagina.

In dit artikel wordt beschreven hoe u een databasemodel kunt maken en wat u kunt doen met het model nadat u het hebt gemaakt. Als u snel wilt beginnen, selecteert u bestand > nieuw > software en-databaseen selecteer vervolgens databasemodeldiagram.

Opmerking: Het databasemodeldiagram is alleen beschikbaar in bepaalde versies van Visio. Zie U kunt de database databasemodelleringsfuncties niet vinden? voor meer informatie.

1: Een databasemodeldiagram starten

Als u geen bestaande database hebt die u als startpunt wilt gebruiken, kunt u beginnen met een leeg databasemodel en uw eigen tabellen en relaties toevoegen.

  1. Selecteer Bestand > Nieuw.

  2. Selecteer onder sjablooncategorieënsoftware en databaseen selecteer vervolgens databasemodeldiagram.

    Sjabloon voor databasemodeldiagram.

  3. Selecteer aan de rechterkant metrische eenheden of Amerikaanse eenhedenen selecteer vervolgens maken.

  4. Ga op het tabblad database op het lint naar de groep beheren en selecteer weergaveopties.

  5. Selecteer in het dialoogvenster Opties voor databasedocumenten het symboolset dat u wilt gebruiken, en andere opties voor tabellen en relaties. Klik vervolgens op OK.

Als u een database hebt die u wilt modelleren, zodat u deze beter begrijpt of kunt gebruiken als uitgangspunt voor een nieuw model, kunt u de wizard Reverse-engineering toepassen gebruiken om het schema of de structuur van de database op te halen en een nieuw model te bouwen.

Voordat u de wizard start:

  • Als u reverse-engineering wilt toepassen op een Excel, opent u eerst de werkmap en geeft u de groep (of het bereik) van cellen die de kolomkoppen bevat een naam. Als u meer werkbladen wilt gebruiken, hoeft u alleen de groep kolomcellen in elk werkblad te benoemen. Deze bereiken worden in de wizard behandeld als tabellen. Zie Namen definiëren en gebruiken in formules voor informatie over het benoemen van een celbereik.

  • Voor de beste resultaten stelt u, voordat u de wizard Reverse-engineering toepassen uitvoert, het standaardstuurprogramma in op de doeldatabase waarop u reverse-engineering wilt toepassen. Deze stap zorgt ervoor dat de wizard de oorspronkelijke gegevenstypen correct toewijst en dat alle code die door de wizard wordt opgehaald, juist wordt weergegeven in het venster Programmacode.

Start de wizard:

  1. Selecteer Bestand > Nieuw.

  2. Selecteer onder sjablooncategorieënsoftware en databaseen selecteer vervolgens databasemodeldiagram.

  3. Selecteer aan de rechterkant metrische eenheden of Amerikaanse eenhedenen selecteer vervolgens maken.

  4. Ga naar het tabblad database op het lint van de werkbalk en klik in de groep model op reverse-engineer.

  5. In het eerste scherm van de wizard Reverse-engineering doet u het volgende:

    1. Selecteer het databasestuurprogramma van Microsoft Office Visio voor uw databasebeheersysteem (DBMS). Als u het databasestuurprogramma van Visio nog niet hebt gekoppeld aan een bepaalde ODBC-gegevensbron, klikt u op Instellen.

      Opmerking: Als u reverse-engineering toepast op een Excel-werkblad, kiest u het Algemeen ODBC-stuurprogramma.

    2. Selecteer de gegevensbron van de database die u bijwerkt. Als u nog geen gegevensbron voor de bestaande database hebt gemaakt, klikt u op Nieuw om dit nu te doen.

      Wanneer u een nieuwe bron maakt, wordt de naam ervan toegevoegd aan de lijst Gegevensbronnen.

    3. Wanneer u tevreden bent over de instellingen, klikt u op Volgende.

  6. Volg de instructies in alle dialoogvensters met betrekking tot het specifieke stuurprogramma.

    Typ bijvoorbeeld in het dialoogvenster Gegevensbron verbinden een gebruikersnaam en wachtwoord, en klik vervolgens op OK. Als de gegevensbron niet is beveiligd met een wachtwoord, klikt u alleen op OK.

    Opmerking: Als u het algemene ODBC-stuurprogramma gebruikt, wordt mogelijk het foutbericht weergegeven dat de gegevens waarop reverse-engineering is toegepast onvolledig zijn. In de meeste gevallen is dit geen probleem. Klik gewoon op OK en ga verder met de wizard.

  7. Schakel de selectievakjes in voor het type informatie dat u wilt ophalen. Klik vervolgens op Volgende.

    Opmerking: Sommige items zijn mogelijk niet beschikbaar (deze worden grijs weergegeven) omdat niet alle databasebeheersystemen ondersteuning bieden voor alle soorten elementen die met de wizard kunnen worden opgehaald.

  8. Schakel de selectievakjes in voor de tabellen (en weergaven, indien aanwezig) die u wilt ophalen, of klik op Alles selecteren als u ze allemaal wilt ophalen. Klik tot slot op Volgende.

    Opmerking: Als u reverse-engineering toepast op een Excel-werkblad en niets in deze lijst ziet, moet u waarschijnlijk het bereik met cellen opgeven dat de kolomkoppen in uw werkblad bevat. Zie Namen definiëren en gebruiken in formules voor meer informatie.

  9. Als u in stap 5 het selectievakje Opgeslagen procedures hebt ingeschakeld, selecteert u de procedures die u wilt ophalen of klikt u op Alles selecteren als u ze allemaal wilt ophalen. Klik daarna op Volgende.

  10. Selecteer of u de items waarop reverse-engineering is toegepast, automatisch wilt toevoegen aan de huidige pagina.

    Opmerking: De items waarop reverse-engineering is toegepast, worden weergegeven in het venster Tabellen en Weergaven. Als u de tekening niet automatisch wilt laten maken, kunt u de items van het venster Tabellen en Weergaven naar de tekenpagina slepen om het databasemodel handmatig samen te stellen.

  11. Controleer uw selecties om na te gaan of hiermee de gewenste gegevens worden opgehaald. Klik vervolgens op Voltooien.

    Met de wizard worden de geselecteerde gegevens opgehaald en worden in het venster Uitvoer opmerkingen weergegeven over het ophaalproces.

Als u een bestaand VisioModeler-model PLATINUM ERwin-model hebt, kunt u deze mogelijk importeren om een Visio-databasemodeldiagram te maken. Deze mogelijkheid is beperkt tot modelbestanden (.imd) voor woordenlijsten in VisioModeler 2.0 of later en .erx-bestanden in PLATINUM ERwin 2.6, 3.0 en 3.52.

  1. Selecteer Bestand > Nieuw.

  2. Selecteer onder sjablooncategorieënsoftware en databaseen selecteer vervolgens databasemodeldiagram.

  3. Selecteer aan de rechterkant metrische eenheden of Amerikaanse eenhedenen selecteer vervolgens maken.

  4. Selecteer op het tabblad database op het lint, in de groep model, importerenen selecteer vervolgens het bestandstype dat u wilt importeren.

  5. Typ het pad en de bestandsnaam voor het model dat u wilt importeren, of klik op de knop Bladeren om het modelbestand te zoeken. Klik vervolgens op Openen.

  6. Klik in het dialoogvenster Importeren op OK.

    Het bestand wordt geïmporteerd in Visio en de voortgang wordt weergegeven in het venster Uitvoer. De geïmporteerde tabellen worden weergegeven in het venster Tabellen en weergaven.

  7. Selecteer in het venster Tabellen en weergaven de geselecteerde tabellen waarvoor u een model wilt maken, en sleep deze vervolgens naar de tekenpagina.

In dit artikel wordt beschreven hoe u een databasemodel kunt maken en wat u kunt doen met het model nadat u het hebt gemaakt. Als u snel wilt beginnen, selecteert u bestand > nieuw > software en-databaseen selecteer vervolgens databasemodeldiagram.

Opmerking: Het databasemodeldiagram is alleen beschikbaar in bepaalde versies van Visio. Zie U kunt de database databasemodelleringsfuncties niet vinden? voor meer informatie.

1: Een databasemodeldiagram starten

Als u geen bestaande database hebt die u als startpunt wilt gebruiken, kunt u beginnen met een leeg databasemodel en uw eigen tabellen en relaties toevoegen.

  1. Selecteer Bestand > Nieuw > Software en database en selecteer vervolgens een van de twee opties voor het databasemodeldiagram.

  2. Wijs in het menu Database naar Opties en klik op Document.

  3. Selecteer in het dialoogvenster Opties voor databasedocumenten het symboolset dat u wilt gebruiken, en andere opties voor tabellen en relaties. Klik vervolgens op OK.

Als u een database hebt die u wilt modelleren, zodat u deze beter begrijpt of kunt gebruiken als uitgangspunt voor een nieuw model, kunt u de wizard Reverse-engineering toepassen gebruiken om het schema of de structuur van de database op te halen en een nieuw model te bouwen.

Voordat u de wizard start:

  • Als u reverse-engineering wilt toepassen op een Excel, opent u eerst de werkmap en geeft u de groep (of het bereik) van cellen die de kolomkoppen bevat een naam. Als u meer werkbladen wilt gebruiken, hoeft u alleen de groep kolomcellen in elk werkblad te benoemen. Deze bereiken worden in de wizard behandeld als tabellen. Zie Namen definiëren en gebruiken in formules voor informatie over het benoemen van een celbereik.

  • Voor de beste resultaten stelt u, voordat u de wizard Reverse-engineering toepassen uitvoert, het standaardstuurprogramma in op de doeldatabase waarop u reverse-engineering wilt toepassen. Deze stap zorgt ervoor dat de wizard de oorspronkelijke gegevenstypen correct toewijst en dat alle code die door de wizard wordt opgehaald, juist wordt weergegeven in het venster Programmacode.

Start de wizard:

  1. Wijs in het menu Bestand de optie Nieuw aan. Wijs Software en databases aan selecteer vervolgens een van de twee opties onder Databasemodeldiagram.

  2. Klik in het menu Database op Reverse-engineering om de wizard te openen.

  3. In het eerste scherm van de wizard Reverse-engineering doet u het volgende:

    1. Selecteer het Visio-databasestuurprogramma voor uw databasebeheersysteem (DBMS). Als u het databasestuurprogramma van Visio nog niet hebt gekoppeld aan een bepaalde ODBC-gegevensbron, klikt u op Instellen.

      Opmerking: Als u reverse-engineering toepast op een Excel-werkblad, kiest u het Algemeen ODBC-stuurprogramma.

    2. Selecteer de gegevensbron van de database die u bijwerkt. Als u nog geen gegevensbron voor de bestaande database hebt gemaakt, klikt u op Nieuw om dit nu te doen.

      Wanneer u een nieuwe bron maakt, wordt de naam ervan toegevoegd aan de lijst Gegevensbronnen.

    3. Wanneer u tevreden bent over de instellingen, klikt u op Volgende.

  4. Volg de instructies in alle dialoogvensters met betrekking tot het specifieke stuurprogramma.

    Typ bijvoorbeeld in het dialoogvenster Gegevensbron verbinden een gebruikersnaam en wachtwoord, en klik vervolgens op OK. Als de gegevensbron niet is beveiligd met een wachtwoord, klikt u alleen op OK.

    Opmerking: Als u het algemene ODBC-stuurprogramma gebruikt, wordt mogelijk het foutbericht weergegeven dat de gegevens waarop reverse-engineering is toegepast onvolledig zijn. In de meeste gevallen is dit geen probleem. Klik gewoon op OK en ga verder met de wizard.

  5. Schakel de selectievakjes in voor het type informatie dat u wilt ophalen. Klik vervolgens op Volgende.

    Opmerking: Sommige items zijn mogelijk niet beschikbaar (deze worden grijs weergegeven) omdat niet alle databasebeheersystemen ondersteuning bieden voor alle soorten elementen die met de wizard kunnen worden opgehaald.

  6. Schakel de selectievakjes in voor de tabellen (en weergaven, indien aanwezig) die u wilt ophalen, of klik op Alles selecteren als u ze allemaal wilt ophalen. Klik tot slot op Volgende.

    Opmerking: Als u reverse-engineering toepast op een Excel-werkblad en niets in deze lijst ziet, moet u waarschijnlijk het bereik met cellen opgeven dat de kolomkoppen in uw werkblad bevat. Zie Namen definiëren en gebruiken in formules voor meer informatie.

  7. Als u in stap 5 het selectievakje Opgeslagen procedures hebt ingeschakeld, selecteert u de procedures die u wilt ophalen of klikt u op Alles selecteren als u ze allemaal wilt ophalen. Klik daarna op Volgende.

  8. Selecteer of u de items waarop reverse-engineering is toegepast, automatisch wilt toevoegen aan de huidige pagina.

    Opmerking: De items waarop reverse-engineering is toegepast, worden weergegeven in het venster Tabellen en Weergaven. Als u de tekening niet automatisch wilt laten maken, kunt u de items van het venster Tabellen en Weergaven naar de tekenpagina slepen om het databasemodel handmatig samen te stellen.

  9. Controleer uw selecties om na te gaan of hiermee de gewenste gegevens worden opgehaald. Klik vervolgens op Voltooien.

    Met de wizard worden de geselecteerde gegevens opgehaald en worden in het venster Uitvoer opmerkingen weergegeven over het ophaalproces.

Als u een bestaand VisioModeler-model PLATINUM ERwin-model hebt, kunt u deze mogelijk importeren om een Visio-databasemodeldiagram te maken. Deze mogelijkheid is beperkt tot modelbestanden (.imd) voor woordenlijsten in VisioModeler 2.0 of later en .erx-bestanden in PLATINUM ERwin 2.6, 3.0 en 3.52.

  1. Wijs in het menu Bestand de optie Nieuw aan. Wijs Software en databases aan en klik op Databasemodeldiagram.

  2. Wijs in het menu Database naar Importeren. Klik vervolgens op <modeltype> importeren.

  3. Typ het pad en de bestandsnaam voor het model dat u wilt importeren, of klik op de knop Bladeren om het modelbestand te zoeken. Klik vervolgens op Openen.

  4. Klik in het dialoogvenster Importeren op OK.

    Het bestand wordt geïmporteerd in Visio en de voortgang wordt weergegeven in het venster Uitvoer. De geïmporteerde tabellen worden weergegeven in het venster Tabellen en weergaven.

  5. Selecteer in het venster Tabellen en weergaven de geselecteerde tabellen waarvoor u een model wilt maken, en sleep deze vervolgens naar de tekenpagina.

2: De structuur van het diagram verfijnen

Nadat u een databasemodeldiagram hebt gemaakt, is het tijd om het diagram te verfijnen. U kunt de drie belangrijkste onderdelen van een model toevoegen en aanpassen:

  • Entiteiten (of tabellen),

  • Kolommen (waarin feiten voor een tabel worden beschreven) en

  • Relaties (de koppelingen tussen tabellen). Een relatie kan een-op-een, een-op-veel of veel-op-veel zijn.

Selecteer hieronder een kop om instructies te openen over het toevoegen van de functie aan uw model.

De sjabloon databasemodeldiagram bevat twee stencils. Wanneer u begint met het verfijnen van de structuur van uw diagram, werkt u vanaf het stencil dat voor u het meest geschikt is:

  • Gebruik het stencil Relatie tussen eenheden om databases te modelleren die zijn gebaseerd op de SQL92-standaarden en eerdere standaarden.

  • Gebruik het stencil Relaties tussen objecten, dat extra vormen bevat voor het werken met typen, om databases te modelleren die zijn gebaseerd op SQL99-standaarden en latere standaarden.

Gebruik de vorm Entiteit om een tabel te maken in het diagram:

  1. Sleep vanaf het stencil Relatie tussen eenheden of vanaf het stencil Relaties tussen objecten een vorm Entiteit naar de tekening.

  2. Dubbelklik op de vorm om het venster Database-eigenschappen te openen.

  3. Klik onder Categorieën op Definitie en typ een naam voor de tabel.

  4. Klik onder Categorieën op Kolommen, typ een naam en kies een gegevenstype.

  5. Schakel het selectievakje Vereist in voor de kolommen die geen null-waarden mogen bevatten.

  6. Schakel het selectievakje PK (primaire sleutel) in voor kolommen waarmee elke rij in de databasetabel uniek wordt geïdentificeerd.

  7. Klik onder Categorieën op Indexen, Triggers, Controleren of Uitgebreid om deze optionele elementen te maken.

Gebruik het venster Database-eigenschappen om eigenschappen van kolommen toe te voegen of te wijzigen, zoals gegevenstypen en primaire sleutels:

  1. Dubbelklik op de tabel in het diagram.

  2. Klik in het venster Database-eigenschappen, onder Categorieën, op Kolommen.

  3. Klik in de eerste lege cel Fysieke naam en typ een naam.

  4. Als u het gegevenstype voor een kolom wilt wijzigen, klik u in het veld Gegevenstype van de kolom, en selecteert of typt u vervolgens een gegevenstype in de lijst. U kunt bijvoorbeeld decimal(8,2) of char(30) typen.

  5. Als u null-waarden wilt voorkomen, schakelt u het selectievakje Vereist in.

  6. Als u wilt opgeven dat de kolom een primaire sleutel is, schakelt u het selectievakje PK in.

  7. Selecteer een kolom en klik vervolgens op Bewerken als u meer eigenschappen van de kolom wilt zien dan die worden weergegeven wanneer u op de categorie Kolommen klikt.

Relaties maken gebruik van primaire en refererende sleutels om ervoor te zorgen dat kan worden gezocht naar overeenkomsten tussen rijen uit de ene tabel en rijen uit een gerelateerde tabel in een database. U kunt deze relaties weergeven in het diagram. Daarnaast kunt u de bijbehorende kardinaliteit instellen, bijvoorbeeld een-op-veel, en de notatie Hanenpoten, Relationeel of IDEF1X gebruiken. U kunt met deze drie notaties geen veel-op-veel-relaties weergeven in het sjabloon Databasemodeldiagram.

Een relatie maken tussen tabellen:

  1. Zorg ervoor dat beide tabellen zichtbaar zijn in het diagram. Als u reverse-engineering hebt toegepast op het model vanuit een bestaande database, moet u mogelijk een of beide uit het venster Tabellen en weergaven naar de tekenpagina slepen.

  2. Dubbelklik op de gewenste tabel voor het primaire sleutel-gedeelte van de relatie.

  3. Klik in het venster Database-eigenschappen, onder Categorieën, op Kolommen.

  4. Klik in het raster op de kolom die u wilt gebruiken om elke rij in de tabel uniek te identificeren, en schakel het selectievakje PK in om deze in te stellen als de primaire sleutel.

  5. Sleep vanaf het stencil Relatie tussen objecten of vanaf het stencil Relatie tussen eenheden een vorm Relatie naar een lege ruimte op de pagina.

  6. Koppel de hogere kant aan de tabel met de bovenliggende tabel.

  7. Koppel de andere kant aan de onderliggende tabel.

    Als de tweede tabel nog geen kolom bevat met dezelfde naam als de primaire sleutel, voegt de modelmaker deze als refererende sleutel toe aan de tweede tabel.

    Opmerking: Als relatielijnen verdwijnen, klikt u op het tabblad Database, in de groep Beheren, op Weergaveopties. Schakel op het tabblad Relaties, onder Weergeven, het selectievakje Relaties in.

De kardinaliteit van de relatie instellen:

  1. Dubbelklik op de relatie.

  2. Klik in het venster Database-eigenschappen, onder Categorieën, op Diversen.

  3. Kies onder Kardinaliteit de kardinaliteit die het beste past bij de relatie. Voor een-op-veel-relaties is de beste keuze Nul of meer of Eén of meer. Voor een-op-een-relaties is de beste keuze Nul of één of Precies één.

3: Functies toevoegen voor het zoeken en bijwerken van gegevens

Als u andere verfijningen wilt aanbrengen in het diagram (zoals indexen maken, controlecomponenten en triggers), selecteert u een kop hieronder om instructies te openen over het toevoegen van een van de volgende handelingen:

Met indexen wordt de prestatie, of de snelheid, van de database verbeterd tijdens het uitvoeren van een query.

  1. Open het databasemodeldiagram.

  2. Dubbelklik op de tabel waaraan u een index wilt toevoegen, en klik in het venster Database-eigenschappen, in de lijst Categorieën, op Indexen.

  3. Klik op Nieuw.

  4. Typ in het dialoogvenster Index maken een naam voor de index. Klik vervolgens op OK.

  5. Selecteer in de lijst Indextype een optie om een unieke of niet-unieke index te maken.

  6. Selecteer in de lijst Beschikbare kolommen de naam van elke kolom die u wilt opnemen in deze index. Klik vervolgens op Toevoegen >.

  7. Schakel in de lijst Geïndexeerde kolommen het selectievakje Opl in om een index met een oplopende sorteervolgorde te maken. Schakel het selectievakje uit om een index te maken met een aflopende sorteervolgorde.

    Het Databasemodeldiagram is bijgewerkt.

U kunt een weergave beschouwen als een opgeslagen query. Weergaven zijn met name handig als u herhaaldelijk toegang nodig hebt tot dezelfde gegevens uit meerdere tabellen, of als u wilt dat gebruikers de gegevens kunnen zien maar de werkelijke tabellen niet kunnen wijzigen.

Sleep vanaf het stencil Relatie tussen eenheden of vanaf het stencil Relaties tussen objecten een vorm Weergave naar de tekenpagina.

Afhankelijk van uw databasebeheersysteem (DBMS) kunt u mogelijk uitgebreide eigenschappen voor tabellen en weergaven instellen om te bepalen waar deze zijn opgeslagen.

Dubbelklik op de tabel of de weergave waarvoor u uitgebreide eigenschappen wilt instellen, en klik in het venster Database-eigenschappen, in de lijst Categorieën, op Uitgebreid.

Gebruik controlecomponenten om te controleren of de gegevens die zijn ingevoerd in een kolom, zich binnen een bepaald bereik met waarden bevinden. U kunt bijvoorbeeld een controlecomponent maken waarmee wordt vereist dat de gegevens in een kolom met de naam Leeftijd, boven de 65 zijn.

  1. Dubbelklik op de tabel om het dialoogvenster Database-eigenschappen te openen.

  2. Klik onder Categorieën op Kolommen en klik vervolgens op de kolom waaraan u een controlecomponent wilt toevoegen.

  3. Klik op Bewerken.

  4. Voer op het tabblad Controle van het dialoogvenster Kolomeigenschappen de gewenste beperkingen in. Zie Dialoogvenster Kolom- en veldeigenschappen (tabblad Controle) voor meer informatie over de keuzes die u hebt.

    Het controlecomponent wordt onder Lokale code toegevoegd aan het venster Programmacode.

Gebruik opgeslagen procedures en door de gebruiker gedefinieerde functies om codepakketten te maken die u opnieuw kunt gebruiken om dezelfde acties herhaaldelijk uit te voeren. Het belangrijkste verschil tussen deze twee is dat met een door de gebruiker gedefinieerde functie een waarde wordt geretourneerd, terwijl met de opgeslagen procedure code wordt uitgevoerd zonder dat een waarde wordt geretourneerd.

  1. Selecteer op het tabblad Database, in de groep Weergeven/verbergen, het selectievakje Code om het venster Programmacode te openen.

  2. Klik op Globale code en klik vervolgens op Nieuw.

  3. Klik op het tabblad Eigenschappen van de Code-editor op het soort code dat u wilt maken, en typ een naam voor de code.

  4. Typ op het tabblad Hoofdtekst de code en klik vervolgens op OK.

Triggers zorgen ervoor dat SQL-code die u opgeeft in de trigger, wordt uitgevoerd wanneer een bepaalde gebeurtenis plaatsvindt in de database.

  1. Dubbelklik op de tabel om het dialoogvenster Database-eigenschappen te openen.

  2. Klik onder Categorieën op Triggers en klik vervolgens op Toevoegen.

  3. Typ op het tabblad Eigenschappen een naam voor de trigger.

  4. Typ op het tabblad Hoofdtekst de code en klik vervolgens op OK.

    De trigger wordt onder Lokale code toegevoegd aan het venster Programmacode.

Kunt u de databasemodelleringsfuncties niet vinden?

Bij sommige edities van Visio ontbreken enkele of alle databasemodelleringsfuncties:

  • Visio Standard bevat de sjabloon Databasemodeldiagram niet.

  • De Visio Professional- en Premium-edities ondersteunen de reverse-engineering-functies voor de sjabloon Databasemodeldiagram (dat wil zeggen: een bestaande database gebruiken om een model te maken in Visio), maar ze bieden geen ondersteuning voor forward-engineering (dat wil zeggen: een Visio-databasemodel gebruiken om SQL-code te genereren).

  • De volledige suite met databasemodelleringsfuncties, waaronder reverse-engineering en forward-engineering, bevindt zich in Visio for Enterprise Architects. Visio for Enterprise Architects is opgenomen in het MSDN Premium-abonnement. Dit is beschikbaar met Visual Studio Professional en rolgebaseerde Visual Studio Team System-edities.

Als u wilt weten met welke versie van Visio u werkt, klikt u op Over Microsoft Office Visio in het menu Help. De naam van de versie wordt op de eerste regel van de tekst in het dialoogvenster vermeld.

Als u Visio Abonnement 2 gebruikt en meer wilt weten over het toepassen van een databasemodel op een bestaande database, leest u Een bestaande database reverse-engineeren.

Zie ook

Een relatie definiëren in een databasemodeldiagram

Weergaven maken of bewerken in databasemodeldiagrammen

Tabellen en kolommen toevoegen aan databasemodeldiagrammen

Gegevenstypen instellen en bewerken in databasemodeldiagrammen

Hanenpootnotatie weergeven in een databasemodeldiagram

Een index maken of bewerken in een databasemodeldiagram

Referentiële integriteit behouden in databasemodeldiagrammen

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×