De fout #WAARDE! corrigeren in de functies GEMIDDELDE of SOM

Als GEMIDDELDE of SOM verwijst naar cellen die #WAARDE!-fouten bevatten, resulteren de formules in de fout #WAARDE!.

Fout #WAARDE! in GEMIDDELDE

Om de foutwaarden te negeren, maken we een formule die de fouten in het bereik van de verwijzing negeert tijdens de berekening van het gemiddelde met de resterende 'normale' waarden.

Om dit scenario te omzeilen, gebruiken we een combinatie van GEMIDDELDE in combinatie met ALS en ISFOUT om te bepalen of het opgegeven bereik een fout bevat. Voor dit specifieke scenario is een matrixformule vereist:

=GEMIDDELDE(ALS(ISFOUT(B2:D2);"";B2:D2))

Opmerking : Dit is een matrixformule. Deze moet worden ingevoerd met Ctrl+Shift+Enter. In Excel wordt de formule automatisch tussen accolades ({}) geplaatst. Als u deze zelf invoert, wordt in Excel de formule als tekst weergegeven.

Matrixfunctie in GEMIDDELDE voor het oplossen van de fout #WAARDE!

Opmerking : De bovenstaande functie werkt niet alleen voor #WAARDE!, maar ook voor #N/B, #LEEG!, #DEEL/0! en meer.

U kunt SOM ook op dezelfde manier gebruiken:

=SOM(ALS(ISFOUT(B2:D2);"";B2:D2))

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Help ons Excel verbeteren

Hebt u suggesties voor het verbeteren van de volgende versie van Excel? Als dat het geval is, kijk dan eens naar de onderwerpen op Excel User Voice. (Engelstalig)

Zie ook

Een #WAARDE!-fout corrigeren

GEMIDDELDE, functie

SOM, functie

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Foutcontrole gebruiken om fouten in formules te detecteren

Alle Excel-functies (alfabetisch)

Alle Excel-functies (per categorie)

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×