De fout #WAARDE! corrigeren in de functie TEKST.SAMENVOEGEN

Belangrijk: In Excel 2016, Excel Mobile en Excel Online is TEKST.SAMENVOEGEN vervangen door de functie TEKST.SAMENV. Hoewel de functie TEKST.SAMENVOEGEN nog steeds beschikbaar is voor compatibiliteit met eerdere versies, kunt u beter TEKST.SAMENV gebruiken omdat deze functie meer mogelijkheden heeft.

De fout #WAARDE! komt vaak voor bij TEKST.SAMENVOEGEN als u een tekenreeks maakt waarin een celverwijzing is opgenomen die een fout, zoals #WAARDE!, bevat.

In het volgende voorbeeld willen we D2, E2 en F2 samenvoegen, waarbij E2 een #WAARDE!-fout bevat.

#WAARDE!-fout in TEKST.SAMENVOEGEN

Door de fout in E2 wordt de fout #WAARDE! weergegeven. Voor de juiste werking van de functie, moet u de fout vervangen door een andere waarde dan de fout. U kunt een formule maken waarmee wordt gecontroleerd op fouten in de celverwijzing. Als er een fout wordt geconstateerd, kunt u de tekenreeks weergeven, waarbij een 0 wordt weergegeven in plaats van de fout (of u kunt 0 vervangen door uw eigen tekst, maar dan moet u de tekst wel tussen aanhalingstekens plaatsen: 'Uw tekst').

De volgende formule werkt bijvoorbeeld goed:

=ALS(ISFOUT(E2);TEKST.SAMENVOEGEN(D2;" ";0;" ";F2))

De functies ALS en ISFOUT als tijdelijke oplossing voor het samenvoegen van een tekenreeks met de fout #WAARDE!

Hoe werkt dit? In de functie ALS wordt gebruikgemaakt van de functie ALS.FOUT om te bepalen of E2 een fout bevat. Als dit het geval is, worden met de functie TEKST.SAMENVOEGEN de waarden in D2, E2 en F2 gecombineerd (de functie vervangt de fout door een 0) en wordt de resulterende tekenreeks weergegeven. In de formule worden ook spaties (" ") gebruikt om de waarden te scheiden.

De fout #WAARDE! oplossen met TEKST.SAMENVOEGEN in Excel 2003 en oudere versies

Als de fout #WAARDE! wordt weergegeven in Office Excel 2003 of oudere versies, schakelt u de optie Alternatieve formule-evaluatie in Excel uit. Volg de stappen in #WAARDE!-fout bij het samenvoegen van cellen om het probleem op te lossen.

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Help ons Excel verbeteren

Hebt u suggesties voor het verbeteren van de volgende versie van Excel? Als dat het geval is, kijk dan eens naar de onderwerpen op Excel User Voice. (Engelstalig)

Zie ook

Een #WAARDE!-fout corrigeren

TEKST.SAMENVOEGEN, functie

TEKST.SAMENV, functie

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Foutcontrole gebruiken om fouten in formules te detecteren

Alle Excel-functies (alfabetisch)

Alle Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×