De fout #WAARDE! corrigeren in de functie SOMPRODUCT

Dit onderwerp gaat over veelvoorkomende scenario's van de #WAARDE!-fout bij het werken met SOMPRODUCT.

Probleem: De matrixargumenten hebben niet dezelfde dimensie

Alle matrixargumenten moeten dezelfde dimensie hebben. Als dit niet het geval is, wordt de fout #WAARDE! weergegeven. Als matrix 1 bijvoorbeeld verwijst naar een bereik van 3 rijen en 2 kolommen, moet matrix 2 ook overeenkomen met hetzelfde bereik.

De SOMPRODUCT-formule die een fout veroorzaakt is =SOMPRODUCT(D2:D13;E2:E10): E10 moet worden gewijzigd in E13, zodat dit overeenkomt met het eerste bereik.
  • =SOMPRODUCT(D2:D13;E2:E10)

Mislukt omdat de bereiken waarnaar wordt verwezen, niet hetzelfde aantal rijen bevatten (13 in het eerste bereik, maar slechts 10 in het tweede bereik).

Oplossing: Wijzig de formule in:

  • =SOMPRODUCT(D2:D13;E2:E13)

Zodat beide bereiken hetzelfde aantal begin- en eindrijnummers hebben. Voer de formule vervolgens opnieuw uit.

Los de #WAARDE!-fout in de gegevens op om de SOMPRODUCT-fout op te lossen

Probleem: Een of meer cellen in het bereik bevatten tekst

Als een of meer cellen in het bereik waarnaar wordt verwezen, tekst bevatten of zijn opgemaakt als het gegevenstype Tekst, wordt de fout #WAARDE! weergegeven. De tekst kan het resultaat zijn van een berekening van een andere formule, of de cel is mogelijk niet juist opgemaakt.

De formule in cel E15 bevat een #WAARDE!-fout omdat kolom E een #WAARDE!-fout bevat.

Oplossing: Controleer de cellen die tekst bevatten of die zijn opgemaakt als tekst en stel deze in op het juiste gegevenstype.

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Help ons Excel verbeteren

Hebt u suggesties voor het verbeteren van de volgende versie van Excel? Als dat het geval is, kijk dan eens naar de onderwerpen op Excel User Voice. (Engelstalig)

Zie ook

Een #WAARDE!-fout corrigeren

SOMPRODUCT, functie

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Foutcontrole gebruiken om fouten in formules op te sporen

Alle Excel-functies (alfabetisch)

Alle Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×