De fout #WAARDE! corrigeren in de functie AANTAL.ALS/AANTALLEN.ALS

In dit onderwerp worden de meestvoorkomende oorzaken van de fout #WAARDE! in de functies AANTAL.ALS en AANTALLEN.ALS beschreven.

Probleem: De formule verwijst naar cellen in een gesloten werkmap

Als de functie AANTAL.ALS of AANTALLEN.ALS verwijst naar een cel of celbereik in een gesloten werkmap wordt de fout #WAARDE! als resultaat gegeven.

Opmerking: Dit probleem treedt ook wel op bij een aantal andere Excel-functies, waaronder SOM.ALS, SOMMEN.ALS en AANTAL.LEGE.CELLEN. Zie SOM.ALS, AANTAL.ALS en AANTAL.LEGE.CELLEN geven de fout #WAARDE! als resultaat voor meer informatie.

Oplossing: Open de gekoppelde werkmap die in de formule is aangegeven en druk op F9 om de formule te vernieuwen.

U kunt dit probleem omzeilen door de functies SOM en ALS in een matrixformule te combineren. Zie SOM.ALS, AANTAL.ALS en AANTAL.LEGE.CELLEN geven de fout #WAARDE! als resultaat voor meer informatie.

Probleem: De tekenreeks bevat meer dan 255 tekens

Oplossing: Kort de tekenreeks in, indien mogelijk. Als u deze niet kunt inkorten, gebruikt u de functie TEKST.SAMENVOEGEN of de operator ampersand (&) om de waarde in meerdere tekenreeksen op te splitsen. Bijvoorbeeld:

  • =AANTAL.ALS(B2:B12;"lange tekenreeks"&"een andere lange tekenreeks")

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Help ons Excel verbeteren

Hebt u suggesties voor het verbeteren van de volgende versie van Excel? Als dat het geval is, kijk dan eens naar de onderwerpen op Excel User Voice. (Engelstalig)

Zie ook

De fout #WAARDE! corrigeren

AANTAL.ALS, functie

AANTALLEN.ALS, functie

IF function – nested formulas and avoiding pitfalls (ALS, functie: geneste formules en valkuilen vermijden)

Geavanceerde ALS-functies

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Veelvoorkomende fouten in formules corrigeren met foutcontrole

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×