De fout #N/B corrigeren

De fout #N/B corrigeren

De fout #N/B geeft meestal aan dat een formule iets niet kan vinden waarnaar wordt gezocht.

Beste oplossing

De meest voorkomende oorzaak van de fout #N/B is de functie VERT.ZOEKEN, HORIZ.ZOEKEN, ZOEKEN of VERGELIJKEN als een formule een waarde waarnaar wordt verwezen niet kan vinden. Bijvoorbeeld wanneer de opzoekwaarde niet in de brongegevens bestaat.

Opzoekwaarde bestaat niet  Formule in cel E2 is =VERT.ZOEKEN(D2,$D$6:$E$8,2,ONWAAR).  De waarde Banaan is niet gevonden, dus de formule retourneert een fout #N/B.
Item is niet gevonden in de brongegevens

In dit geval komt 'Banaan' niet voor in de opzoektabel, dus retourneert VERT.ZOEKEN een fout #N/B.

Oplossing: Controleer of de waarde die wordt opgezocht bestaat in de brongegevens, of gebruik foutafhandeling zoals ALS.FOUT in de formule. Voorbeeld: =ALS.FOUT(FORMULE(),0) die staat voor:

  • =ALS(uw formule resulteert in een fout, wordt 0 weergegeven, anders wordt het resultaat van de formule weergegeven)

U kunt “” gebruiken om niets weer te geven of uw eigen tekst gebruiken: = ALS.FOUT(FORMULE(),”Foutbericht hier”)

Als u niet zeker weet wat u op dit punt moet doen of welke soort hulp u nodig hebt, kunt u zoeken naar soortgelijke vragen op het forum van de Excel-community of zelf een vraag publiceren.

Koppeling naar het forum van de Excel-community

Als u verder wilt gaan, dan bevat de volgende controlelijst stappen om na te gaan wat er in uw formules kan zijn misgegaan.

De opzoekwaarde en de brongegevens zijn van verschillende typen. U probeert bijvoorbeeld VERT.ZOEKEN te laten verwijzen naar een getal, maar het brongegeven is opgeslagen als tekst.

Verkeerde waardetypen.  Voorbeeld van een VERT.ZOEKEN-formule die fout #N/B retourneert omdat het opzoekitem is opgemaakt als een getal, maar de opzoektabel is opgemaakt als tekst.
De fout #N/B veroorzaakt door verschillende gegevenstypen

Oplossing: Zorg ervoor dat de gegevenstypen dezelfde zijn. U kunt de celopmaak controleren door een cel of celbereik te selecteren, met de rechtermuisknop te klikken en Celeigenschappen > Getal te selecteren (of op Ctrl+1 te drukken), en de getalnotatie indien nodig te wijzigen.

Het dialoogvenster Celeigenschappen met het tabblad Getal geopend en de optie Tekst geselecteerd

Tip: Als u een opmaakwijziging voor een hele kolom wilt afdwingen, past u eerst de opmaak toe die u wilt en gebruikt u vervolgens Gegevens > Tekst naar kolommen > Voltooien.

U kunt de functie SPATIES.WISSEN gebruiken om voorloop- of volgspaties te verwijderen. In het volgende voorbeeld is SPATIES.WISSEN genest binnen de functie VERT.ZOEKEN om de voorloopspaties te verwijderen uit de namen in A2:A7 en de afdelingsnaam te retourneren.

VERT.ZOEKEN gebruiken met SPATIES.WISSEN in een matrixformule om voorloopspaties en volgspaties te verwijderen.  De formule in cel E3 is {=VERT.ZOEKEN(D2,SPATIES.WISSEN(A2:B7),2,ONWAAR)} en moet worden ingevoerd met Ctrl+Shift+Enter.

{=VERT.ZOEKEN(D2,SPATIES.WISSEN(A2:B7),2,ONWAAR)}

Opmerking: Dit is een matrixformule die moet worden ingevoerd met Ctrl+Shift+Enter. De formule wordt automatisch tussen accolades {} geplaatst. Als u die zelf probeert in te voeren, wordt de formule in Excel weergegeven als tekst.

Standaard moeten functies voor het zoeken van gegevens in tabellen worden gesorteerd in oplopende volgorde. De werkbladfuncties VERT.ZOEKEN en HORIZ.ZOEKEN bevatten een argument benaderen die de functie instrueert om naar een exacte overeenkomst te zoeken, ook als de tabel niet is gesorteerd. Als u een exacte overeenkomst zoekt, stelt u het argument benaderen in op ONWAAR. Houd er rekening mee dat als u WAAR gebruikt, waarmee de functie wordt geïnstrueerd om te zoeken naar een niet-geheel exacte overeenkomst, dit niet alleen kan leiden tot een fout #N/B maar ook tot onjuiste resultaten, zoals te zien is in het volgende voorbeeld.

Voorbeeld van hoe het gebruik van VERT.ZOEKEN met het argument benaderen ingesteld op WAAR, onjuiste resultaten kan opleveren.
VERT.ZOEKEN mislukt vanwege het gebruik van het argument niet-geheel exacte overeenkomst in een niet-gesorteerde tabel

In dit voorbeeld geeft niet alleen 'Banaan' een #N/B-fout als resultaat, maar wordt voor 'Peer' de verkeerde prijs geretourneerd. Dit wordt veroorzaakt door gebruik van het argument TRUE, waarmee wordt aangegeven dat de functie VERT.ZOEKEN moet zoeken naar een niet-geheel exacte overeenkomst in plaats van naar een exacte overeenkomst. Er is niets dat lijkt op ‘Banaan’ en ‘Peer’ komt alfabetisch vóór 'Perzik'. Door in dit geval VERT.ZOEKEN te gebruiken met het argument ONWAAR, wordt de juiste prijs voor 'Peer' geretourneerd, maar resulteert 'Banaan' nog steeds in fout #N/B, omdat er geen overeenkomende 'Banaan' in de opzoeklijst voorkomt.

Als u de functie VERGELIJKEN gebruikt, wijzigt u de waarde van het argument criteriumtype_getal om de sorteervolgorde van de tabel aan te geven. Als u een exacte overeenkomst wilt vinden, stelt u het argument criteriumtype_getal in op 0 (nul).

U kunt dit oplossen door ervoor te zorgen dat het bereik waarnaar wordt verwezen in de matrixformule hetzelfde aantal rijen en kolommen heeft als het bereik met cellen waarin de matrixformule is ingevoerd. Een andere oplossing is om de matrixformule in te voeren in minder of meer cellen om zo het bereik in overeenstemming te brengen met de bereikverwijzing in de formule.

In dit voorbeeld verwijst cel E2 naar niet-overeenkomende bereiken:

Voorbeeld van een matrixformule met een #N/B-fout door niet-overeenkomende bereikverwijzingen.  De formule in cel E2 is {=SOM(ALS(A2:A11=D2,B2:B5))} en moet worden ingevoerd met Ctrl+Shift+Enter.

{=SOM(ALS(A2:A11=D2,B2:B5))}

Om de formule correct te laten berekenen moet deze zodanig worden gewijzigd dat beide bereiken verwijzen naar rijen 2 - 11.

{=SOM(ALS(A2:A11=D2,B2:B11))}

Opmerking: Dit is een matrixformule die moet worden ingevoerd met Ctrl+Shift+Enter. De formule wordt automatisch tussen accolades {} geplaatst. Als u die zelf probeert in te voeren, wordt de formule in Excel weergegeven als tekst.

Voorbeeld van #N/B ingevoerd in cellen, waardoor een SOM-formule niet correct wordt berekend.

In dit geval hebben Mei-December de waarde #N/B, zodat het totaal niet kan worden berekend en in plaats daarvan een fout #N/B wordt geretourneerd .

U kunt dit oplossen door de formulesyntaxis te controleren van de gebruikte functie en alle vereiste argumenten in te voeren in de formule die de fout oplevert. Hiervoor moet u mogelijk de Visual Basic Editor (VBE) gebruiken om de functie te controleren. U kunt de VBE openen op het tabblad Ontwikkelaars of met Alt+F11.

U lost dit op door te controleren of de werkmap met de functie is geopend en of de functie juist werkt.

U kunt dit oplossen door te controleren of de argumenten in de functie juist zijn en in de goede volgorde staan.

U kunt dit oplossen door op Ctrl+Alt+F9 te drukken om het blad opnieuw te berekenen

U kunt de wizard Functie gebruiken als u niet zeker bent van de juiste argumenten. Selecteer de cel met de betreffende formule, ga naar het tabblad Formule op het lint en klik op Functie invoegen.

De knop Functie invoegen.

De Wizard wordt automatisch door Excel geladen:

Voorbeeld van het dialoogvenster wizard Formule.

Als u op een argument klikt, geeft Excel de juiste informatie daarvoor weer.

#N/B kan ook handig zijn! #N/B wordt vaak gebruikt wanneer gegevens zoals die in het volgende voorbeeld worden gebruikt in grafieken, omdat #N/B-waarden niet worden uitgezet in een grafiek. Dit zijn voorbeelden van hoe een grafiek eruitziet met 0-waarden en met #N/B.

Voorbeeld van een lijndiagram waarin 0-waarden zijn uitgezet.

In het vorige voorbeeld ziet u dat de 0-waarden zijn uitgezet en worden weergegeven als een vlakke lijn onderin de grafiek, die vervolgens omhoog schiet naar het totaal. In het volgende voorbeeld zijn de 0-waarden vervangen door #N/B.

Voorbeeld van een lijndiagram waarin #N/B-fouten niet zijn uitgezet.

Raadpleeg de onderstaande onderwerpen voor meer informatie over een fout #N/B in een specifieke functie:

Naar boven

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Tekstnotaties van getallen converteren naar getalnotatie

VERT.ZOEKEN, functie

HORIZ.ZOEKEN, functie

ZOEKEN, functie

VERGELIJKEN, functie

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Foutcontrole gebruiken om fouten in formules op te sporen

Excel-sneltoetsen en -functietoetsen voor Windows

Sneltoetsen in Excel 2016 voor Mac

Alle Excel-functies (alfabetisch)

Alle Excel-functies (per categorie)

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×