ALS.FOUT, functie

In dit artikel worden de syntaxis van de formule en het gebruik van de functie ALS.FOUT in Microsoft Excel beschreven.

Beschrijving

Geeft een opgegeven waarde als resultaat als een formule een foutwaarde als resultaat heeft. Als dat niet het geval is, wordt het resultaat van de formule weergegeven. Gebruik de functie ALS.FOUT voor het opsporen en oplossen van fouten in een formule.

Syntaxis

ALS.FOUT(waarde;waarde_indien_fout)

De syntaxis van de functie ALS.FOUT heeft de volgende argumenten:

  • waarde    Vereist. Het argument dat op fouten wordt gecontroleerd.

  • waarde_indien_fout    Vereist. De waarde die moet worden geretourneerd als de formule een foutwaarde als resultaat geeft. De volgende fouttypen kunnen als resultaat worden gegeven: #N/B, #WAARDE!, #VERW!, #DEEL/0!, #GETAL!, #NAAM? of #LEEG!.

Opmerkingen

  • Als waarde of waarde_indien_fout een lege cel is, behandelt ALS.FOUT deze als een lege tekenreekswaarde ("").

  • Als waarde een matrixformule is, retourneert ALS.FOUT een matrix van resultaten voor elke cel in het bereik dat is opgegeven in waarde. Zie het tweede voorbeeld hierna.

Voorbeelden

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. U kunt de resultaten van formules weergeven door de formules te selecteren en op F2 en vervolgens op Enter te drukken. Desgewenst kunt u de kolombreedte wijzigen om alle gegevens te zien.

Geprojecteerde verkopen

Gerealiseerde verkopen

210

35

55

0

23

Formule

Beschrijving

Resultaat

=ALS.FOUT(A2/B2; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule (210 delen door 35), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

6

=ALS.FOUT(A3/B3; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule (55 delen door 0), wordt een 'delen door 0'-fout gevonden en wordt waarde_indien_fout als resultaat gegeven.

Fout in berekening

=ALS.FOUT(A4/B4; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule ("" delen door 23), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

0

Voorbeeld 2

Geprojecteerde verkopen

Gerealiseerde verkopen

Verhouding

210

35

6

55

0

Fout in berekening

23

0

Formule

Beschrijving

Resultaat

=C2

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het eerste element van de matrix (A2/B2 of 210 delen door 35), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

6

=C3

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het tweede element van de matrix (A3/B3 of 55 delen door 0), wordt een 'delen door 0'-fout gevonden en wordt waarde_indien_fout als resultaat gegeven.

Fout in berekening

=C4

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het derde element van de matrix (A4/B4 of "" delen door 23), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

0

Opmerking: De formule in het voorbeeld moet als matrixformule worden ingevoerd. Kopieer het voorbeeld eerst naar een leeg werkblad. Selecteer vervolgens het bereik C2:C4, druk op F2 en druk daarna op Ctrl+Shift+Enter.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×