ALS.FOUT, functie

U kunt de functie als. fout gebruiken om fouten in een formule te onderscheppen en te verwerken. Als. fout retourneert een waarde die u opgeeft als een formule een fout oplevert. anders wordt het resultaat van de formule als resultaat gegeven.

Syntaxis

ALS.FOUT(waarde;waarde_indien_fout)

De syntaxis van de functie ALS.FOUT heeft de volgende argumenten:

  • waarde    Vereist. Het argument dat op fouten wordt gecontroleerd.

  • waarde_indien_fout    Verplicht. De te retourneren waarde als de formule een fout oplevert. De volgende fouttypen worden geëvalueerd: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? of #NULL!.

Opmerkingen

  • Als waarde of waarde_indien_fout een lege cel is, behandelt als. fout dit als een lege tekenreekswaarde ("").

  • Als waarde een matrixformule is, retourneert als. fout een matrix van resultaten voor elke cel in het bereik dat is opgegeven bij waarde. Zie het tweede voorbeeld hierna.

Voorbeelden

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Om resultaten van formules weer te geven, selecteert u deze, drukt u op F2 en drukt u vervolgens op Enter.

Geprojecteerde verkopen

Gerealiseerde verkopen

210

35

55

0

19

Formule

Beschrijving

Resultaat

=ALS.FOUT(A2/B2; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule (210 delen door 35), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

6

=ALS.FOUT(A3/B3; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule (55 delen door 0), wordt een 'delen door 0'-fout gevonden en wordt waarde_indien_fout als resultaat gegeven.

Fout in berekening

=ALS.FOUT(A4/B4; "Fout in berekening")

Hiermee wordt gecontroleerd op een fout in het eerste argument van de formule ("" delen door 23), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

0

Voorbeeld 2

Geprojecteerde verkopen

Gerealiseerde verkopen

Verhouding

210

35

6

55

0

Fout in berekening

19

0

Formule

Beschrijving

Resultaat

=C2

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het eerste element van de matrix (A2/B2 of 210 delen door 35), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

6

=C3

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het tweede element van de matrix (A3/B3 of 55 delen door 0), wordt een 'delen door 0'-fout gevonden en wordt waarde_indien_fout als resultaat gegeven.

Fout in berekening

=C4

Hiermee wordt gecontroleerd op een fout in de formule in het eerste argument van het derde element van de matrix (A4/B4 of "" delen door 23), wordt geen fout gevonden en wordt de uitkomst van de formule als resultaat gegeven.

0

Opmerking: als u een actuele versie van Office 365hebt, kunt u de formule in de cel linksboven in het uitvoerbereik invoeren en vervolgens op ENTER drukken om de formule te bevestigen als een dynamische matrixformule. Anders moet de formule worden ingevoerd als een verouderde matrixformule door eerst het uitvoerbereik te selecteren, de formule in de cel linksboven in het uitvoerbereik te selecteren en vervolgens op CTRL + SHIFT + ENTER te drukken om deze te bevestigen. In Excel worden de accolades aan het begin en het einde van de formule voor u ingevoegd. Zie Richtlijnen en voorbeelden van matrixformules voor meer informatie over matrixformules.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Opmerking:  Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor je is. Wil je ons laten weten of deze informatie nuttig is? Hier is het Engelstalige artikel ter referentie.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×