Voorwaardelijke formules maken

Vaak dient u bij het uitvoeren van taken te controleren of voorwaarden waar of onwaar zijn en dient u logische vergelijkingen te maken tussen expressies. U kunt de functies EN, OF, NIET en ALS gebruiken om voorwaardelijke formules te maken.

De functie ALS heeft bijvoorbeeld de volgende argumenten.

formule met de if functie

Formule waarin de functie ALS wordt gebruikt

Knopafbeelding  logische_test: de voorwaarde die u wilt controleren.

Bijschrift 2  waarde_als_waar: de waarde die moet worden weergegeven als aan de voorwaarde wordt voldaan.

Knopafbeelding  waarde_als_onwaar: de waarde die moet worden weergegeven als niet aan de voorwaarde wordt voldaan.

Zie Een formule maken of verwijderen voor meer informatie over het maken van formules.

Wat wilt u doen?

Een voorwaardelijke formule maken die een logische waarde (WAAR of ONWAAR) oplevert

Een voorwaardelijke formule maken die tot een andere berekening leidt of tot andere waarden dan WAAR of ONWAAR

Een voorwaardelijke formule maken die een logische waarde (WAAR of ONWAAR) oplevert

Gebruik de functies EN, OF en NIET alsmede operatoren om deze taak uit te voeren, zoals in het volgende voorbeeld.

Voorbeeld

De voorbeelden zijn mogelijk beter te begrijpen als u deze naar een leeg werkblad kopieert.

Hoe kopieer ik een voorbeeld?

  1. Selecteer het voorbeeld in dit artikel.

    Belangrijk : Selecteer geen rij- of kolomkoppen.

    een voorbeeld selecteren in de help in Excel 2013 voor Windows

    Een voorbeeld in een Help-onderwerp selecteren

  2. Druk op CTRL+C.

  3. Maak een lege werkmap of leeg werkblad in Excel.

  4. SeIecteer cel A1 in het werkblad en druk op CTRL+V.

Belangrijk : Als u wilt dat het voorbeeld goed werkt, moet u het in cel A1 van het werkblad plakken.

  1. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook op het tabblad Formules in de groep Formules controleren op de knop Formules weergeven klikken.

Nadat u het voorbeeld naar een leeg werkblad hebt gekopieerd, kunt u het naar eigen inzicht aanpassen.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Gegevens

15

9

8

Raderen

Apparaatjes

Formule

Beschrijving (resultaat)

=EN(A2>A3; A2<A4)

Bepaalt of de waarde in cel A2 groter is dan de waarde in A3 en of de waarde in A2 kleiner is dan de waarde in A4. (ONWAAR)

=OF(A2>A3; A2<A4)

Bepaalt of de waarde in cel A2 groter is dan de waarde in A3 of dat de waarde in A2 kleiner is dan de waarde in A4. (WAAR)

=NIET(A2+A3=24)

Bepaalt of de som van de waarden in cellen A2 en A3 niet gelijk is aan 24. (ONWAAR)

=NIET(A5="Raderen")

Bepaalt of de waarde in cel A5 niet gelijk is aan "Raderen." (ONWAAR)

=OF(A5<>"Raderen";A6 = "Apparaatjes")

Bepaalt of de waarde in cel A5 niet gelijk is aan "Raderen" of dat de waarde in A6 gelijk is aan "Apparaatjes." (WAAR)

Zie EN, functie, OF, functie en NIET, functie voor meer informatie over het gebruik van deze functies.

Naar boven

Een voorwaardelijke formule maken die tot een andere berekening leidt of tot andere waarden dan WAAR of ONWAAR

Gebruik de functies ALS, EN en OF en operatoren om deze taak uit te voeren, zoals in het volgende voorbeeld.

Voorbeeld

De voorbeelden zijn mogelijk beter te begrijpen als u deze naar een leeg werkblad kopieert.

Hoe kopieer ik een voorbeeld?

  1. Selecteer het voorbeeld in dit artikel.

Belangrijk : Selecteer geen rij- of kolomkoppen.

een voorbeeld selecteren in de help in Excel 2013 voor Windows

Een voorbeeld in een Help-onderwerp selecteren

  1. Druk op CTRL+C.

  2. Maak een lege werkmap of leeg werkblad in Excel.

  3. SeIecteer cel A1 in het werkblad en druk op CTRL+V.

Belangrijk : Als u wilt dat het voorbeeld goed werkt, moet u het in cel A1 van het werkblad plakken.

  1. Als u afwisselend de resultaten en de bijbehorende formules wilt weergeven, drukt u op CTRL+` (accent grave). U kunt ook op het tabblad Formules in de groep Formules controleren op de knop Formules weergeven klikken.

Nadat u het voorbeeld naar een leeg werkblad hebt gekopieerd, kunt u het naar eigen inzicht aanpassen.

1

2

3

4

5

6

7


8



9



10



11




12



13



1,4




1,5



16

A

B

Gegevens

15

9

8

Raderen

Apparaatjes

Formule

Beschrijving (resultaat)

=ALS(A2=15; "OK"; "Niet OK")

Als de waarde in cel A2 gelijk is aan 15, dan "OK" als resultaat geven. Anders "Niet OK") (OK)

=ALS(A2<>15; "OK"; "Niet OK")

Als de waarde in cel A2 niet gelijk is aan 15, dan "OK" als resultaat geven. Anders "Niet OK". (Niet OK)

=ALS(NIET(A2<=15; "OK"; "Niet OK")

Als de waarde in cel A2 niet kleiner dan of gelijk is aan 15, dan "OK" als resultaat geven. Anders " Niet OK". (Niet OK)

=ALS(A5<>"RADEREN"; "OK"; "Niet OK")

Als de waarde in cel A5 niet gelijk is aan "RADEREN", dan "OK" als resultaat geven. Anders "Niet OK". (Niet OK)

=ALS(EN(A2>A3; A2<A4); "OK"; "Niet OK")

Als de waarde in cel A2 groter is dan de waarde in A3 en de waarde in A2 ook kleiner is dan de waarde in A4, dan "OK" als resultaat geven. Anders "Niet OK". (Niet OK)

=ALS(EN(A2<>A3; A2<>A4); "OK"; "Niet OK")

Als de waarde in cel A2 niet gelijk is aan A3 en de waarde in A2 ook niet gelijk is aan de waarde in A4, dan "OK" als resultaat geven. Anders "Niet OK". (OK)

=ALS(OF(A2>A3; A2<A4); "OK"; "Niet OK")

Als de waarde in cel A2 groter is dan de waarde in A3 of de waarde in A2 kleiner is dan de waarde in A4, dan "OK" als resultaat geven. Anders "Niet OK". (OK)

=ALS(OF(A5<>"Raderen"; A6<>"Apparaatjes"); "OK"; "Niet OK")

Als de waarde in cel A5 niet gelijk is aan "Raderen" of als de waarde in cel A6 niet gelijk is aan "Apparaatjes", dan "OK" als resultaat geven. Anders "Niet OK". (Niet OK)

=ALS(OF(A2<>A3; A2<>A4); "OK"; "Niet OK")

Als de waarde in cel A2 niet gelijk is aan de waarde in A3 of de waarde in A2 niet gelijk is aan de waarde in A4, dan "OK" als resultaat geven. Anders "Niet OK". (OK)

Zie ALS, functie, EN, functie en OF, functie voor meer informatie over het gebruik van deze functies.

Naar boven

Was deze informatie nuttig?

Wat kan er beter?

Wat kan er beter?

Voeg ter bescherming van uw privacy geen contactgegevens aan uw feedback toe. Beoordeel onze privacybeleid.

Bedankt voor uw feedback.