Een macro maken, uitvoeren, bewerken of verwijderen

Belangrijk : Dit artikel is automatisch vertaald, bekijk de disclaimer. De Engelse versie van dit artikel vindt u hier voor referentiedoeleinden.

Als u bepaalde taken regelmatig uitvoert, kunt u tijd besparen door de stappen waaruit de taken bestaan op te nemen in een macro. En als u vervolgens een van die opgenomen taken wilt uitvoeren, kunt u de macro activeren en deze de stappen voor u laten uitvoeren.

Word

In Word 2016 voor Mac, kunt u een macro met een sneltoets maken, een macro uitvoeren en verwijderen van een macro die u niet meer nodig hebt.

  1. Klik op Beeld > Macro's > Macro opnemen.

    Klik op het tabblad Beeld op Macro en klik vervolgens op Macro opnemen om een macro te maken.
  2. Typ een naam voor de macro of accepteer de standaardnaam die door Word wordt gegeven.

    Typ een naam voor uw macro in Macronaam of accepteer de generieke naam die door Word wordt voorgesteld.
  3. Als u deze macro wilt gebruiken in nieuwe documenten die u maakt, moet u controleren of in de lijst Macro opslaan in de optie Alle documenten (normaal) is geselecteerd.

  4. Klik op Toetsenbord om een toetsencombinatie toe te wijzen aan uw macro.

    In Word wordt het dialoogvenster Toetsenbord aanpassen weergegeven.

  5. Type een toetscombinatie in het vak Druk op nieuwe sneltoets.

    In Word wordt de opdracht of macro die al is toegewezen aan een toetsencombinatie (indien van toepassing) weergegeven, nadat u de toetsencombinatie indrukt.

    Wanneer u op een toetsencombinatie drukt, wordt in Word de eventueel aan deze toetsencombinatie toegewezen opdracht of actie weergegeven.

  6. Als de door u gekozen toetsencombinatie al is toegewezen, verwijdert u deze in het vak Druk op nieuwe sneltoets en kiest u vervolgens een nieuwe toetsencombinatie.

    Ga door met de volgende stap nadat u een toetsencombinatie hebt gevonden die niet is toegewezen.

    In Word wordt aangegeven wanneer u een toetsencombinatie hebt ingedrukt die nog niet is toegewezen aan een opdracht of macro.
  7. Als u deze sneltoets wilt gebruiken in nieuwe documenten, moet u controleren of in de lijst Wijzigingen opslaan in de optie Normal.dotm, de algemene sjabloon, is geselecteerd.

    Selecteer Normal.dotm om een macro beschikbaar te maken in nieuwe documenten die u maakt.
  8. Klik op Toewijzen.

  9. Wanneer u klaar bent om de macro op te nemen, klikt u op OK.

  10. Klik voor elke stap in de taak op de gewenste opdrachten of druk op de toetsen.

    In Word worden uw klikken en toetsaanslagen opgenomen, maar niet de tekst die u met de muis selecteert. Gebruik het toetsenbord om tekst te selecteren tijdens het opnemen van een macro.

  11. Als u de opname wilt stoppen, klikt u op Beeld > Macro's > Opname stoppen.

    Klik op Opname stoppen in het menu Macro’s om de opname van een macro te beëindigen.

U kunt een macro activeren door op de sneltoets te drukken die u eraan hebt toegewezen of u kunt de macro uitvoeren vanaf de lijst Macro's.

  1. Klik op Beeld > Macro's > Macro's weergeven.

    Klik op Macro’s weergeven om de macro’s weer te geven en te bewerken die aan het huidige document zijn gekoppeld.
  2. Selecteer in de lijst onder Macronaam de macro die u wilt uitvoeren.

  3. Klik op Uitvoeren.

    Na het selecteren van een macro onder Macronaam, klikt u op Uitvoeren om deze uit te voeren.

  1. Klik op Beeld > Macro's > Macro's weergeven.

    Klik op Macro’s weergeven om de macro’s weer te geven en te bewerken die aan het huidige document zijn gekoppeld.
  2. Controleer of de locatie die is opgegeven in Macro's in de locatie van de macro bevat die u wilt verwijderen.

    Selecteer de locatie van de macro's die u wilt weergeven vanuit de lijst Macro's in.

    De lijst vermeldt het document dat is geopend in het huidige venster, evenals de algemene sjabloon en Word-opdrachten.

  3. Selecteer bij Macronaam de macro die u wilt verwijderen en klik vervolgens op het minteken onder de lijst.

    Selecteer de macro die u wilt verwijderen en klik vervolgens op het minteken onder de lijst.
  4. Wanneer u in Word wordt gevraagd om te bevestigen dat u de macro wilt verwijderen, klikt u op Ja.

Excel

In Excel 2016 voor Mac, kunt u een macro met een sneltoets maken, een macro uitvoeren en verwijderen van een macro die u niet meer nodig hebt.

Als u een macro opneemt, wordt de macro recorder records alle stappen om te voltooien van de acties die u wilt dat uw macro wilt uitvoeren. Deze stappen kunnen opnemen tekst of getallen typen, te klikken op cellen of opdrachten op het lint of in menu's, opmaak, cellen, rijen of kolommen selecteren en uw muis slepen om cellen in het werkblad te selecteren.

Opmerking : De opdrachten voor opnemen, maken en verwijderen van macro's, evenals andere geavanceerde functies, zijn ook beschikbaar op het tabblad ontwikkelaars op het lint. Zie Gebruik het tabblad Ontwikkelaars maken of verwijderen van een macro in Excel 2016 voor Macvoor meer informatie over het gebruik van het tabblad ontwikkelaars.

  1. Selecteer Extra > Macro > nieuwe Record.

    Selecteer Extra, klikt u vervolgens Macro, klikt u vervolgens opnemen nieuwe Macro

  2. Typ in het vak Macronaam een naam voor de macro.

    Voer een naam, locatie en snelkoppeling-code van macro 's

  3. Als u wilt een sneltoets voor de macro hebt gemaakt, typt u een letter in het vak Option + Cmd .

  4. Selecteer een locatie voor de macro in de vervolgkeuzelijst.

    De macro opslaan

    Optie

    Klik in het document dat u macro maakt

    Deze werkmap

    In alle geopende documenten

    Nieuwe werkmap

    Om altijd beschikbaar te zijn wanneer u Excel gebruikt

    Persoonlijke macrowerkmap

  5. (Optioneel) Een beschrijving van uw macro toevoegen.

  6. Als u wilt opnemen, klik op OK.

  7. Klik voor elke stap in de taak op de gewenste opdrachten of druk op de toetsen.

  8. Als u wilt stoppen met het opnemen, selecteer Extra > Macro > Opname stoppen. (Deze stap, niet wordt vastgelegd in uw macro.)

    Selecteer stoppen opname

Een macro wilt uitvoeren, drukt u op de sneltoets die zijn toegewezen aan deze of de macro in het dialoogvenster macro's uitvoeren.

  1. Klik op het tabblad Beeld op Macro’s weergeven.

  2. Klik op macro's in het venstermenu en selecteert u Deze werkmap.

  3. Selecteer de macro in de lijst en klik op Uitvoeren.

    Dialoogvenster Macro’s in Excel voor Mac

  1. Selecteer Extra > Macro > macro's.

    Selecteer macro's en selecteer vervolgens macro 's

  2. Selecteer de macro wilt verwijderen en druk vervolgens op het min-teken.

    Selecteer de macronaam van de en selecteer vervolgens minteken ()

  3. Er wordt een bevestigingsbericht weergegeven. Klik op Ja om de verwijdering te bevestigen.

    Verwijdering bevestigen

U kunt ook een macro verwijderen uit het tabblad ontwikkelaars .

  1. Klik op het tabblad Ontwikkelaars op Macro’s.

  2. Klik in de lijst op de macro die u wilt verwijderen en klik op de knop Verwijderen.

    Selecteer een macro en klik op het minteken om deze te verwijderen

Word

Als u een terugkerende taak wilt automatiseren, kunt u snel een macro maken in Word. U kunt ook Visual Basic Editor in Microsoft Visual Basic for Applications gebruiken om uw eigen macroscript te schrijven of een macro geheel of gedeeltelijk te kopiëren naar een nieuwe macro.

Als u een macro opneemt, worden de stappen die nodig zijn voor het voltooien van de acties die u wilt dat uw macro wilt uitvoeren opgenomen. Navigatie terug naar het tabblad om te stoppen met het opnemen is echter niet opgenomen in de opgenomen stappen.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Opnemen.

    Tabblad Ontwikkelaar, groep Visual Basic voor Word

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Typ in het vak Macronaam een naam voor de macro.

  3. Voer in het snelmenu Macro opslaan in een van de volgende handelingen uit:

    De macro opslaan

    Klik op

    In het document waarin u de macro maakt

    [documentnaam] (document)

    In alle geopende documenten

    Alle documenten (normaal)

  4. Klik op OK en voer de acties uit die u wilt opnemen.

  5. Klik op het tabblad Ontwikkelaars onder Visual Basic op Stoppen.

U kunt de ingebouwde Visual Basic Editor gebruiken om een macro te maken.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Editor.

    Tabblad Ontwikkelaar, groep Visual Basic voor Word

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Als u een module wilt invoegen, klikt u in Visual Basic Editor op Module in het menu Invoegen.

  3. Typ of plak de macrocode die u wilt gebruiken in het codevenster van de module.

  4. Klik wanneer u klaar bent in het menu Word op Sluiten en terugkeren naar Microsoft Word.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Word

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt uitvoeren en klik op Uitvoeren.

Als u een macro wilt bewerken, gebruikt u Visual Basic Editor.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Word

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt bewerken en klik op Bewerken.

    Visual Basic Editor wordt geopend.

  3. Breng de gewenste wijzigingen aan.

  4. Klik wanneer u klaar bent in het menu Word op Sluiten en terugkeren naar Microsoft Word.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Word

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt kopiëren en klik op Bewerken.

    Visual Basic Editor wordt geopend.

  3. Selecteer in het codevenster van de Visual Basic Editor de regels van de macro die u wilt kopiëren.

    Tip : Als u de hele macro wilt kopiëren, moet u ook de regels met Sub en End Sub in de selectie opnemen.

  4. Klik op Kopiëren in het menu Bewerken.

  5. Klik in het vak Project van het codevenster op de module waarin u de code wilt plaatsen.

  6. Klik op Plakken in het menu Bewerken.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Word

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt verwijderen en klik op Verwijderen.

PowerPoint

Een terugkerende taak wilt automatiseren, kunt u Visual Basic for Applications een macro maken in PowerPoint.

U kunt de ingebouwde Visual Basic Editor gebruiken om een macro te maken.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Editor.

    Tabblad Ontwikkelaar, groep Visual Basic voor PowerPoint

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Als u een module wilt invoegen, klikt u in Visual Basic Editor op Module in het menu Invoegen.

  3. Typ of plak de macrocode die u wilt gebruiken in het codevenster van de module.

  4. Klik wanneer u klaar bent in het menu PowerPoint op Sluiten en terugkeren naar Microsoft PowerPoint.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor PowerPoint

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt uitvoeren en klik op Uitvoeren.

Als u een macro wilt bewerken, gebruikt u Visual Basic Editor.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor PowerPoint

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt bewerken en klik op Bewerken.

    Visual Basic Editor wordt geopend.

  3. Breng de gewenste wijzigingen aan.

  4. Klik wanneer u klaar bent in het menu PowerPoint op Sluiten en terugkeren naar Microsoft PowerPoint.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor PowerPoint

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt kopiëren en klik op Bewerken.

    Visual Basic Editor wordt geopend.

  3. Selecteer in het codevenster van de Visual Basic Editor de regels van de macro die u wilt kopiëren.

    Tip : Als u de hele macro wilt kopiëren, moet u ook de regels met Sub en End Sub in de selectie opnemen.

  4. Klik op Kopiëren in het menu Bewerken.

  5. Klik in het vak Project van het codevenster op de module waarin u de code wilt plaatsen.

  6. Klik op Plakken in het menu Bewerken.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor PowerPoint

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt verwijderen en klik op Verwijderen.

Excel

Als u een terugkerende taak wilt automatiseren, kunt u snel een macro maken in Excel. U kunt ook Visual Basic Editor in Microsoft Visual Basic for Applications gebruiken om uw eigen macroscript te schrijven of een macro geheel of gedeeltelijk te kopiëren naar een nieuwe macro.

Alle stappen die nodig zijn om de acties te voltooien die u de macro wilt laten uitvoeren, zijn opgenomen. De navigatie terug naar het tabblad om het opnemen te stoppen maakt echter geen deel uit van de opgenomen stappen.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Opnemen.

    Tabblad Ontwikkelaar, groep Visual Basic voor Excel

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Typ in het vak Macronaam een naam voor de macro.

    Tip : Als u een sneltoets aan de macro wilt toewijzen, typt u een letter in het vak Option+Cmd+.

  3. Voer in het snelmenu Macro opslaan in een van de volgende handelingen uit:

    De macro opslaan

    Klik op

    In het document waarin u de macro maakt

    Deze werkmap

    In alle geopende documenten

    Nieuwe werkmap

    Om altijd beschikbaar te zijn wanneer u Excel gebruikt

    Persoonlijke macrowerkmap

    De persoonlijke macrowerkmap bevindt zich in Users / gebruikersnaam/bibliotheek/Application ondersteunen / Microsoft/Office/Excel.

  4. Klik op OK en voer de acties uit die u wilt opnemen.

  5. Klik op het tabblad Ontwikkelaars onder Visual Basic nogmaals op Opnemen.

U kunt de ingebouwde Visual Basic Editor gebruiken om een macro te maken.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Editor.

    Tabblad Ontwikkelaar, groep Visual Basic voor Excel

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Als u een module wilt invoegen, klikt u in Visual Basic Editor op Module in het menu Invoegen.

  3. Typ of plak de macrocode die u wilt gebruiken in het codevenster van de module.

  4. Klik wanneer u klaar bent in het menu Excel op Sluiten en terugkeren naar Microsoft Excel.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Excel

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt uitvoeren en klik op Uitvoeren.

    Tip : Als u een macro wilt uitvoeren via een sneltoets, drukt u op OPTION + COMMAND + de letter die u hebt getypt bij het toewijzen van de sneltoets.

Als u een macro wilt bewerken, gebruikt u Visual Basic Editor.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Excel

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt bewerken en klik op Bewerken.

    Visual Basic Editor wordt geopend.

  3. Breng de gewenste wijzigingen aan.

  4. Klik wanneer u klaar bent in het menu Excel op Sluiten en terugkeren naar Microsoft Excel.

Nadat u deze procedure hebt voltooid, wordt de macro uitgevoerd wanneer de werkmap met de macro wordt geopend.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Opnemen.

    Tabblad Ontwikkelaar, groep Visual Basic voor Excel

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Typ Auto_Openen in het vak Macronaam.

  3. Voer in het snelmenu Macro opslaan in een van de volgende handelingen uit:

    De macro opslaan

    Klik op

    In het document waarin u de macro maakt

    Deze werkmap

    In alle geopende documenten

    Nieuwe werkmap

    Om altijd beschikbaar te zijn wanneer u Excel gebruikt

    Persoonlijke macrowerkmap

  4. Klik op OK en voer de acties uit die u wilt opnemen.

  5. Klik op het tabblad Ontwikkelaars onder Visual Basic nogmaals op Opnemen.

  6. Klik in het menu Bestand op Opslaan als.

  7. Klik in het snelmenu Indeling op Excel-werkmap met macro's (.xlsm) en klik vervolgens op Opslaan.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Excel

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt kopiëren en klik op Bewerken.

    Visual Basic Editor wordt geopend.

  3. Selecteer in het codevenster van de Visual Basic Editor de regels van de macro die u wilt kopiëren.

    Tip : Als u de hele macro wilt kopiëren, moet u ook de regels met Sub en End Sub in de selectie opnemen.

  4. Klik op Kopiëren in het menu Bewerken.

  5. Klik in het vak Project van het codevenster op de module waarin u de code wilt plaatsen.

  6. Klik op Plakken in het menu Bewerken.

  1. Klik op het tabblad Ontwikkelaars onder Visual Basic op Macro’s.

    Tabblad Ontwikkelaar, groep Visual Basic voor Excel

    Als het tabblad Ontwikkelaars niet beschikbaar is

    1. Klik aan de rechterkant van het lint op Pop-upmenu Actie en klik op Lintvoorkeuren.

    2. Schakel onder Aanpassen het selectievakje Ontwikkelaars in.

  2. Klik in de lijst op de macro die u wilt verwijderen en klik op Verwijderen.

Opmerking : Disclaimer voor automatische vertaling: Dit artikel is vertaald door een computersysteem zonder menselijke tussenkomst. Microsoft biedt deze automatische vertalingen aan om niet-Engels sprekende gebruikers te helpen de inhoud over producten, services en technologieën van Microsoft te raadplegen. Omdat het artikel automatisch is vertaald, bevat het mogelijk fouten in grammatica, woordenschat en syntaxis.

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagents.

×