De fout #WAARDE! corrigeren in de functie TEKST.SAMENVOEGEN

Belangrijk: In Excel 2016, Excel Mobile en Excel voor het web, is de functie SAMENVOEGen vervangen door de functie CONCAt. Hoewel de functie TEKST.SAMENVOEGEN nog steeds beschikbaar is voor compatibiliteit met eerdere versies, kunt u beter TEKST.SAMENV gebruiken omdat deze functie meer mogelijkheden heeft.

De fout #WAARDE! komt vaak voor bij TEKST.SAMENVOEGEN als u een tekenreeks maakt waarin een celverwijzing is opgenomen die een fout, zoals #WAARDE!, bevat.

In het volgende voorbeeld willen we D2, E2 en F2 samenvoegen, waarbij E2 een #VALUE heeft. fout.

Fout #WAARDE! fout bij SAMENVOEGen

De fout in E2 veroorzaakt een functie voor het weergeven van de #VALUE! fout. Om de fout te kunnen uitvoeren, moet u de fout vervangen door een andere waarde dan de fout. U kunt een formule maken waarmee wordt gecontroleerd of er een fout wordt weergegeven in de celverwijzing, en als dit het geval is, kunt u de teksttekenreeks weergeven waarbij een 0 wordt weergegeven in plaats van de fout (of u kunt de tekst tussen de aanhalingstekens plaatsen, maar u moet de tekst tussen de aanhalingstekens plaatsen.

De volgende formule werkt bijvoorbeeld goed:

=ALS(ISFOUT(E2);TEKST.SAMENVOEGEN(D2;" ";0;" ";F2))

De functies als en ISFOUT als tijdelijke oplossing voor het samenvoegen van een tekenreeks met de #VALUE! corrigeren

Hoe werkt dit? Met de functie als wordt de functie als. fout gebruikt om te bepalen of er een fout is in E2, en als dat zo is, combineert de functie tekst. SAMENVOEGen de waarden in D2, E2 en F2 (de functie vervangt de fout door een 0) en geeft de resultaat tekstreeks weer. Opmerking de formule gebruikt ook spaties ("") om de waarden te scheiden.

De fout #WAARDE! oplossen met TEKST.SAMENVOEGEN in Excel 2003 en oudere versies

Als u de #VALUE krijgt. Er is een fout opgetreden in Office Excel 2003 of oudere versies, moet u de optie overgangs formule (TFE) uitschakelen in Excel. Voer de stappen uit die worden beschreven in #VALUE! bij het samenvoegen van cellen het probleem op te lossen.

Hebt u een vraag over een bepaalde functie?

Stel een vraag op het forum van de Excel-community

Help ons Excel verbeteren

Hebt u suggesties voor het verbeteren van de volgende versie van Excel? Als dat het geval is, kijk dan eens naar de onderwerpen op Excel User Voice (Engelstalig).

Zie ook

De fout #WAARDE! corrigeren

TEKST.SAMENVOEGEN, functie

TEKST.SAMENV, functie

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Alle Excel-functies (alfabetisch)

Alle Excel-functies (per categorie)

Opmerking:  Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor je is. Wil je ons laten weten of deze informatie nuttig is? Hier is het Engelstalige artikel ter referentie.

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×