ALS, functie

De functie ALS is een van de meest gebruikte functies in Excel, waarmee u logische vergelijkingen kunt maken tussen een waarde en wat u zou verwachten. In de meest eenvoudige vorm staat de functie ALS voor het volgende:

  • ALS(iets waar is, doe dan iets, doe anders iets anders)

Een ALS-instructie kan dus twee resultaten hebben. Het eerste resultaat is als de vergelijking Waar is, het tweede is als de vergelijking Onwaar is.

Eenvoudige voorbeelden van ALS

Cel D2 bevat de formule =ALS(C2="Ja",1,2)
  • =ALS(C2="Ja",1,2)

Cel D2 in het bovenstaande voorbeeld betekent: ALS(C2 = Ja, retourneer dan 1; retourneer anders 2)

Cel D2 bevat de formule =ALS(C2=1,"JA","NEE")
  • =ALS(C2=1,"Ja","Nee")

De formule in cel D2 in dit voorbeeld betekent: ALS(C2 = 1, retourneer dan Ja; retourneer anders Nee)

Zoals u ziet, kan de ALS-functie worden gebruikt om zowel tekst als waarden te evalueren. De functie kan ook worden gebruikt voor het evalueren van fouten. U kunt niet alleen controleren of iets gelijk is aan iets anders en één resultaat retourneren. Afhankelijk van uw criteria kunt u ook wiskundige operatoren gebruiken en aanvullende berekeningen uitvoeren. U kunt ook meerdere ALS-functies samen nesten om meerdere vergelijkingen uit te voeren.

OPMERKING: als u in formules tekst wilt gebruiken, moet u de tekst tussen aanhalingstekens plaatsen (bijvoorbeeld "Tekst"). De enige uitzonderingen daarop zijn WAAR en ONWAAR. Deze worden automatisch door Excel begrepen.

Aan de slag

De beste manier om een ALS-instructie te schrijven, is om na te denken over wat u wilt bereiken. Wat wilt u vergelijken? Het schrijven van een ALS-instructie is vaak net zo eenvoudig als wanneer u erover nadenkt: 'wat moet er gebeuren als aan deze voorwaarde wordt voldaan en wat moet er gebeuren als dat niet zo is?' U moet er altijd voor zorgen dat uw stappen een logische volgorde hebben. Anders levert uw formule niet op wat deze op zou moeten leveren. Dit is vooral belangrijk bij het maken van complexe (geneste) ALS-instructies.

Voorbeelden van ALS

De formule in cel D2 is =ALS(C2>B2,"Budget overschreden","Binnen budget")
  • =ALS(C2>B2,"Budget overschreden","Binnen budget")

De ALS-functie in D2 in het bovenstaande voorbeeld betekent ALS(C2 groter is dan B2, retourneer dan "Budget overschreden"; retourneer anders "Binnen budget")

De formule in cel E2 is =ALS(C2>B2,C2-B2,"")
  • =ALS(C2>B2,C2-B2,"")

In plaats van een tekstresultaat, gaan we in de bovenstaande afbeelding een wiskundige berekening retourneren. De formule in E2 betekent dus ALS(werkelijk groter is dan gebudgetteerd, trek dan het gebudgetteerde bedrag van het werkelijke bedrag af; retourneer anders niets).

De formule in cel F7 is ALS(E7="Ja",F5*0,0825,0)
  • =ALS(E7="Ja",F5*0,21,0)

De formule in F7 in dit voorbeeld betekent ALS(E7 = "Ja", bereken dan het totaalbedrag in F5 * 21%, anders hoeft er geen btw te worden betaald; retourneer dus 0)

Aanbevolen procedures: variabelen

In het laatste voorbeeld zijn zowel "Ja" als het btw-tarief (0,21) rechtstreeks in de formule ingevoerd. In het algemeen geldt dat variabelen (waarden die mogelijk van tijd tot tijd moeten worden gewijzigd) beter niet rechtstreeks in formules kunnen worden ingevoerd, omdat ze in de toekomst lastig zijn te vinden en te wijzigen. Het is veel beter om de variabelen in een eigen cel te plaatsen, waar ze goed zichtbaar zijn en gemakkelijk kunnen worden gevonden en gewijzigd. In dit geval is het geen probleem, omdat er slechts één ALS-functie is en het btw-tarief zelden wordt gewijzigd. Zelfs als dat gebeurt, kan dit eenvoudig in de formule worden gewijzigd.

Voorbeeld van geneste ALS

De formule in cel E2 is =ALS(D2=1,"Ja",ALS(D2=2,"Nee","Misschien"))

Terwijl een eenvoudige ALS-functie slechts twee resultaten oplevert (Waar of Onwaar), kunnen geneste ALS-functies maar liefst 3 tot 64 resultaten geven.

  • =ALS(D2=1,"Ja",ALS(D2=2,"Nee","Misschien"))

De formule in E2 in de bovenstaande afbeelding betekent: ALS(D2 gelijk is aan 1, retourneer dan "Ja"; ALS(D2 gelijk is aan 2, retourneer dan "Nee"; retourneer anders "Misschien")

Waarschuwing

Hoewel u in Excel maximaal 64 verschillende ALS-functies kunt nesten, wordt dit niet aangeraden. Waarom?

  • Het kost veel denkwerk om meerdere ALS-instructies correct uit te werken en ervoor te zorgen dat de logica ervan via elke voorwaarde helemaal tot het eind correct kan worden berekend. Als u de ALS-instructies niet 100% nauwkeurig nest, kan een formule 75% van de tijd werken, maar 25% van de tijd onverwachte resultaten geven. Helaas is de kans klein dat u die 25% ontdekt.

  • Meerdere ALS-instructies kunnen zeer lastig bij te houden zijn, vooral wanneer u later probeert te achterhalen wat u, of erger nog, iemand anders probeerde te doen.

Algemene problemen

Probleem

Wat is er fout gegaan

O (nul) in cel

Er bestaat geen argument voor een van de argumenten waarde_als_waar of waarde_als_onwaar. Als u de juiste waarde wilt retourneren, voegt u argumenttekst toe aan de twee argumenten of voegt u WAAR of ONWAAR toe aan het argument.

#NAAM? in cel

Dit betekent meestal dat de formule onjuist is gespeld.

Technische gegevens

Gebruik de functie ALS, een van de logische functies, om één waarde te retourneren als een voorwaarde waar is en een andere waarde als de voorwaarde onwaar is.

Syntaxis

ALS(logische_test;waarde_als_waar;[waarde_als_onwaar])

Bijvoorbeeld:

  • =ALS(A2>B2;"Budget overschreden";"OK")

  • =ALS(A2=B2,B4-A4,"")

Naam argument

Beschrijving

logische_test    (vereist)

De voorwaarde die u wilt testen.

waarde_als_waar    (vereist)

De waarde die u als resultaat wilt hebben als het resultaat van logische_test WAAR is.

waarde_als_onwaar    (optioneel)

De waarde die u als resultaat wilt hebben als het resultaat van logische_test ONWAAR is.

Gerelateerd

Was deze informatie nuttig?

Wat kan er beter?

Wat kan er beter?

Voeg ter bescherming van uw privacy geen contactgegevens aan uw feedback toe. Beoordeel onze privacybeleid.

Bedankt voor uw feedback.