ALS, functie

In dit artikel worden de syntaxis en het gebruik van de functie ALS in Microsoft Excel beschreven.

Beschrijving

De functie ALS geeft een bepaalde waarde als resultaat als de opgegeven voorwaarde WAAR is en een andere waarde als deze ONWAAR is. De formule =ALS(A1>10;"Meer dan 10";"10 of minder") geeft 'Meer dan 10' als resultaat als A1 groter is dan 10, en '10 of minder' als A1 kleiner is dan of gelijk is aan 10.

Syntaxis

ALS(logische_test, [waarde_als_waar], [waarde_als_onwaar])

De syntaxis van de functie ALS heeft de volgende argument.

  • logische_test    Vereist. Een waarde of expressie die resulteert in de waarde WAAR of ONWAAR. Zo is A10=100 een logische expressie: als de waarde in cel A10 gelijk is aan 100, resulteert de expressie in de waarde WAAR; in het andere geval is het resultaat ONWAAR. In dit argument kunt u alle vergelijkingsoperators gebruiken.

  • waarde_als_waar    Optioneel. De waarde die u als resultaat wilt hebben als het argument logische_test WAAR is. Als de waarde van dit argument bijvoorbeeld de tekenreeks "Binnen het budget" is en het argument logische_test WAAR is, geeft de functie ALS de tekst "Binnen het budget" als resultaat. Als logische_test WAAR is en het argument waarde_als_waar wordt weggelaten (dat wil zeggen dat het argument logische_test alleen wordt gevolgd door een puntkomma), geeft de functie ALS 0 (nul) als resultaat. Als u het woord WAAR wilt weergeven, gebruikt u de logische waarde WAAR voor het argument waarde_als_waar.

  • waarde_als_onwaar    Optioneel. De waarde die u als resultaat wilt hebben als het argument logische-test ONWAAR is. Als de waarde van dit argument bijvoorbeeld de tekenreeks 'Budget overschreden' is en het argument logische-test ONWAAR is, geeft de functie ALS de tekst 'Budget overschreden' als resultaat. Als logische-test ONWAAR is en het argument waarde-als-onwaar wordt weggelaten (dat wil zeggen dat het argument waarde-als-waar niet wordt gevolgd door een puntkomma), geeft de functie ALS de logische waarde ONWAAR als resultaat. Als logische-test ONWAAR is en de waarde van het argument waarde-als-onwaar leeg is (dat wil zeggen dat alleen een puntkomma volgt op het argument waarde-als-waar ), geeft de functie ALS de waarde 0 (nul) als resultaat.

Opmerkingen

  • U kunt maximaal 64 functies ALS nesten als argumenten waarde_als_waar en waarde_als_onwaar om uitgebreidere tests op te zetten. (Zie voorbeeld 3 voor voor een voorbeeld van geneste functies ALS.) Als u veel voorwaarden wilt testen, kunt u ook de functies OPZOEKEN, VERT.ZOEKEN, HORIZ.ZOEKEN of KIEZEN gebruiken. (Zie voorbeeld 4 voor een voorbeeld van de functie OPZOEKEN.)

  • Als een of meer van de argumenten van ALSmatrix zijn, wordt elk element in de matrix geëvalueerd wanneer de instructie ALS wordt uitgevoerd.

  • Excel bevat nog meer functies die kunnen worden gebruikt om uw gegevens te analyseren op basis van een voorwaarde. Als u bijvoorbeeld het aantal malen wilt tellen dat een tekenreeks of een getal in een cellenbereik voorkomt, gebruikt u de werkbladfuncties AANTAL.ALS of AANTALLEN.ALS. Als u een som wilt berekenen op basis van een tekenreeks of een getal in een bereik, gebruikt u de werkbladfunctie SOM.ALS of SOMMEN.ALS.

Voorbeelden

In de onderstaande werkmappen ziet u voorbeelden van deze functie. U kunt de formules bekijken, bestaande formules wijzigen of uw eigen formules invoeren om te leren hoe de functie werkt.

Kopieer de voorbeeldgegevens uit de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. U kunt de resultaten van formules weergeven door deze te selecteren en op F2 en vervolgens op Enter te drukken. Desgewenst kunt u de kolombreedte wijzigen om alle gegevens te zien.

Gegevens

50

23

33175

Formule

Beschrijving

Resultaat

=ALS((A2<=100;"Binnen budget";"Budget overschreden")

Als het getal in cel A2 kleiner is dan of gelijk is aan 100, geeft de functie de tekst "Binnen het budget" als resultaat. Als dit niet het geval is, wordt de tekst "Budget overschreden" als resultaat gegeven.

Binnen het budget

=ALS(A2=100;A2+B2;"")

Als het getal in cel A2 gelijk is aan 100, wordt A2 + B2 berekend en als resultaat gegeven. Anders wordt lege tekst ("") als resultaat gegeven.

0

=ALS(3<1;"OK")

Als het resultaat Onwaar is en geen waarde-als-onwaar-argument is opgegeven voor het resultaat Onwaar, wordt ONWAAR als resultaat gegeven.

ONWAAR

Als het resultaat Onwaar is en een leeg waarde-als-onwaar-argument is opgegeven voor het resultaat Onwaar (er volgt een puntkomma op het waarde-als-onwaar-argument), wordt 0 geretourneerd.

0

Als u verder wilt werken met de voorbeeldgegevens in Excel, kunt u de ingesloten werkmap downloaden naar uw computer en openen in Excel.

Voorbeeld 2

Werkelijke uitgaven

Voorspelde uitgaven

€ 1500

€ 900

€ 500

€ 900

€ 500

€ 925

Formule

Beschrijving

Resultaat

=Als(A2>B2;"Budget overschreden";"OK")

Hiermee wordt gecontroleerd of de werkelijke uitgaven in rij 2 hoger liggen dan de voorspelde uitgaven. Er wordt 'Budget overschreden' weergegeven omdat het resultaat van de controle Waar is.

Budget overschreden

=ALS((A3>B3;"Budget overschreden";"OK")

Hiermee wordt gecontroleerd of de werkelijke uitgaven in rij 3 hoger liggen dan de voorspelde uitgaven. Er wordt 'OK' weergegeven omdat het resultaat van de controle Onwaar is.

OK

Voorbeeld 3

Score

45

90

78

Formule

Beschrijving

Resultaat

=ALS(A2>89;"A";ALS(A2>79;"B"; ALS(A2>69;"C";ALS(A2>59;"D";"F"))))

Hierdoor worden geneste ALS-voorwaarden gebruikt om een letter toe te wijzen als score in cel A2.

F

=ALS(A3>89;"A";ALS(A3>79;"B"; ALS(A3>69;"C";ALS(A3>59;"D";"F"))))

Hierdoor worden geneste ALS-voorwaarden gebruikt om een letter toe te wijzen als score in cel A3.

A

=ALS(A4>89,"A";ALS(A4>79;"B"; ALS(A4>69;"C";ALS(A4>59;"D";"F"))))

Hierdoor worden geneste ALS-voorwaarden gebruikt om een letter toe te wijzen als score in cel A4.

C

Voorbeeld 4

Score

45

90

78

Formule

Beschrijving

Resultaat

=ZOEKEN(A2;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

In plaats van meerdere geneste ALS-functies, wordt in deze formule de functie ZOEKEN gebruikt om een letterscore te zoeken die overeenkomst met een numerieke score die is opgeslagen in een matrix in de formule.

F

=ZOEKEN(A3;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

In plaats van meerdere geneste ALS-functies, wordt in deze formule de functie ZOEKEN gebruikt om een letterscore te zoeken die overeenkomst met een numerieke score die is opgeslagen in een matrix in de formule.

A-

=ZOEKEN(A4;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

In plaats van meerdere geneste ALS-functies, wordt in deze formule de functie ZOEKEN gebruikt om een letterscore te zoeken die overeenkomst met een numerieke score die is opgeslagen in een matrix in de formule.

C+

Is van toepassing op: Excel 2013, Excel Online



Was deze informatie nuttig?

Ja Nee

Wat kan er beter?

255 tekens resterend

Voeg ter bescherming van uw privacy geen contactgegevens aan uw feedback toe. Beoordeel onze privacybeleid.

Bedankt voor uw feedback.

Ondersteuningsbronnen

Taal wijzigen