Formules en functies

ALS, functie

ALS, functie

Opmerking: We willen u graag zo snel mogelijk de meest recente Help-inhoud in uw eigen taal bieden. Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor u is. Kunt u ons onder aan deze pagina laten weten of de informatie nuttig voor u was? Hier is het Engelstalige artikel ter referentie.

De functie ALS is een van de meest gebruikte functies in Excel, waarmee u logische vergelijkingen kunt maken tussen een waarde en wat u zou verwachten.

Een ALS-instructie kan dus twee resultaten hebben. Het eerste resultaat is als de vergelijking Waar is, het tweede is als de vergelijking Onwaar is.

Bijvoorbeeld: =ALS(C2="Ja";1;2) betekent ALS(C2 = Ja; retourneer dan 1; retourneer anders 2).

Uw browser biedt geen ondersteuning voor video. Installeer Microsoft Silverlight, Adobe Flash Player of Internet Explorer 9.

Gebruik de functie ALS, een van de logische functies, om één waarde te retourneren als een voorwaarde waar is en een andere waarde als de voorwaarde onwaar is.

ALS(logische_test;waarde_als_waar;[waarde_als_onwaar])

Bijvoorbeeld:

  • =ALS(A2>B2;"Budget overschreden";"OK")

  • =ALS(A2=B2;B4-A4,"")

Naam argument

Beschrijving

logische_test    (vereist)

De voorwaarde die u wilt testen.

waarde_als_waar    (vereist)

De waarde die u als resultaat wilt hebben als het resultaat van logische_test WAAR is.

waarde_als_onwaar    (optioneel)

De waarde die u als resultaat wilt hebben als het resultaat van logische_test ONWAAR is.

Eenvoudige voorbeelden van ALS

Cel D2 bevat de formule =ALS(C2="Ja",1,2)
  • =ALS(C2="Ja";1;2)

De ALS-functie van cel D2 in het bovenstaande voorbeeld betekent: ALS(C2 = Ja, retourneer dan 1; retourneer anders 2)

Cel D2 bevat de formule =ALS(C2=1,"JA","NEE")
  • =ALS(C2=1;"Ja";"Nee")

In dit voorbeeld luidt de formule in cel D2: ALS (c2 = 1, retourneer dan Ja, anders retourneer Nee) Zoals u ziet, kan de functie ALS worden gebruikt voor het evalueren van tekst en waarden. Deze functie kan ook worden gebruikt om fouten te evalueren. U hoeft niet alleen te controleren of één ding gelijk is aan een andere, en een enkel resultaat retourneert, maar u kunt ook wiskundige operatoren gebruiken en extra berekeningen uitvoeren, afhankelijk van uw criteria. U kunt meerdere ALS-functies ook nesten om meerdere vergelijkingen te kunnen uitvoeren.

De formule in cel D2 is =ALS(C2>B2;"Budget overschreden";"Binnen budget")
  • =ALS(C2>B2;"Budget overschreden";"Binnen budget")

De ALS-functie in D2 in het bovenstaande voorbeeld betekent ALS(C2 groter is dan B2, retourneer dan "Budget overschreden"; retourneer anders "Binnen budget")

De formule in cel E2 is =ALS(C2>B2,C2-B2,"")
  • =ALS(C2>B2;C2-B2;0)

In plaats van een tekstresultaat, gaan we in de bovenstaande afbeelding een wiskundige berekening retourneren. De formule in E2 betekent dus ALS(werkelijk groter is dan gebudgetteerd, trek dan het gebudgetteerde bedrag van het werkelijke bedrag af; retourneer anders niets).

De formule in cel F7 is ALS(E7="Ja";F5*0,0825,0)
  • =ALS(E7="Ja";F5*0,21;0)

De formule in F7 in dit voorbeeld betekent ALS(E7="Ja", bereken dan het totaalbedrag in F5 * 21%, anders hoeft er geen btw te worden betaald; retourneer dus 0)

Opmerking: Als u tekst in formules gebruiken, moet u de tekst laten teruglopen tussen aanhalingstekens (bijvoorbeeld "tekst"). De enige uitzondering die wordt gebruikt waar of ONWAAR geven, die Excel automatisch begrijpt.

Algemene problemen

Probleem

Wat is er fout gegaan

0 (nul) in cel

Er bestaat geen argument voor een van de argumenten waarde_als_waar of waarde_als_onwaar. Als u de juiste waarde wilt retourneren, voegt u argumenttekst toe aan de twee argumenten of voegt u WAAR of ONWAAR toe aan het argument.

#NAAM? in cel

Dit betekent meestal dat de formule onjuist is gespeld.

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community, ondersteuning vragen in de Answer-community of een nieuwe functie of verbetering voorstellen in Excel User Voice.

Zie ook

Rekenkundige operatoren en prioriteit in Excel

Geneste functies gebruiken in een formule

ALS gebruiken om te controleren of een cel leeg is

ALS gebruiken om te controleren of een cel leeg is

Video: Geavanceerde ALS-functies

ALS.VOORWAARDEN, functie (Office 365, Excel 2016 en later)

ALS-functie: geneste formules en het vermijden van valkuilen

Trainingsvideo's: Geavanceerde ALS-functies

Met de functie AANTAL.ALS worden waarden geteld op basis van één criterium

Met de functie AANTALLEN.ALS worden waarden geteld op basis van meerdere criteria

Met de functie SOM.ALS worden waarden opgeteld op basis van één criterium

Met de functie SOMMEN.ALS worden waarden opgeteld op basis van meerdere criteria

EN, functie

OF, functie

VERT.ZOEKEN, functie

Overzicht van formules in Excel

Niet-werkende formules voorkomen

Fouten opsporen in formules

Logische functies

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×