ALS, functie

Gebruik de functie ALS, een van de logische functies, om één waarde te retourneren als een voorwaarde waar is en een andere waarde als de voorwaarde onwaar is.

Syntaxis

ALS(logische_test;waarde_als_waar;[waarde_als_onwaar])

Bijvoorbeeld:

  • =ALS(A2>B2;"Budget overschreden";"OK")

  • =ALS(A4=500;B4-A4;""

Naam argument

Beschrijving

logische_test    (vereist)

De voorwaarde die u wilt testen.

waarde_als_waar    (vereist)

De waarde die u als resultaat wilt hebben als het resultaat van logische_test WAAR is.

waarde_als_onwaar    (optioneel)

De waarde die u als resultaat wilt hebben als het resultaat van logische_test ONWAAR is.

Voorbeelden

Kopieer de voorbeeldgegevens in de volgende tabel en plak deze in cel A1 van een nieuw Excel-werkblad. Als u de formule in een formulecel wilt zien, selecteert u de cel en drukt u op F2.

Werkelijke uitgaven

Voorspelde uitgaven

€ 1500

€ 900

€ 500

€ 900

€ 500

€ 925

=ALS(A2>B2;"Budget overschreden";"OK")

Aangezien de werkelijke uitgaven van € 1500 (A2) de voorspelde uitgaven van € 900 (B2) hebben overschreden, is het resultaat Budget overschreden.

=ALS(A2<B2;WAAR;ALS(A3>B3;"budget overschreden";"OK"))

De eerste ALS-functie is onwaar. Daarom wordt de tweede ALS-instructie berekend en omdat deze ook onwaar is, is het resultaat OK.

=ALS(A4=500;B4-A4;"")

Omdat A4 gelijk is aan 500, worden de werkelijke uitgaven van € 500 afgetrokken van de voorspelde uitgaven van € 925, zodat u kunt zien met hoeveel het budget is overschreden. Het resultaat is 425. Als A4 niet gelijk is aan 500, wordt lege tekst ("") geretourneerd.

=ALS(A2<B2;WAAR;ALS(A3>B3;"budget overschreden";"OK"))

De eerste ALS-functie is onwaar. Daarom wordt de tweede ALS-instructie berekend en omdat deze ook onwaar is, is het resultaat OK.

Algemene problemen

Probleem

Wat is er fout gegaan

O (nul) in cel

Er bestaat geen argument voor een van de argumenten waarde_als_waar of waarde_als_onwaar. Als u de juiste waarde wilt retourneren, voegt u argumenttekst toe aan de twee argumenten of voegt u WAAR of ONWAAR toe aan het argument.

#NAAM? in cel

Dit betekent meestal dat de formule onjuist is gespeld.

Aanbevolen procedures

Werkwijze

Waarom

Een ALS-functie gebruiken in een andere ALS-functie.

Maximaal 64 ALS-functies kunnen binnen elkaar worden genest voor de argumenten waarde_als_waar en waarde_als_onwaar om uitgebreidere tests te maken.

ALS gebruiken met matrices

Als een van de argumenten voor de ALS-functie een matrix is, wordt elk element van de matrix geëvalueerd wanneer de ALS-instructie wordt uitgevoerd. Lees hoe u een matrixformule kunt maken.

Gerelateerd

Is van toepassing op: Excel for Mac 2011, Excel 2010, Excel 2016 for Mac, Excel Online, Excel Starter, Excel 2013, Excel 2007



Was deze informatie nuttig?

Ja Nee

Wat kan er beter?

255 tekens resterend

Voeg ter bescherming van uw privacy geen contactgegevens aan uw feedback toe. Beoordeel onze privacybeleid.

Bedankt voor uw feedback.

Ondersteuningsbronnen

Taal wijzigen