TEKST (funksjon)

Obs!: Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

TEKST-funksjonen lar deg endre måten et tall vises på ved å bruke formatering på det med formatkoder. Det er nyttig i situasjoner der du vil vise tall i et mer lesbart format, eller der du vil kombinere tall med tekst eller symboler.

Obs!: TEKST-funksjonen konverterer tall til tekst, noe som kan gjøre det vanskelig å referere til tallene i senere beregninger. Det er best å beholde den opprinnelige verdien i en celle, og så bruke TEKST-funksjonen i en annen celle. Hvis du senere trenger å lage andre formler, referer alltid til den opprinnelige verdien og ikke resultatet av TEKST-funksjonen.

Syntaks

TEKST(verdi, format_tekst)

Syntaksen for TEKST-funksjonen har følgende argumentene:

Argumentnavn

Beskrivelse

verdi

En numerisk verdi du vil konvertere til tekst.

format_tekst

En tekststreng som definerer formateringen du vil bruke til den angitte verdien.

Oversikt

I sin enkleste form sier TEKST-funksjonen:

  • =TEKST(Verdi du vil formatere, «Formatkode du vil bruke»)

Her er noen populære eksempler, som du kan kopiere direkte inn i Excel for å eksperimentere på egen hånd. Legg merke til formatkodene i anførselstegn.

Formel

Beskrivelse

=TEKST(1234.567, «$#,##0.00»)

Valuta med tusenskilletegn og 2 desimaler, for eksempel $1,234.57. Legg merke til at Excel runder av verdien til 2 desimaler.

= TEKST(IDAG(),«MM/DD/ÅÅ»)

Dagens dato i MM/DD/ÅÅ format, for eksempel 03/14/12

=TEKST(IDAG(),«DDDD»)

Dagens ukedag, for eksempel mandag

= TEKST(NÅ(),«T: MM AM/PM»)

Gjeldende klokkeslett, for eksempel 13:29

= TEKST(0,285, «0,0%»)

Prosent, som 28,5 %

= TEXT(4.34,"# ?/?")

Brøk, som 4 1/3

= TRIMME (TEKST (0,34,«#? /?»))

Brøk, som 1/3 Legg merke til at dette bruker TRIMME-funksjonen til å fjerne innledende mellomrom med en desimalverdi.

= TEKST(12200000,«0,00E+00»)

Vitenskapelig notasjon, som 1,22E+07

=TEKST(1234567898,"[<=9999999]###-####;(###) ###-####")

Spesielle (telefonnummer), som (123) 456-7898

= TEKST(1234,«0000000»)

Legge til foranstilte nuller (0), som 0001234

=TEKST(123456,«##0° 00' 00»»)

Egendefinert - breddegrad/lengdegrad

Obs!: Men du kan bruke tekst-funksjonen til å endre formatering, er det ikke den eneste måten. Du kan endre formatet uten en formel ved å trykke CTRL + 1 (eller Bilde av ikonet for MAC-kommando-knappen + 1 på Mac), og velg ønsket format fra Formater celler > tall-dialogboksen.

Last ned eksemplene våre

Du kan laste ned en eksempelarbeidsboken med alle tekst-funksjonen eksemplene du finner i denne artikkelen, pluss noen tillegg. Du kan følge med, eller du kan opprette din egen tekst-funksjonen formatkoder.

Eksempler på Last ned Excel tekst-funksjonen

Andre formatkoder som er tilgjengelige

Du kan bruke dialogboksen Formater celler for å finne andre tilgjengelige formatkoder:

  1. Trykk CTRL+1 ( Bilde av ikonet for MAC-kommando-knappen +1 på Mac) for å hente frem dialogboksenFormater celler.

  2. Velg formatet du ønsker fra Tall-fanen.

  3. Velg Egendefinert-alternativet

  4. Formatkoden du vil ha vises nå i Type-boksen. I dette tilfellet merker du alt fra Type-boksen, unntatt semikolon (;) og @-symbolet. Vi valgte og kopierte bare mm/dd/åå i eksemplet nedenfor.

  5. Trykk CTRL+C Hvis du vil kopiere formatkoden, trykk Avbryt for å lukke dialogboksen Formater celler.

  6. Alt du trenger å gjøre er å trykke CTRL+V for å lime inn formatkoden i TEKST-formelen, for eksempel: = TEKST(B2,«mm/dd/åå»). Kontroller at du limer inn formatkoden i anførselstegn («formatkoden»), ellers vil Excel iverksette en feilmelding.

Eksempel på bruk av Format > Celler > Tall > Egendefinert dialogboks for å få Excel til å opprette formatstrenger for deg.

Formatkoder etter kategori

Nedenfor ser du noen eksempler på hvordan du kan bruke ulike tallformater til dine verdier ved hjelp av Formater celler-dialogboksen. Deretter kan du bruke Egendefinert-alternativet for å kopiere Formatkoder til din TEKST-funksjon.

Hvorfor sletter Excel mine innledende nuller?

Excel er kvalifisert til å søke etter tall som skrives inn i celler, ikke tall som ser ut som tekst, for eksempel delenummer eller SKU-er. Hvis du vil beholde foranstilte nuller, formater inndataområdet som tekst før du limer inn eller skrive inn verdier. Merk kolonnen eller området der du vil plassere verdiene, Bruk CTRL + 1 for å hente frem den Format > celler dialogboksen og merke tekst i tall-fanen. Nå Excel beholder din linjeavstand 0.

Hvis du allerede har skrevet inn data og Excel har fjernet de innledende nullene, kan du bruke TEKST-funksjonen for å legge dem til igjen. Du kan referere til den øverste cellen med verdiene og legge inn =TEKST(verdi,«00000»), der antall nuller i formelen representerer det totale antallet tegn du vil bruke, og deretter kopierer og limer du inn til resten av området.

Eksempler på bruk av TEKST til å formatere foranstilte nuller.  =TEKST(A2,"00000")

Hvis du av en eller annen grunn trenger å konvertere verdier tilbake til tall du kan multiplisere med 1, som =D4*1, eller bruke dobbelt-monooperatoren (--), som =--D4.

Excel skiller tusener med komma hvis formatet inneholder et komma (,) som er omsluttet av nummertegn (#) eller av nuller. Hvis for eksempel formatstrengen er «#,###» vil Excel vise tallet 12200000 som 12,200,000.

Et kolon som følger etter en sifferplassholder skalerer tallet med 1000. Hvis for eksempel formatstrengen er «#, ###.0,», viser Excel tallet 12200000 som 12,200.0.

Eksempler på at TEKST-funksjonen bruker tusenskilletegn

Obs!: 

  • Tusenskilletegnet er avhengig av de regionale innstillingene. Det er et komma i USA, men det kan være et punktum (.) på andre språk.

  • Tusenskilletegnet er tilgjengelig for tall- valuta- og regnskapsformatene.

Her følger eksempler på standard tall- (tusenskilletegnet og bare desimaler), valuta- og regnskapsformater. Valutaformat gjør at du kan sette inn det valutasymbolet du vil og at det justeres ved siden av verdien, mens regnskapformat vil justere valutasymbolet til venstre for cellen, og verdien til høyre. Vær oppmerksom på forskjellen mellom formatkoder for valuta og regnskap nedenfor, der regnskap bruker en stjerne (*) til å opprette skille mellom symbolet og verdien.

Eksempler på TEKST-funksjonen med formater for tall, valuta og regnskap

Hvis du vil finne formatkoden for et valutasymbol, må du først trykke CTR+1 (eller Bilde av ikonet for MAC-kommando-knappen + 1 på Mac), velge formatet du ønsker, og deretter velge et symbol fra Symbol rullegardinlisten:

Valutasymbol-utvalg fra dialogboksen Formater celler

Klikk deretter Egendefinert til venstre for Kategori-delen, og kopier formatkoden, inkludert valutasymbolet.

TEKST-funksjonen – egendefinert valuta med symbol

Obs!: TEKST-funksjonen støtter ikke fargeformatering, så hvis du kopierer en tallformatkode fra dialogboksen Formater celler som inneholder en farge, slik som dette: $#,##0.00_);[Rød]($#,##0.00), vil TEKST-funksjonen godta formatkoden, men den vil ikke vise fargen.

Du kan endre måten en dato vises på ved hjelp av en blanding av «M» for måned, «D» for dager og «Å» for år.

Formatkode for måned, dag og år

Formatkoder i TEKST-funksjonen skiller ikke mellom store og små bokstaver, så du kan bruke «M» eller «m», «D» eller «d», «Å» eller «å».

Excel-MVP Mynda Treacy

Mynda anbefaler...

Hvis du deler Excel-filer og rapporter med brukere fra forskjellige land, kan du ønsker å gi dem en rapport i språket. Excel MVP, Mynda Treacy har en flott løsning i denne artikkelen Excel datoer vises på forskjellige språk . Den inneholder også et eksempel på en arbeidsbok kan du laste ned.

Du kan endre måten klokkeslett vises ved hjelp av en blanding av «T» for timer, «M» for minutter, eller «S» for sekunder og «AM/PM» for en 12-timers klokke.

Klokkeslettformater for timer, minutter og sekunder

Hvis du utelater «AM/PM» eller «A/P», vil klokkeslett vises basert på en 24-timers klokke.

Formatkoder i TEKST-funksjonen skiller ikke mellom store og små bokstaver, så du kan bruke «T» eller «t», «M» eller «m», «S» eller «s», «AM/PM» eller «am/pm».

Du kan endre måten desimalverdier vises på med prosentformater (%).

Formatkoder for prosent

Du kan endre måten desimalverdier vises på med brøkformater (?/?).

Formatkoder for brøker

Vitenskapelig notasjon er en visning av tall i form av en desimal mellom 1 og 10, multiplisert med en potens av 10. Det brukes ofte til å forkorte måten store tall vises på.

Formatkoder for Vitenskapelig notasjon

Excel har 4 spesielle formateringer.

  • Postnummer - «0000»

  • Postnummer + 4 - «00000-0000»

  • Telefonnummer - «[<=9999999]###-####;(###) ###-####»

  • Personnummer - «000000-00000»

Spesielle formater for TEKST-funksjonen

Spesielle formater vil være forskjellige, avhengig av nasjonale innstillinger, men hvis det ikke finnes en spesiell formatering for dine nasjonale innstillinger, eller hvis disse ikke oppfyller behovene, kan du opprette din egen via dialogboksene Formater celler > Egendefinerte.

Vanlig scenario

Tekst -funksjonen brukes sjelden alene, og brukes vanligvis sammen med noe annet. La oss si at du vil slå sammen tekst og en tallverdi som "rapportere utskrevet: 03/14/12", eller "ukentlig inntekter: $66,348.72". Du kan skrive inn som i Excel manuelt, men som defeats formålet med har Excel gjøre det for deg. Dessverre når du kombinerer tekst og tall formatert, for eksempel datoer, klokkeslett, valuta, osv., Excel, ikke vet hvordan du vil vise dem, slik at den faller tallformatering. Dette er der tekst -funksjonen er uvurderlig, fordi det gjør det mulig å tvinge Excel til å formatere verdiene slik du ønsker ved hjelp av en kode foreksempel "MM/DD/åå" for datoformat.

I eksemplet nedenfor kan du se hva som skjer hvis du prøver å koble til tekst og et tall uten å bruke tekst -funksjonen. I dette tilfellet bruker vi ampersand (&) til å sette sammen en tekststreng, et mellomrom (""), og en verdi med = A2 & "" & B2.

Eksempel på å slå sammen tekst uten TEKST-funksjonen

Som du kan se, fjernet Excel formateringen fra datoen i celle B2. I neste eksempel ser du hvordan TEKST-funksjonen lar deg bruke det formatet du ønsker.

Eksempel på å slå sammen tekst med TEKST-funksjonen

Vår oppdaterte formel er:

  • Celle C2:=A2&« »&TEKST(B2,«mm/dd/åå») – datoformat

Vanlige spørsmål

Dessverre ikke at med tekst -funksjonen, du må bruke Visual Basic for Applications (VBA)-kode. Den følgende koblingen er en metode: hvordan du konverterer en numerisk verdi til engelske ord i Excel

Ja, du kan bruke funksjonene STORE, SMÅ og STOR FORBOKSTAV. =STORE(«hallo») vil for eksempel returnere «HALLO».

Ja, men det tar noen få trinn. Først velger du cellen eller cellene der du vil at dette skal skje og bruke Ctrl + 1 for å hente frem den Format > celler dialogboksen deretter Justering > tekstkontroll > Merk alternativet Bryt tekst. Deretter justere den ferdige tekst -funksjonen hvis du vil inkludere funksjonen ASCII Tegnkode(10) der du vil at linjeskiftet. Du må kanskje justere spaltebredden avhengig av hvordan det endelige resultatet justerer.

Eksempel på bruk av TEKST med TEGNKODE(10) til å sette inn et linjeskift. ="I dag er: "&CHAR(10))&TEKST(TODAY(),"MM/DD/YY")

I dette tilfellet brukte vi: =«I dag er:»&TEGNKODE(10)&TEKST(IDAG(),«mm/dd/åå»)

Dette kalles Vitenskapelig notasjon, og Excel vil automatisk konvertere tall som er lengre enn 12 sifre hvis en eller flere celler er formatert som Generelt, og 15 sifre hvis en eller flere celler er formatert som et Tall. Hvis du trenger å angi lange numeriske strenger, men ikke vil at de konverteres, så formaterer du de aktuelle cellene som Tekst før du skriver eller limer inn dine verdier i Excel.

Excel-MVP Mynda Treacy

Mynda anbefaler...

Hvis du deler Excel-filer og rapporter med brukere fra forskjellige land, kan du ønsker å gi dem en rapport i språket. Excel MVP, Mynda Treacy har en flott løsning i denne artikkelen Excel datoer vises på forskjellige språk . Den inneholder også et eksempel på en arbeidsbok kan du laste ned.

Se også

Opprette eller slette et egendefinert tallformat

Konverter tall som er lagret som tekst, til tall

Alle Excel-funksjoner (etter kategori)

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×