SUMMERPRODUKT (funksjon)

Denne artikkelen beskriver formelsyntaks for og bruk av funksjonen SUMMERPRODUKT i Microsoft Excel.

Beskrivelse

Multipliserer samsvarende komponenter i gitte matriser, og returnerer summen av disse produktene.

Syntaks

SUMMERPRODUKT(matrise1; [matrise2]; [matrise3]; ...)

Syntaksen for SUMMERPRODUKT har følgende argumenter:

  • Matrise1     Obligatorisk. Det første matriseargumentet som du vil multiplisere og deretter legge sammen.

  • Matrise2; matrise3;...     Valgfri. Matriseargumenter fra 2 til 255 med komponenter du vil multiplisere og deretter legge sammen.

Merknader

  • Matriseargumentene må ha samme dimensjoner. Hvis ikke, returnerer SUMMERPRODUKT feilverdien #VERDI!.

  • SUMMERPRODUKT behandler matriseverdier som ikke er numeriske, som null.

Eksempel

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Matrise 1

Matrise 2

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Beskrivelse

Resultat

=SUMMERPRODUKT(A2:B4; D2:E4)

Multipliserer alle komponenter i de to matrisene og legger deretter sammen produktene - det vil si 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×