Formler og funksjoner

Funksjonen SUMMER

SUMMER, funksjon

Obs!: Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

SUMMER-funksjonen, én av funksjonene for matematikk og trigonometri, legger sammen verdier. Du kan legge til enkeltverdier, cellereferanser eller celleområder, eller en blanding av alle tre.

Eksempel:

  • =SUMMER(A2:A10)

  • =SUMMER(A2:A10, C2:C10)

Nettleseren støtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

SUMMER(tall1;[tall2]; ...)

Argumentnavn

Beskrivelse

tall1    (obligatorisk)

Det første tallet du vil legge til. Nummeret kan være 4, en cellereferanse som B6, eller en celle område som B2:B8.

tall2-255    (valgfritt)

Dette er det andre tallet du legger til. Du kan angi opptil 255 tall på denne måten.

Denne delen drøfter noen anbefalte fremgangsmåter for arbeid med SUMMER-funksjoner. Mye av dette kan også anvendes på arbeid med andre funksjoner.

Metoden =1+2 eller =A+B – Selv om du kan legge inn =1+2+3 eller =A1+B1+C2 og få nøyaktige resultater, er disse metodene av forskjellige årsaker tilbøyelige til feil:

  1. Skrivefeil – Tenk deg at du skal skrive inn flere og/eller mye større verdier, som dette:

    • =14598,93+65437,90+78496,23

    Prøv deretter å validere at oppføringene er riktige. Det er mye enklere å plassere disse verdiene i individuelle celler og bruke en SUMMER-formel. I tillegg kan du formatere verdiene når de er i celler, slik at det blir mye enklere å lese dem når de er i en formel.

    Bruk SUMMER-funksjonen i stedet for hardkodede verdier i formler.  Formelen i celle D5 er =SUMMER(D2:D4)
  2. #VERDI! feil fra å referere til tekst i stedet for tall

    Hvis du bruker en formel som:

    • =A1+B1+C1 eller =A1+A2+A3

    Eksempel på dårlig formelbygging.  Formelen i celle D2 er =A2+B2+C2

    Formelen kan brytes hvis det finnes en ikke-numerisk verdi (tekst) i de refererte cellene, noe som kommer til å returnere en #VALUE! -feil. SUMMEN ignorerer tekst verdier, og gir deg summen av bare de numeriske verdiene.

    Riktig formelbygging.  I stedet for =A2+B2+C2, er formelen i D2 =SUMMER(A2:C2)
  3. #REF! feil fra sletting av rader eller kolonner

    #REF! feil forårsaket av sletting av en kolonne.  Formelen er endret til = a2 + #REF! + B2

    Hvis du sletter en rad eller kolonne, blir ikke formelen oppdatert for å utelate den slettede raden, og den vil returnere en #REF! feil, der en Summer-funksjon oppdateres automatisk.

    SUMMER-funksjonen justerer automatisk for innsatte eller slettede rader og kolonner
  4. Formler oppdaterer ikke referanser ved innsetting av rader eller kolonner

    = A+B+C-formler oppdateres ikke om du legger til rader

    Hvis du setter inn en rad eller kolonne, oppdateres ikke formelen for inkludering av raden som legges til der en SUMMER-funksjon ville blitt oppdatert automatisk (så lenge du ikke er utenfor området referert til i formelen). Dette er spesielt viktig hvis du forventer at formelen oppdateres og dette ikke skjer, da det vil gi deg ufullstendige resultater som du kanskje ikke fanger opp.

    Eksemplet viser en SUMMER-formel som automatisk utvides fra =SUMMER(A2:C2) til =SUMMMER(A2:D2) når det settes inn en kolonne
  5. SUMMER med enkeltvise cellereferanser kontra områder

    Bruk av en formel som:

    • =SUMMER(A1,A2,A3,B1,B2,B3)

    er like tilbøyelig til feil ved innsetting eller sletting av rader innenfor det refererte området, av samme årsaker. Det er mye bedre å bruke individuelle områder, som:

    • =SUMMER(A1:A3,B1:B3),

    som oppdateres når du legger til eller sletter rader.

Problem

Hva gikk galt

SUMMER-funksjonen min viser ##### i stedet for resultatet.

Kontroller kolonnebreddene. ##### betyr vanligvis at kolonnen er for smal til å vise resultatet av formelen.

SUMMER-funksjonen viser selve formelen som tekst, ikke resultatet.

Kontroller at cellen ikke er formatert som tekst. Merk den aktuelle cellen eller det aktuelle celleområdet, og bruk CTRL+1 for å åpne dialogboksen Formater celler og klikk deretter Tall-fanen og velg ønsket format. Hvis cellen er formatert som tekst og ikke endres etter at du har forandret formatet, kan det være du må bruke F2 > Enter for å tvinge endringen av formatet.

SUMMER-funksjonen min oppdateres ikke.

Kontroller at Beregning er satt til Automatisk. Gå til beregnings alternativerfanen formel . Du kan også bruke F9 for å tvinge beregning av regnearket.

Kontroller at beregning er satt til Automatisk.  På Formel-fanen går du til Beregningsalternativer.

Enkelte verdier legges ikke til.

Bare tallverdier i funksjonsreferansen eller -området kan legges til. Tomme celler, logiske verdier som SANN eller tekst ignoreres.

Feilen #NAVN? vises i stedet for det forventede resultatet.

Dette betyr vanligvis at formelen er feilstavet, for eksempel =sume(A1:A10) i stedet for =SUMMER(A1:A10).

Min SUMMER-funksjon viser et helt tall, men det skal vise desimaler

Kontroller celle formateringen for å sikre at du viser desimaler. Merk cellen eller området i spørsmålet, og bruk CTRL + 1 for å vise dialog boksen Formater celler , og klikk deretter kategorien tall og velg ønsket format, og pass på at du angir antallet desimaler du vil bruke.

  1. Jeg vil bare legge til/trekke fra/multiplisere/Dividere tall Se denne video serien i grunnleggende matematikk i Excel, eller Bruk Excel som kalkulator.

  2. Hvordan kan jeg vise flere/færre desimaler? Du kan endre tall formatet. Merk cellen eller området i spørsmålet, og bruk CTRL + 1 for å vise dialog boksen Formater celler , og klikk deretter kategorien tall og velg ønsket format, og pass på at du angir antallet desimaler du vil bruke.

  3. Hvordan legge til eller trekke fra tid? Du kan legge til og trekke fra tid på et par forskjellige måter. For eksempel kan du finne forskjellen mellom 08:00 – 12:00 for lønnsformål ved på bruke =(«12:00»-«08:00»)*24, som tar sluttidspunktet minus starttidspunktet. Legg merke til at Excel beregner tidsrom som brøker av et døgn, så du må multiplisere med 24 å få totalt antall timer. I det første eksemplet bruker vi =((B2-A2)+(D2-C2))*24 for å få summen av timer fra start til slutt, minus en lunsjpause (8,50 timer totalt).

    Hvis du bare vil legge til timer og minutter og vil vise på denne måten, kan du summere og trenger ikke å multiplisere med 24, slik at vi i det andre eksemplet bruker =SUMMER(A6:C6) fordi vi trenger bare det totale antallet timer og minutter for tildelte aktiviteter (5:36 eller 5 timer, 36 minutter).

    Beregn tidsrom

    Hvis du vil ha mer informasjon, kan du se: Legge til eller trekke fra tid.

  4. Hvordan beregner jeg forskjellen mellom datoer? I likhet med tidspunkt kan du addere og subtrahere datoer. Her er et svært vanlig eksempel på hvordan å telle antall dager mellom to datoer. Det er så enkelt som =B2-A2. Nøkkelen til å arbeide med både datoer og klokkeslett er at du starter med sluttdato/sluttid og trekker fra startdato/starttid.

    Beregn forskjeller mellom datoer

    Hvis du vil ha flere måter å arbeide med datoer på, kan du se: beregne forskjellen mellom to datoer.

  5. Hvordan summerer jeg bare synlige celler? Noen ganger når du manuelt skjuler radene eller bruker AutoFilter for å vise bare bestemte data, vil du også bare summere de synlige cellene. Du kan bruke TOTALSUM-funksjonen. Hvis du bruker en totalrad i en Excel-tabell, legges funksjoner du velger fra Total-rullegardinlisten automatisk inn som en totalsum. Se mer informasjon om hvordan du summerer dataene i en Excel-tabell.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Finn ut mer om Summer

SUMMERHVIS-funksjonen legger bare sammen verdiene som oppfyller ett enkelt vilkår

SUMMER.HVIS.SETT-funksjonen legger bare sammen verdiene som oppfyller flere vilkår

ANTALL.HVIS-funksjonen teller bare verdiene som oppfyller ett enkelt vilkår

ANTALL.HVIS.SETT -funksjonen teller bare verdiene som oppfyller flere vilkår

Oversikt over formler i Excel

Unngå formler med feil

Finne og rette feil i formler

Hurtigtaster i Excel for Windows

Hurtigtaster i Excel for Mac

Matematikk- og trigonometri-funksjoner

Funksjoner i Excel (alfabetisk)

Excel-funksjoner (etter kategori)

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×