Slik retter du en #REF!-feilmelding

Slik retter du en #REF!-feilmelding

Obs!: Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

Den #REF! feil viser når en formel refererer til en celle som ikke er gyldig. Dette skjer oftest når celler som er referert til i formler få slettet eller limt over.

Eksempel – #REF!-feilen ble forårsaket ved å slette en kolonne

Følgende eksempel bruker formelen =SUM(B2,C2,D2) for kolonne E.

En formel som bruker eksplisitte cellereferanser, som =SUM(B2,C2,D2), kan føre til en #REF!-feil hvis en kolonne blir slettet.

Hvis du vil slette kolonne B, C eller D det vil føre til #REF! feil. I dette tilfellet vi skal slette kolonne C (2007 salg), og formelen nå heter =SUM(B2,#REF!,C2). Når du bruker eksplisitte cellereferanser slik ut (der du refererer til hver celle enkeltvis, atskilt med semikolon) og slette en refererte rad eller kolonne, kan ikke løses, slik at det returnerer feilverdien #REF! feil. Dette er de viktigste grunnen Hvorfor bruke eksplisitte cellereferanser i funksjoner ikke anbefales.

Eksempel på en #REF!-feil forårsaket ved å slette en kolonne.

Løsning

  • Hvis du ved et uhell slettet rader eller kolonner, kan du umiddelbart klikke Angre-knappen på verktøylinjen for hurtigtilgang (eller trykke CTRL+Z) for å gjenopprette dem.

  • Justere formelen slik at den bruker en områdereferanse i stedet for enkeltceller, for eksempel =SUM(B2:D2). Nå kan du slette en kolonne i området summer og Excel justeres automatisk formelen. Du kan også bruke =SUM(B2:B5) for en sum av rader.

Eksempel – FINN.RAD med feil områdereferanser

I eksemplet nedenfor vil =FINN.RAD(A8,A2:D5,5,USANN) returnere en #REF!-feil fordi den leter etter en verdi å returnere fra kolonne 5, men referanseområdet er A:D, som bare er 4 kolonner.

Eksempel på en FINN.RAD-formelen med feil område.  Formelen er =FINN.RAD(A8,A2:D5,5,USANN).  Det er ingen femte kolonne i området FINN.RAD, slik at 5 fører til en #REF!-feil.

Løsning

Justere området slik at det blir større, eller Reduser oppslagsverdien kolonne for å samsvare med referanse-området. =VLOOKUP(a8,a2:E5,5,False) er en gyldig referanse-område, måte = VLOOKUP(A8,A2:D5,4,FALSE).

Eksempel – INDEKS med feil referanserad eller -kolonne

I dette eksemplet returnerer formelen =INDEKS(B2:E5,5,5) feilverdien #REF! fordi INDEKS-området er på 4 rader ved 4 kolonner, men formelen ber om å returnere hva som er i 5. rad og 5. kolonne.

Eksempel på en INDEKS-formel med en ugyldig områdereferanse.  Formelen er =INDEKS(B2:E5,5,5), men området er bare 4 rader ganger 4 kolonner.

Løsning

Justere referansene raden eller kolonnen slik at de er innenfor området indeks oppslag. =INDEX(B2:E5,4,4) returnere et gyldig resultat.

Eksempel – refererer til en lukket arbeidsbok med INDIREKTE

I eksemplet nedenfor forsøker en INDIREKTE-funksjon å referere til en arbeidsbok som er lukket, noe som forårsaker en #REF!-feil.

Eksempel på en #REF!-feil forårsaket av indirekte refererer til en lukket arbeidsbok.

Løsning

Åpne refererte arbeidsboken. Du kan støte på samme feil hvis du refererer til en lukket arbeidsbok med en dynamisk matriseformel.

OLE-problemer

Hvis du har brukt kobling og innebygging av objekter (OLE) som returnerer en #REF!-feil, og deretter starter programmet som koblingen kaller på.

Obs! OLE er en teknologi som du kan bruke til å dele informasjon mellom programmer.

DDE-problemer

Hvis du har brukt et emne (dynamisk Datautveksling), som returnerer feilverdien #REF! feil, første Kontroller at du er refererer til det riktige emnet. Hvis du fortsatt får feilen #REF! feil, og kontroller Innstillinger for klareringssenter for eksternt innhold som beskrives i blokkere eller oppheve blokkering av eksternt innhold i Office-dokumenter.

Notat: Dynamisk datautveksling (DDE)er en etablert protokoll for utveksling av data mellom Microsoft Windows-baserte programmer.

Makro-problemer

Hvis en makro som angir en funksjon i regnearket som refererer til en celle over funksjonen og cellen som inneholder funksjonen er i rad 1, returnerer funksjonen #REF! fordi det ikke finnes noen celler over rad 1. Kontroller om funksjonen for å se et argument som refererer til en celle eller celleområde som ikke er gyldig. Dette kan kreve redigere makroen i Visual Basic Editor (VBE) til å ta denne situasjonen til kontoen.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Oversikt over formler i Excel

Unngå formler med feil

Bruke feilkontroll for å oppdage feil i formler

Funksjoner i Excel

Excel-funksjoner (etter kategori)

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×