Office
Logg på

Slå opp verdier med FINN.RAD, INDEKS eller SAMMENLIGNE

Obs!:  Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

Anta at du har en liste over kontornumre plassering, og du må vite hvilke ansatte som er i hver office. Regnearket er stort, så du tror det er det en utfordring oppgave. Det er faktisk ganske enkelt å gjøre med en oppslagsfunksjon.

Funksjonene Finn.rad og Finn.kolonne , sammen med indeks og sammenligne,er noen av de mest nyttige funksjonene i Excel.

Obs!: Funksjonen oppslagsveiviseren ikke lenger tilgjengelig i Excel.

Her er et eksempel på hvordan du bruker Finn.rad.

=FINN.RAD(B2;C2:E7;3;SANT)

I dette eksemplet er B2 det første argumentet– et dataelement som funksjonen skal fungere. For Finn.rad er dette første argumentet verdi som du vil finne. Dette argumentet kan være en cellereferanse eller en fast verdi for eksempel "Jensen" eller 21 000. Det andre argumentet er celleområdet, C2-:E7, der du vil søke etter verdi du vil finne. Det tredje argumentet er kolonnen i celleområdet som inneholder verdien du søker etter.

Det fjerde argumentet er valgfritt. Angi TRUE eller FALSE. Hvis du angir SANN eller utelater argumentet tom, returnerer funksjonen et omtrentlig samsvar av verdien du angir i det første argumentet. Hvis du angir USANN, funksjonen tilsvarer verdien gi ved det første argumentet. Med andre ord, slik at det fjerde argumentet tomt, eller skrive inn SANN, gir deg mer fleksibilitet.

Dette eksemplet viser hvordan funksjonen virker. Når du angir en verdi i celle B2 (det første argumentet), Finn.rad søker cellene i området C2:E7 (2-argumentet), og returnerer den nærmeste omtrentlig samsvar fra den tredje kolonnen i området, kolonne E (3-argumentet).

Et typisk eksempel på bruk av FINN.RAD-funksjonen

Det fjerde argumentet er tom, dermed gir funksjonen et omtrentlig samsvar. Hvis ikke, må du angi en av verdiene i kolonnene C eller D for å få et resultat i det hele tatt.

Når du er komfortabel med Finn.rad, er Finn.kolonne-funksjonen like enkelt å bruke. Du angir de samme argumentene, men den søker i rader i stedet for kolonner. "

Prøv det

Hvis du ønsker å eksperimentere med oppslagsfunksjoner før du prøver dem med dine egne data, kan du her er noen eksempeldata. Noen Excel-brukere som når du bruker Finn.rad og Finn.kolonne; Andre foretrekker å bruke indeks og sammenligne sammen. Prøv hver metode og se hvilke du liker best.

Finn.rad-eksempel på jobben

Kopier følgende data til et tomt regneark..

Tips:    Angi bredden til kolonne A og b til 250 piksler før du limer inn dataene i Excel, og klikk Bryt tekst (kategorienHjem, Justering-gruppen).

Tetthet

Viskositet

Temperatur

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formel

Beskrivelse

Resultat

=FINN.RAD(1;A2:C10;2)

Søker etter verdien 1 i kolonne A med bruk av tilnærmet samsvar, og finner den største verdien som er mindre enn eller lik 1 (0,946) i kolonne A, og returnerer deretter verdien fra kolonne B i samme rad.

2,17

=FINN.RAD(1;A2:C10;3;SANN)

Søker etter verdien 1 i kolonne A med bruk av tilnærmet samsvar, og finner den største verdien som er mindre enn eller lik 1 i kolonne A, som er 0,946, og returnerer deretter verdien fra kolonne C i samme rad

100

=FINN.RAD(0,7;A2:C10;3;USANN)

Søker etter verdien 0,7 i kolonne A med bruk av nøyaktig samsvar. Siden det ikke finnes noen nøyaktig samsvarende verdier i kolonne A, returneres en feil.

#I/T

=FINN.RAD(0,1;A2:C10;2;SANN)

Søker etter verdien 0,1 i kolonne A med bruk av tilnærmet samsvar. Ettersom 0,1 er mindre enn den minste verdien i kolonne A, returneres en feil.

#I/T

=FINN.RAD(2;A2:C10;2;SANN)

Søker etter verdien 2 i kolonne A med bruk av tilnærmet samsvar, finner den største verdien som er mindre enn eller lik 2 i kolonne A, som er 1, 29, og returnerer deretter verdien fra kolonne B i samme rad.

1,71

Finn.kolonne-eksempel

Kopier alle cellene i denne tabellen, og lim dem inn i celle A1 i et tomt regneark i Excel.

Tips:    Angi bredden til kolonne A og b til 250 piksler før du limer inn dataene i Excel, og klikk Bryt tekst (kategorienHjem, Justering-gruppen).

Aksler

Lagre

Bolter

4

4

9

5

7

10

6

8

11

Formel

Beskrivelse

Resultat

=FINN.KOLONNE("Aksler";A1:C4;2;SANN)

Slår opp Aksler i rad 1, og returnerer verdien fra rad 2 i samme kolonne (kolonne A).

4

=FINN.KOLONNE("Lagre";A1:C4;3;USANN)

Slår opp Lagre i rad 1, og returnerer verdien fra rad 3 i samme kolonne (kolonne B).

7

=FINN.KOLONNE("B";A1:C4;3;SANN)

Slår opp B i rad 1, og returnerer verdien fra rad 3 i samme kolonne. I og med at et eksakt samsvar med B ikke blir funnet, brukes den største verdien i rad 1 som er større enn B: Aksler i kolonne A.

5

=FINN.KOLONNE("Bolter";A1:C4;4)

Slår opp Bolter i rad 1, og returnerer verdien fra rad 4 i samme kolonne (kolonne C).

11

=FINN.KOLONNE(3; {1;2;3\"a";"b";"c"\"d";"e";"f"}; 2; SANN)

Slår opp tallet 3 i den trerads matrisekonstanten, og returnerer verdien fra rad 2 i den samme (i dette tilfellet tredje) kolonnen. Det er tre rader med verdier i matrisekonstanten, og hver rad er atskilt med en omvendt skråstrek (\). Fordi c finnes i rad 2 og i samme kolonne som 3, returneres c.

c

INDEKS og sammenligne eksempler

Det siste eksemplet bruker funksjonene indeks og sammenligne sammen til å returnere tidligste fakturanummeret og den tilsvarende datoen for hver av fem steder. Fordi datoen returneres som et tall, kan vi bruke tekst-funksjonen til å formatere den som en dato. INDEKS-funksjonen bruker faktisk resultatet av sammenligne-funksjonen som argument. Brukes kombinasjonen av funksjonene indeks og sammenligne to ganger i hver formel – først til å returnere fakturanummeret, og deretter for å returnere datoen.

Kopier alle cellene i denne tabellen, og lim dem inn i celle A1 i et tomt regneark i Excel.

Tips:    Angi bredden til kolonne A og D til 250 piksler før du limer inn dataene i Excel, og klikk Bryt tekst (kategorienHjem, Justering-gruppen).

Faktura

By

Fakturadato

Tidligste faktura etter by, med dato

3115 som gir

Atlanta

07.04.2012

="Atlanta = "&INDEKS($A$2:$C$33;SAMMENLIGN("Atlanta";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Atlanta";$B$2:$B$33;0);3);"dd.mm.yyyy")

3137

Atlanta

09.04.2012

="Austin = "&INDEKS($A$2:$C$33;SAMMENLIGN("Austin";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Austin";$B$2:$B$33;0);3);"dd.mm.yyyy")

3154

Atlanta

11.04.2012

="Dallas = "&INDEKS($A$2:$C$33;SAMMENLIGN("Dallas";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Dallas";$B$2:$B$33;0);3);"dd.mm.yyyy")

3191

Atlanta

21.04.2012

="New Orleans = "&INDEKS($A$2:$C$33;SAMMENLIGN("New Orleans";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("New Orleans";$B$2:$B$33;0);3);"dd.mm.yyyy")

3293

Atlanta

25.04.2012

="Tampa = "&INDEKS($A$2:$C$33;SAMMENLIGN("Tampa";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Tampa";$B$2:$B$33;0);3);"dd.mm.yyyy")

3331

Atlanta

27.04.2012

3350

Atlanta

28.04.2012

3390

Atlanta

01.05.2012

3441

Atlanta

02.05.2012

3517

Atlanta

08.05.2012

3124

Austin

09.04.2012

3155

Austin

11.04.2012

3177

Austin

19.04.2012

3357

Austin

28.04.2012

3492

Austin

06.05.2012

3316

Dallas

25.04.2012

3346

Dallas

28.04.2012

3372

Dallas

01.05.2012

3414

Dallas

01.05.2012

3451

Dallas

02.05.2012

3467

Dallas

02.05.2012

3474

Dallas

04.05.2012

3490

Dallas

05.05.2012

3503

Dallas

08.05.2012

3151

New Orleans

09.04.2012

3438

New Orleans

02.05.2012

3471

New Orleans

04.05.2012

3160

Tampa

18.04.2012

3328

Tampa

26.04.2012

3368

Tampa

29.04.2012

3420

Tampa

01.05.2012

3501

Tampa

06.05.2012

Lær mer om oppslagsfunksjoner

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×