INDEKS (funksjon)

INDEKS-funksjonen returnerer en verdi eller referansen til en verdi fra en tabell eller et område.

Nettleseren støtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Det finnes to måter å bruke INDEKS-funksjonen på:

  • Hvis du vil returnere verdien til en angitt celle eller matrise av celler, kan du se Matriseform.

  • Hvis du vil returnere en referanse til angitte celler, kan du se Referanseform.

Matriseform

Beskrivelse

Returnerer verdien av et element i en tabell eller matrise, som er valgt av rad-og Kol onne nummer indeksene.

Bruk matriseformelen hvis det første argumentet i INDEKS er en matrisekonstant.

Syntaks

INDEKS(matrise; rad_nr; [kolonne_nr])

Matrise-skjemaet for indeks-funksjonen har følgende argumenter:

  • styre    Obligatorisk. Et celleområde eller en matrisekonstant.

    • Hvis matrise bare inneholder én rad eller kolonne, er det tilsvarende argumentet rad_nr eller kolonne_nr valg fritt.

    • Hvis matrise har mer enn én rad og mer enn én kolonne, og bare rad_nr eller kolonne_nr brukes, returnerer indeks en matrise av hele raden eller kolonnen i matrisen.

  • rad_nr    Obligatorisk. Velger raden i en matrise som en verdi skal returneres fra. Hvis rad_nr utelates, kreves kolonne_nr.

  • kolonne_nr    Valgfri. Velger kolonnen i en matrise som en verdi skal returneres fra. Hvis kolonne_nr utelates, kreves rad_nr.

Merknader

  • Hvis både rad_nr-og kolonne_nr-argumentene brukes, returnerer INDEKS verdien i cellen i skjærings punktet mellom rad_nr og kolonne_nr.

  • rad_nr og kolonne_nr må peke på en celle i matrisen. Hvis ikke, returnerer indeks en #REF! .

  • Hvis du angir rad_nr eller kolonne_nr til 0 (null), returnerer indeks matrisen for verdier for hele kolonnen eller raden. Hvis du vil bruke verdier som returneres som en matrise, skriver du inn indeks-funksjonen som en matriseformel.

    Obs!: Hvis du har en gjeldende versjon av Office 365, kan du skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke Enter for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved først å velge utdataområdet, skrive inn formelen i øverste venstre celle i utdataområdet, og deretter trykke CTRL + SKIFT + ENTER for å bekrefte det. Excel setter inn klammeparenteser i begynnelsen og slutten av formelen for deg. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

Eksempler

Eksempel 1

Disse eksemplene bruker INDEKS-funksjonen til å finne verdien i cellen i skjæringspunktet der en rad og kolonne møtes.

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker på F2 og deretter ENTER.

Data

Data

Epler

Sitroner

Bananer

Pærer

Formel

Beskrivelse

Resultat

=INDEKS(A2:B3,2,2)

Verdien i skjæringspunktet mellom andre rad og andre kolonne i området A2:B3.

Pærer

=INDEKS(A2:B3;2;1)

Verdien i skjæringspunktet mellom andre rad og første kolonne i området A2:B3.

Bananer

Eksempel 2

Dette eksemplet bruker INDEKS-funksjonen i en matriseformel til å finne verdiene i to celler angitt i en 2x2-matrise.  

Obs!: Hvis du har en gjeldende versjon av Office 365, kan du skrive inn formelen i cellen øverst til venstre i utdataområdet, og deretter trykke Enter for å bekrefte formelen som en dynamisk matriseformel. Ellers må formelen angis som en eldre matriseformel ved først å merke to tomme celler, skrive inn formelen i øverste venstre celle i utdataområdet, og deretter trykke CTRL + SKIFT + ENTER for å bekrefte den. Excel setter inn klammeparenteser i begynnelsen og slutten av formelen for deg. Hvis du vil ha mer informasjon om matriseformler, kan du se retningslinjer og eksempler på matriseformler.

Formel

Beskrivelse

Resultat

=INDEKS({1,2;3,4},0,2)

Verdien i første rad, andre kolonne i matrisen. Matrisen inneholder 1 og 2 i første rad og 3 og 4 i andre rad.

2

Verdien i andre rad, andre kolonne i matrisen (samme matrise som ovenfor).

4

Til toppen av siden


Referanse skjema

Beskrivelse

Returnerer referansen for cellen i skjæringspunktet mellom en bestemt rad eller kolonne. Hvis referansen består av ikke-sammenhengende utvalg, kan du velge utvalget du vil søke i.

Syntaks

INDEKS(referanse; rad_nr;[kolonne_nr]; [område_nr])

Referanse skjemaet for indeks-funksjonen har følgende argumenter:

  • refererer    Obligatorisk. En referanse til ett eller flere celleområder.

    • Hvis du skriver inn et ikke-sammenhengende område for referansen, setter du referansen i parentes.

    • Hvis hvert område i referanse bare inneholder én rad eller kolonne, er henholdsvis rad_nr-eller kolonne_nr-argumentet valg fri. For en referanse til en enkelt rad, bruker du for eksempel INDEKS(referanse;kolonne_nr).

  • rad    Obligatorisk. Nummeret på raden i referanse som en referanse returneres fra.

  • kolonne_nr    Valgfri. Nummeret på kolonnen i referanse som en referanse returneres fra.

  • kolonne    Valgfri. Velger et område i referanse som skjærings punktet for rad_nr og kolonne_nr returneres fra. Det første området som velges eller skrives inn, er nummerert 1, det andre er 2 og så videre. Hvis område_nr utelates, bruker INDEKS område 1.  Områdene som er oppført her, må være plassert på ett ark.  Hvis du angir områder som ikke er på samme ark som hverandre, vil det føre til en #VALUE! .  Hvis du trenger å bruke områder som er plassert i forskjellige ark fra hverandre, anbefales det at du bruker matrise-skjemaet i indeks-funksjonen, og bruk en annen funksjon til å beregne området som utgjør matrisen.  Du kan for eksempel bruke Velg-funksjonen til å beregne hvilket område som skal brukes.

Hvis for eksempel referanse beskriver cellene (a1: B4; D1: E4; G1: H4); område_nr 1 er området a1: B4, område_nr 2 er området D1: E4 og område_nr 3 er området G1: H4.

Merknader

  • Når referanse og område_nr har merket et bestemt område, velger rad_nr og kolonne_nr en bestemt celle: rad_nr 1 er den første raden i området, kolonne_nr 1 er den første kolonnen og så videre. Referansen som returneres av indeks, er skjærings punktet mellom rad_nr og kolonne_nr.

  • Hvis du angir rad_nr eller kolonne_nr til 0 (null), returnerer indeks referansen for hele kolonnen eller raden.

  • Rad_nr, kolonne_nr og område_nr må peke på en celle innenfor referansen; Hvis ikke, returnerer indeks en #REF! . Hvis rad_nr og kolonne_nr utelates, returnerer INDEKS området i referansen som er angitt av område_nr.

  • Resultatet av INDEKS-funksjonen er en referanse og tolkes som en referanse av andre formler. Avhengig av formelen, kan returverdien fra INDEKS brukes som en referanse eller som en verdi. Formelen CELLE("bredde";INDEKS(A1:B2;1;2)) er for eksempel ekvivalent med CELLE("bredde";B1). CELLE-funksjonen bruker returverdien fra INDEKS som en cellereferanse. På den andre siden vil en formel som for eksempel 2*INDEKS(A1:B2;1;2) oversette returverdien fra INDEKS til tallet i celle B1.

Eksempler

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER.

Frukt

Pris

count

Epler

$0.69

40

Bananer

$0.34

38

Sitroner

$0.55

15

Appelsiner

$0.25

23

Pærer

$0.59

40

Mandler

$2.80

10

Acajounøtter

$3.55

16

Peanøtter

$1.25

20

Valnøtter

$1.75

12

Formel

Beskrivelse

Resultat

=INDEKS(A2:C6;2;3)

Skjæringspunktet mellom den andre raden og den tredje kolonnen i området A2:C6, som er innholdet i celle C3.

38

=INDEKS((A1:C6;A8:C11);2;2;2)

Skjæringspunktet mellom den andre raden og den andre kolonnen i det andre området for A8:C11, som er innholdet i celle B9.

1,25

=SUMMER(INDEKS(A1:C11;0;3;1))

Summen av den tredje kolonnen i det første området av område A1:C11, som er summen av C1:C11.

216

=SUMMER(B2:INDEKS(A2:C6;5;2))

Summen av området som starter i B2, og slutter i skjæringspunktet mellom den femte raden og den andre kolonnen i området A2:A6, som er summen av B2:B6.

2,42

Til toppen av siden

Se også

FINN.RAD (funksjon)

SAMMENLIGNE (funksjon)

INDIREKTE (funksjon)

Retningslinjer og eksempler på matriseformler

Oppslags- og referansefunksjoner (referanse)

Obs!:  Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig? Her er den engelske artikkelen for referanse.

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×