Bruke HVIS til å sjekke om en celle er tom

Obs!: Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

Noen ganger må du sjekke om en celle er tom, vanligvis fordi du ikke vil at en formel skal vise et resultat uten inndata.

Formelen i celle E2 er =HVIS(D2=1,"Ja",HVIS(D2=2,"Nei","Kanskje"))

I dette tilfellet bruker vi HVIS med ERTOM-funksjonen:

  • =HVIS(ERTOM(D2), "Tom", "Ikke tom")

Som sier HVIS(D2 er tom, returner resultatet «Tom», og hvis ikke, returner «Ikke tom»). Du kan også bruke din egen formel for «Ikke tom»-betingelsen. I neste eksempel bruker vi «» i stedet for ERTOM. I praksis betyr «» «ingenting».

Sjekk om en celle er tom – formel i celle E2 er =HVIS(ERTOM(D2),"Tom","Ikke tom")

=HVIS(D3="","Tom", "Ikke tom")

Denne formelen sier HVIS(D3 er tom, returner resultatet «Tom», og hvis ikke, returner «Ikke tom»). Her er et eksempel på en svært vanlig måte å bruke «» på for å hindre at en formel beregner hvorvidt en underordnet celle er tom:

  • =HVIS(D3="","",DinFormel())

    Hvis (D3 er ingenting, og deretter retur ingenting, ellers beregne formelen).

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×