VELG (funksjon)

Denne artikkelen beskriver formelsyntaks for og bruk av funksjonen VELG i Microsoft Excel.

Beskrivelse

Returnerer en verdi fra listen over verdiargumenter ved hjelp av indekstall. Bruk VELG til å velge én av opptil 254 verdier basert på indekstallet. Hvis for eksempel verdi1 til og med verdi7 er ukedagene, returnerer VELG én av dagene når et tall mellom 1 og 7 brukes som indekstall.

Syntaks

VELG(indeks; verdi1; [verdi2]; ...)

Syntaksen for VELG-funksjonen har følgende argumenter:

  • Indeks    Obligatorisk. Angir hvilket verdiargument som er valgt. Indeks må være et tall mellom 1 og 254, eller en formel eller referanse til en celle som inneholder et tall mellom 1 og 254.

    • Hvis indeks er 1, returnerer VELG verdi1. Hvis den er 2, returnerer VELG verdi2 og så videre.

    • Hvis indeks er mindre enn 1 eller større enn tallet for den siste verdien i listen, returnerer VELG feilverdien #VERDI!.

    • Hvis indeks er en brøk, blir den avkortet til det laveste heltallet før den brukes.

  • Verdi1;verdi2;...     Verdi 1 er obligatorisk, og etterfølgende verdier er valgfritt. 1 til 254 verdiargumenter som VELG velger en verdi eller en handling som skal utføres basert på indeks, fra. Argumentene kan være tall, cellereferanser, definerte navn, formler, funksjoner eller tekst.

Kommentarer

  • Hvis indeks er en matrise, beregnes alle verdier når VELG beregnes.

  • Verdiargumentene for VELG kan både være områdereferanser og enkeltverdier.

    Formelen:

=SUMMER(VELG(2;A1:A10;B1:B10;C1:C10))

returnerer for eksempel:

=SUMMER(B1:B10)

som deretter returnerer en verdi basert på verdiene i området B1:B10.

VELG-funksjonen beregnes først og returnerer referansen B1:B10. SUMMER-funksjonen beregnes deretter ved å bruke B1:B10, resultatet av VELG-funksjonen, som argumentet.

Eksempler

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Data

 

Første

Spikre

Andre

Skruer

Tredje

Muttere

Fullført

Bolter

Formel

Beskrivelse

Resultat

=VELG(2;A2;A3;A4;A5)

Verdien til det andre listeargumentet (verdien i celle A3)

Andre

=VELG(4;B2;B3;B4;B5)

Verdien til det fjerde listeargumentet (verdien i celle B5)

Bolter

=VELG(3;"Hele";115;"verden";8)

Verdien til det tredje listeargumentet

verden

Eksempel 2

Data

2, 3

4,5

12

10

Formel

Beskrivelse (Resultat)

Resultat

=SUMMER(A2:VELG(2;A3;A4;A5))

Legger sammen området A2:A4. VELG-funksjonen returnerer A4 som den andre delen av området for SUMMER-funksjonen.

80

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×