Unngå formler med feil

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

Når formler viser utilsiktede resultater eller feil, kan det være veldig frustrerende, spesielt hvis du ikke vet hva du skal gjøre.

En rekke ting kan være feil. Det kan for eksempel være parenteser som mangler, skrivefeil eller referanser til data i områder som ikke finnes. Følgende anbefalte fremgangsmåter kan hjelpe deg med å forebygge eller løse vanlige feil når du bygger formler eller trenger å rette dem.

Bruk denne anbefalte fremgangsmåten:

Slik unngår du denne vanlige feilen:

Start alle funksjoner med et likhetstegn (=)

Hvis oppføringen ikke starter med et likhetstegn, er det ikke en formel og blir ikke beregnet – en vanlig feil som er lett å gjøre.

Hvis du for eksempel skriver SUMMER(A1:A10), viser Excel Online tekststrengen SUMMER(A1:A10) i stedet for et formelresultat. Hvis du skriver 2/11, vises en dato, for eksempel 2. nov eller 02/11/2009, i stedet for å dele 2 på 11.

For å unngå disse uventede resultatene, må du alltid begynne med et likhetstegn. Skriv for eksempel =SUMMER(A1:A10) og =2/11

Sørg for at det er like mange venstre- og høyreparenteser

Kontroller at alle parenteser er i par. I en formel som bruker en funksjon, må hver venstreparentes ha en høyreparentes for at funksjonen skal fungere som den skal.

Formelen =HVIS(B5<0);"Ikke gyldig";B5*1,05) vil for eksempel ikke fungere fordi det er to høyreparenteser og bare én venstreparentes.

Riktig formel ser slik ut: =HVIS(B5<0;"Ikke gyldig";B5*1,05 ).

Angi alle nødvendige argumenter

De fleste funksjoner har obligatoriske argumenter, det vil si verdier som du må angi for at funksjonen skal fungere. Det er bare noen funksjoner (som PI eller IDAG) som ikke har noen argumenter. Kontroller formelsyntaksen som vises når du begynner å skrive et likhetstegn etterfulgt av en funksjon, for å forsikre deg om at du skriver inn alle nødvendige argumenter, verken mer eller mindre.

STORE-funksjonen godtar for eksempel bare én tekststreng eller cellereferanse som argument: =STORE("hallo") eller =STORE(C2)

Og enkelte funksjoner, for eksempel SUMMER, krever bare numeriske argumenter, mens andre funksjoner, for eksempel ERSTATT, krever en tekstverdi for minst ett av argumentene. Hvis du bruker feil datatype, kan noen funksjoner returnere uventede resultater, eller vise en #VERDI!-feil.

Bruke uformaterte tall i formler

Ikke skriv inn tall som er formatert med dollartegn ($) eller semikolon (;) i formler, fordi dollartegn angir absolutte referanser, og semikolon er skilletegn mellom argumenter. Formaterte tall brukes ikke i beregningen av formelen. I stedet for å skrive inn $1000, skriver du inn 1000 i formelen.

Hvis du bruker formaterte tall i argumenter, vil du få uventede beregningsresultater, men det kan også oppstå en #NUM!-feil . Hvis du for eksempel skriver inn formelen =ABS(-2;134) for å finne den absolutte verdien av -2134, vises det en #NUM!-feil i Excel Online fordi ABS-funksjonen bare godtar ett argument.

Du kan formatere resultatet av formelen med semikolon og valutasymboler etter at du har skrevet inn formelen ved hjelp av uformaterte tall ved å bruke et tallformat.

Bruk riktig datatype i cellen

Formelen kan ikke returnere forventede resultater hvis datatypen i cellen ikke kan brukes i beregninger.

Hvis du for eksempel skriver inn en enkel formel, =2+3, i en celle som er formatert som tekst, kan ikke Excel Online beregne dataene du har angitt. Alt du ser i cellen, er =2+3.

Du kan løse dette ved å endre datatypen i cellen fra Tekst til Standard på denne måten:

  1. Merk cellen.

  2. Klikk Hjem > Tallformat-pilen, og velg Standard.

  3. Trykk F2 for å aktivere redigeringsmodus for cellen, og trykk deretter ENTER for å godta formelen.

Datoen du angir i en celle som har datatypen Tall, kan vises som en numerisk datoverdi i stedet for en dato. Velg et Dato-format i Tallformat-galleriet for å vise dette tallet som en dato.

Bruk * til å multiplisere tall

Det kan hende du vil bruke x som multiplikasjonstegn i en formel, men du må bruke en stjerne (*) i stedet.

Når du bruker x i en formel, kan ikke Excel Online beregne resultatet og viser formelen i cellen i stedet, og plasserer en stiplet rød kantlinje rundt cellen for å vise at det er en formelfeil.

Bruk anførselstegn rundt tekst i formler

Hvis du oppretter en formel som inneholder tekst, omslutter du teksten med anførselstegn.

Formelen = "I dag er det " & TEKST(IDAG(),"dddd dd. mmmm") kombinerer for eksempel teksten "I dag er det " med resultatet av funksjonene TEKST og IDAG, og returnerer I dag er det mandag 30. mai i cellen.

Legg merke til at det er et mellomrom foran det andre anførselstegnet i formelen «"I dag er det "». Dette sørger for mellomrommet du vil ha mellom ordene I dag er det og mandag 30. mai. Uten anførselstegn rundt teksten kan det hende at formelen ville vist en #NAVN?-feil.

Ikke nest flere enn 64 funksjoner i en formel

Du kan kombinere, eller neste, opptil 64 nivåer av funksjoner i en formel.

Formelen =HVIS(ROT(PI())<2;"Mindre enn to!";"Større enn to!") har for eksempel tre nivåer av funksjoner: PI-funksjonen er nestet i ROT-funksjonen, som igjen er nestet i HVIS-funksjonen.

Unngå å dele numeriske verdier på null

Hvis du deler en celle på en annen celle som inneholder null (0) eller er tom, vil det oppstå en #DIV/0!-feil .

Ved å neste divisjonsoperasjonen i HVISFEIL-funksjonen kan du unngå denne feilen. Skriv for eksempel inn følgende to formler i celler i et regneark:

=HVISFEIL(3/0;0)

=HVISFEIL(3/7;0)

Den første formelen returnerer 0 fordi HVISFEIL-funksjonen gjenkjenner at deling på null fører til en feil. Den andre formelen returnerer verdien 3/7. Det er ingen feil fordi du ikke deler på null.

Hvis du vil gjøre det enklere å opprette formler, kan det også være lurt å lære om noen tips og triks for formler.

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×