Telle unike verdier blant duplikater

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

La oss si at du vil finne ut hvor mange unike tekst- eller tallverdier finnes i et område. Hvis du for eksempel hvis en kolonne har teksten verdier Bradley, Halberg, Halberg, Halberg, finnes det to unike verdier – Bradley og Halberg. Hvis området har tall 5, 6, 7, 6, er de unike verdiene 5, 6 og 7.

For å telle bare unike verdier, bruker du en kombinasjon av følgende funksjoner, som vist i eksempelregnearket nedenfor:

  • Bruk HVIS-funksjonen til å tilordne en verdi av 1 til hver betingelse som er SANN.

  • Bruk SUMMER-funksjonen til å legge til alle unike verdier.

  • Bruk FREKVENS-funksjonen til å telle antallet unike verdier. Denne funksjonen ignorerer tekst- og nullverdier. For den første forekomsten av en bestemt verdi, returnerer denne funksjonen et tall som er likt antallet forekomster av den verdien. For hver etterfølgende forekomst med samme verdi som den første, returnerer funksjonen 0.

  • Bruk SAMMENLIGNE-funksjonen til å returnere plasseringen til en tekstverdi i et område. FREKVENS -funksjonen bruker den resulterende verdien til å evaluere de tilsvarende tekstverdiene.

  • Bruk LENGDE-funksjonen til å finne tomme celler. Tomme celler har en lengde (antall tegn) på 0.

Eksempel

Kopier tabellen til celle A1 i et tomt regneark i Excel for å arbeide med formeleksemplene som bruker funksjoner.

Data

Data

986

Berg

Larsen

563

67

789

235

Berg

Larsen

689

789

Larsen

143

56

237

67

235

Formel

Beskrivelse (Resultat)

=SUMMER(HVIS(FREKVENS(A2:A10;A2:A10)>0;1))

Teller antallet unike tallverdier i celleområdet A2:A10, men ikke tomme celler eller tekstverdier (4)

=SUMMER(HVIS(FREKVENS(SAMMENLIGNE(B2:B10;B2:B10;0);SAMMENLIGNE(B2:B10;B2:B10;0))>0;1))

Teller antallet unike tekst- og tallverdier i celleområdet B2:B10 (som ikke må inneholde tomme celler) (7)

=SUMMER(HVIS(FREKVENS(HVIS(LENGDE(A2:A10)>0;SAMMENLIGNE(A2:A10;A2:A10;0);""); HVIS(LENGDE(A2:A10)>0;SAMMENLIGNE(A2:A10;A2:A10;0);""))>0;1))

Teller antallet unike tekst- og tallverdier i celleområdet A2:A10, men ikke tomme celler eller tekstverdier (6)

Kommentarer: 

  • Formlene i dette eksemplet må angis som matriseformler. Merk hver celle som inneholder en formel, trykker F2, og trykk deretter Ctrl + Skift + Enter.

  • Hvis du vil evaluere en funksjon trinn for trinn, merker du cellen som inneholder formelen, og deretter klikker du Evaluer formel i Formelrevisjon-gruppen i kategorien Formler.

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×