Telle unike verdier blant duplikater

Obs!:  Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

La oss si at du vil finne ut hvor mange unike tekst- eller tallverdier finnes i et område. Hvis du for eksempel hvis en kolonne har teksten verdier Bradley, Halberg, Halberg, Halberg, finnes det to unike verdier – Bradley og Halberg. Hvis området har tall 5, 6, 7, 6, er de unike verdiene 5, 6 og 7.

For å telle bare unike verdier, bruker du en kombinasjon av følgende funksjoner, som vist i eksempelregnearket nedenfor:

  • Bruk Hvis-funksjonen til å tilordne en verdi på 1 til hver betingelse er SANN.

  • Bruke SUMMER-funksjonen til å legge til alle unike verdier.

  • Bruke frekvens-funksjonen til å telle antallet unike verdier. Denne funksjonen ignorerer tekst og nullverdier. For den første forekomsten av en bestemt verdi returneres et tall til antall forekomster av denne verdien. Denne funksjonen returnerer en verdi på 0 for hver forekomst med samme verdi etter først.

  • Bruk sammenligne-funksjonen til å returnere plasseringen av en tekstverdi i et område. FREKVENS-funksjonen bruker resultatverdien skal evalueres de tilsvarende tekstverdiene.

  • Bruke lengde-funksjonen til å finne tomme celler. Tomme celler har en lengde (tegnantall) på 0.

Eksempel

Kopier tabellen til celle A1 i et tomt regneark i Excel for å arbeide med formeleksemplene som bruker funksjoner.

Data

Data

986

Berg

Larsen

563

67

789

235

Berg

Larsen

689

789

Larsen

143

56

237

67

235

Formel

Beskrivelse (Resultat)

=SUMMER(HVIS(FREKVENS(A2:A10;A2:A10)>0;1))

Teller antallet unike tallverdier i celleområdet A2:A10, men ikke tomme celler eller tekstverdier (4)

=SUMMER(HVIS(FREKVENS(SAMMENLIGNE(B2:B10;B2:B10;0);SAMMENLIGNE(B2:B10;B2:B10;0))>0;1))

Teller antallet unike tekst- og tallverdier i celleområdet B2:B10 (som ikke må inneholde tomme celler) (7)

=SUMMER(HVIS(FREKVENS(HVIS(LENGDE(A2:A10)>0;SAMMENLIGNE(A2:A10;A2:A10;0);""); HVIS(LENGDE(A2:A10)>0;SAMMENLIGNE(A2:A10;A2:A10;0);""))>0;1))

Teller antallet unike tekst- og tallverdier i celleområdet A2:A10, men ikke tomme celler eller tekstverdier (6)

Obs!: 

  • Formlene i dette eksemplet må angis som matriseformler. Merk hver celle som inneholder en formel, trykker F2, og trykk deretter Ctrl + Skift + Enter.

  • Hvis du vil evaluere en funksjon trinn for trinn, merker du cellen som inneholder formelen, og deretter klikker du Evaluer formel i Formelrevisjon-gruppen i kategorien Formler.

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×