Telle hvor ofte en verdi forekommer i Excel

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

La oss si du ønsker å finne ut av hvor mange ganger en bestemt tekst eller en tallverdi forekommer i et celleområde. Eksempel:

  • Hvis et område som for eksempel A2 til D20 inneholder tallverdiene 5, 6, 7 og 6, forekommer tallet 6 to ganger.

  • Hvis en kolonne inneholder Berg, Larsen, Larsen og Larsen, forekommer Larsen tre ganger.

Det finnes flere metoder for å telle hvor ofte en verdi forekommer.

Hva vil du gjøre?

Telle hvor ofte en enkelt verdi forekommer ved å bruke en funksjon

Telle basert på flere kriterier ved hjelp av ANTALL.HVIS.SETT-funksjonen

Telle basert på kriterier ved hjelp av ANTALL- og HVIS-funksjonen

Telle hvor ofte flere tekst- eller tallverdier forekommer ved å bruke SUMMER- og HVIS-funksjonen sammen

Telle hvor ofte flere verdier forekommer ved å bruke en pivottabellrapport

Telle hvor ofte en enkelt verdi forekommer ved å bruke en funksjon

Bruk ANTALL.HVIS-funksjonen til å utføre denne oppgaven.

Eksempel

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vise resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Selger

Faktura

Buchanan

15 000

Buchanan

9 000

Suyama

8 000

Suyama

20 000

Buchanan

5 000

Dodsworth

22 500

Formel

Beskrivelse

Resultat

'=ANTALL.HVIS(A2:A7,"Buchanan")

Antall oppføringer for Buchanan (3)

=ANTALL.HVIS(A2:A7;"Buchanan")

'=ANTALL.HVIS(A2:A7,A4)

Antall oppføringer for Suyama (2)

=ANTALL.HVIS(A2:A7,A4)

'=ANTALL.HVIS(B2:B7,"< 20000")

Antall fakturaverdier som er mindre enn 20 000 (4)

=ANTALL.HVIS(B2:B7;"< 20000")

'=ANTALL.HVIS(B2:B7,">="&B5)

Antall fakturaverdier som er større enn eller lik 20 000 (2)

=ANTALL.HVIS(B2:B7;">="&B5)

Du finner mer informasjon om dette i artikkelen ANTALL.HVIS-funksjonen.

Til toppen av siden

Telle basert på flere kriterier ved hjelp av ANTALL.HVIS.SETT-funksjonen

Funksjonen ANTALL.HVIS.SETT ble innført i Excel 2007 og ligner på ANTALL.HVIS-funksjonen, med ett viktig unntak: Med ANTALL.HVIS.SETT kan du bruke vilkår på flere celleområder og telle antall ganger alle vilkårene oppfylles. Du kan bruke opptil 127 område-/vilkårpar med funksjonen ANTALL.HVIS.SETT. Syntaksen for funksjonen ser slik ut:

ANTALL.HVIS.SETT(kriterieområde1;kriterium1;[kriterieområde2;kriterium2];…)

Eksempel

Ansatt-ID

Områdenr.

Avdeling

20552

2

Salg

21268

2

Økonomi

23949

1

Administrasjon

24522

4

Administrasjon

28010

3

IT

29546

4

Salg

31634

3

IT

32131

1

IT

35106

4

Økonomi

40499

1

Personal

42051

1

Salg

43068

2

Personal

45382

2

Økonomi

47971

1

IT

Hvor mange er ansatt i område 2 og på økonomiavdelingen?

'=ANTALL.HVIS.SETT(B2:B15,"2",C2:C15,"Økonomi")

=ANTALL.HVIS.SETT(B2:B15,"2",C2:C15,"Økonomi")

Det første vilkårsområdet er områdenumrene, og det andre vilkårsområdet er avdelingsnavnet. Vilkåret som brukes i det første vilkårsområdet, er 2. Vilkåret i det andre vilkårsområdet er Økonomi. ANTALL.HVIS.SETT kontrollerer om begge vilkårene oppfylles.

Du finner mer informasjon om hvordan du bruker denne funksjonen til å telle med flere områder og kriterier, i artikkelen ANTALL.HVIS.SETT-funksjonen.

Til toppen av siden

Telle basert på kriterier ved hjelp av ANTALL- og HVIS-funksjonen

La oss si at du må fastslå hvor mange selgere som har solgt en bestemt artikkel i et område, eller du vil vite hvor mange salg over en bestemt verdi som ble foretatt av en bestemt selger. Du kan bruke HVIS- og ANTALL-funksjonen sammen. Først bruker du HVIS-funksjonen til å teste en betingelse, og bare hvis resultatet av HVIS-funksjonen er Sant, bruker du ANTALL-funksjonen til å telle celler.

Eksempler

Område

Selger

Type

Salg

Sør

Buchanan

Drikkevarer

3571

Vest

Davolio

Melk og smør

3338

Øst

Suyama

Drikkevarer

5122

Nord

Suyama

Melk og smør

6239

Sør

Dodsworth

Meieriprodukter

8677

Sør

Davolio

Kjøtt

450

Sør

Davolio

Kjøtt

7673

Øst

Suyama

Meieriprodukter

664

Nord

Davolio

Meieriprodukter

1500

Sør

Dodsworth

Kjøtt

6596

Formel

Beskrivelse

Resultat

=SUMMER(HVIS((A2:A11="Sør")*(C2:C11="Kjøtt");D2:D11)

Salg av kjøtt i område Sør. (3)

=SUMMER(HVIS((A2:A11="Sør")*(C2:C11="Kjøtt");D2:D11)

=ANTALL(HVIS((B2:B11="Suyama")*(D2:D11>=1000),D2:D11))

Antall salg som er større enn 1000 av Suyama. (2)

=ANTALL(HVIS((B2:B11="Suyama")*(D2:D11>=1000),D2:D11))

Merknad: 

  • Formlene i dette eksemplet må legges inn som matriseformler. Hvis du har åpnet denne arbeidsboken i den installerte versjonen av Excel og vil endre formelen eller opprette en lignende formel, trykker du F2, og deretter trykker du CTRL+SKIFT+ENTER for å få formelen til å gi resultatene du forventer.

  • Disse formlene fungerer bare hvis det andre argumentet for HVIS-funksjonen er et tall.

ANTALL-funksjonen teller antallet celler som inneholder tall, og teller også tall i listen over argumenter. HVIS-funksjonen gir én verdi hvis en betingelse du angir, evalueres som Sant, og en annen verdi hvis den evalueres om Usant.

Du finner mer informasjon om dette i artiklene ANTALL-funksjonen og HVIS-funksjonen.

Til toppen av siden

Telle hvor ofte flere tekst- eller tallverdier forekommer ved å bruke SUMMER- og HVIS-funksjonen sammen

I de følgende eksemplene bruker vi HVIS- og SUMMER-funksjonen sammen. HVIS-funksjonen tester først verdiene i enkelte celler, og hvis resultatet av testen er Sant, legger SUMMER sammen verdiene som består testen.

Eksempler

Selger

Faktura

Buchanan

15000

Buchanan

9000

Suyama

8000

Suyama

20000

Buchanan

5000

Dodsworth

22500

Formel

Beskrivelse

Resultat

=SUMMER(HVIS((A2:A7="Buchanan")+(A2:A7="Dodsworth"),1,0)

Antall fakturaer for >>>Buchanan eller Dodsworth.

=SUMMER(HVIS((A2:A7="Buchanan")+(A2:A7="Dodsworth"),1,0)

=SUMMER(HVIS((B2:B7<9000)+(B2:B7>19000);1;0))

Antall fakturaer en verdi under 9 000 eller over 19 000.

=SUMMER(HVIS((B2:B7<9000)+(B2:B7>19000);1;0))

=SUMMER(HVIS(A2:A7="Buchanan",HVIS(B2:B7<9000,1,0))

Antall fakturaer for Buchanan med en verdi på mindre enn 9 000

=SUMMER(HVIS(A2:A7="Buchanan",HVIS(B2:B7<9000,1,0))

Merknad: Formlene i dette eksemplet må legges inn som matriseformler. Hvis du har åpnet denne arbeidsboken i den installerte versjonen av Excel og vil endre formelen eller opprette en lignende formel, trykker du F2, og deretter trykker du CTRL+SKIFT+ENTER for å få formelen til å gi resultatene du forventer.

Til toppen av siden

Telle hvor ofte flere verdier forekommer ved å bruke en pivottabellrapport

Du kan bruke en pivottabellrapport til å vise totalsummer, og til å telle forekomstene av unike verdier. En pivottabellrapport er en rask og interaktiv måte å lage sammendrag av store datamengder på. Du kan bruke en pivottabell til å utvide og skjule nivåer med data for å fokusere på resultatene, og drille ned til detaljer fra sammendragsdataene for områder som interesser deg. I tillegg kan du flytte (pivotere) rader til kolonner eller kolonner til rader for å se ulike sammendrag av kildedataene.

Eksempel på kildedata og resulterende pivottabellrapport

1    Kildedata, i dette tilfellet fra et regneark

2    Kildeverdiene for golfsammendraget for tredje kvartal i pivottabellrapporten

3    Hele pivottabellrapporten

4    Sammendrag av kildeverdiene i C2 og C8 fra kildedataene

Slik oppretter du en pivottabellrapport:

  1. Merk kolonnen som inneholder dataene.
    Kontroller at kolonnen har en kolonneoverskrift.

  2. Klikk Pivottabell i Tabeller-gruppen på Sett inn-fanen.
    Dialogboksen Opprett pivottabell vises.

  3. Klikk Velg en tabell eller et område.

  4. Plasser pivottabellrapporten i et nytt regneark, og start i celle A1 ved å klikke Nytt regneark.

  5. Klikk OK.
    Det legges til en tom pivottabellrapport på plasseringen du har angitt, og feltlisten for pivottabell vises.

  6. I feltdelen øverst i feltlisten for pivottabell kan du klikke og holde feltnavnet og deretter dra feltet til Radetiketter-boksen i oppsettdelen nederst i feltlisten for pivottabell.

  7. I feltdelen øverst i feltlisten for pivottabell kan du klikke og holde det samme feltnavnet og deretter dra feltet på nytt til Verdier-boksen i oppsettdelen nederst i feltlisten for pivottabell.

Merknad: Hvis dataene inneholder tall, vil pivottabellrapporten legge sammen oppføringene i stedet for å telle dem. Hvis du vil bytte fra sammendragsfunksjonen Summer til sammendragsfunksjonen Antall, merker du en celle i denne kolonnen og klikker Feltinnstillinger i Aktivt felt-gruppen på fanen Analyse, og deretter klikker du Antall på fanen Sammendragsmetode og OK.

Til toppen av siden

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×