Telle hvor ofte en verdi forekommer

En rekke regnearkfunksjoner kan hjelpe deg med å telle hvor mange ganger en bestemt tekst eller tallverdi forekommer i et celleområde. Du kan for eksempel bruke funksjonen ANTALL.HVIStil å telle hvor ofte en enkelt verdi forekommer, som vist i eksemplet nedenfor.

Eksempel

Selger

Faktura

Buchanan

15 000

Buchanan

9 000

Suyama

8000

Suyama

20 000

Buchanan

5 000

Dodsworth

22 500

Formel

Beskrivelse

Resultat

=ANTALL.HVIS(A2:A7;"Buchanan")

Antall oppføringer for Buchanan (3)

3

=ANTALL.HVIS(A2:A7,A4)

Antall oppføringer for Suyama (2)

2

=ANTALL.HVIS(B2:B7;"< 20000")

Antall fakturaverdier som er mindre enn 20 000 (4)

4

=ANTALL.HVIS(B2:B7;">="&B5)

Antall fakturaverdier som er større enn eller lik 20 000 (2)

2

Bruk ANTALL.HVIS.SETT til å telle verdier basert på flere vilkår

ANTALL.HVIS.SETT-funksjonen ligner ANTALL.HVIS-funksjonen, med ett viktig unntak: Med ANTALL.HVIS.SETT kan du bruke vilkårene på flere celleområder og telle antall ganger alle vilkårene oppfylles. Du kan bruke opptil 127 serie-/vilkårpar med ANTALL.HVIS.SETT-funksjonen. Syntaksen for funksjonen ser slik ut:

ANTALL.HVIS.SETT(kriterieområde1; kriterium1; [kriterieområde2; kriterium2] …)

Eksempel

Ansatt-ID

Områdenummer

Avdeling

20552

2

Salg

21268

2

Økonomi

23949

1

Administrasjon

24522

4

Administrasjon

28010

3

IT

29546

4

Salg

31634

3

IT

32131

1

IT

35106

4

Økonomi

40499

1

Personal

42051

1

Salg

43068

2

Personal

45382

2

Økonomi

47971

1

IT

Formel

Beskrivelse

Resultat

=ANTALL.HVIS.SETT(B2:B15,"2",C2:C15,"Økonomi")

Antall ansatte i område 2 og på økonomiavdelingen

2

Det første vilkårsområdet inkluderer områdenumrene, og det andre vilkårsområdet inkluderer avdelingsnavnet. Vilkåret som brukes i det første vilkårsområdet, er 2. Vilkåret i det andre vilkårsområdet er Økonomi. ANTALL.HVIS.SETT kontrollerer om begge vilkårene oppfylles.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×