Tell tegn i celler med Excel 2016 for Mac

Når du skal telle tegn i cellene, bruker du LENGDE-funksjon. Funksjonen teller bokstaver, tall, tegn og alle mellomrom. Lengden på for eksempel «Det er 26 grader i dag, så jeg skal bade» (unntatt anførselstegnene) er 40 tegn: 28 bokstaver, 2 tall, 9 mellomrom og ett komma.

  • Du bruker funksjonen ved å skrive =LENGDE(celle) i formellinjen og trykke ENTER. I disse eksemplene betyr celle cellen du vil telle, for eksempel B1.

  • Når du vil telle tegn i mer enn én celle, skriver du inn formelen, og deretter kopierer og limer du inn formelen i andre celler.

  • Hvis du vil telle totalt antall tegn i flere celler, bruker du SUMMER-funksjonene sammen med LENGDE. Eksempel: =SUMMER((LENGDE(celle1);LENGDE(celle2);(LENGDE(celle3)))). I dette eksempelet teller LENGDE-funksjonen tegnene i hver celle, og SUMMER-funksjonen legger sammen tallene.

  • Hvis du vil telle visse bestemte tegn i cellene, bruker du funksjonene LENGDE med funksjonen BYTT.UT. Hvis du for eksempel vil vite hvor mange ganger z finnes i en celle, bruker du denne formelen: =LENGDE(celle1) -LENGDE(BYTT.UT(cell1,"z";""))

Prøv det

Skriv inn følgende data i et nytt Excel-regneark. Start i celle A1.

Tekststrenger

Formler

Den raske brune reven

Den raske brune reven hoppet

Den raske brune reven hoppet over den late hunden.

Telle tegn i én celle

  1. Klikk celle B2.

  2. Skriv =LENGDE(A2) i cellen, og trykk ENTER.

Formelen teller tegnene i celle A2, og det blir 19 inkludert mellomrom. Hvis det er mellomrom etter siste punktum, teller formelen disse også.

Telle tegn i flere celler

  1. Trykk CTRL+C for å kopiere celle B2.

  2. Trykk CTRL+V for å lime inn formelen i cellene B3:B4

Det kopierer formelen til celle B3 og B4, og funksjonen teller tegnene i hver celle (26 og 44).

Telle totalt antall tegn

  1. Klikk celle B6.

  2. Skriv =SUMMER(LENGDE(A2),LENGDE(A3),LENGDE(A4)) i cellen, og trykk ENTER.

Dette teller antall tegn i hver av de tre cellene og summerer dem (89).

Slik teller du bestemte tegn i celler

  1. Klikk celle C4.

  2. Skriv inn =LENGDE(A4)-LENGDE(BYTT.UT(A4;"z";"")), og trykk ENTER.

Dette teller alle tilfeller av z i celle A4, som er 1.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×