Slik retter du en #VERDI! feil i kjede-funksjonen

Viktig!: I Excel 2016, Excel Mobile og Excel for nettet, har KJEDEt blitt erstattet av funksjonen CONCAT. Selv om KJEDE.SAMMEN fremdeles er tilgjengelig for bakoverkompatibilitet, bør du vurdere å bruke KJED.SAMMEN som er en mer robust funksjon.

Et av de vanligste scenariene der du opplever #VALUE! feil med SAMMENKJEDING er når du prøver å bygge en streng som inneholder en celle referanse som har en feil, for eksempel #VALUE!.

I eksemplet nedenfor vil vi kjede sammen D2, E2 og F2, der E2 har en #VALUE! -feil.

#VERDI! feil i SAMMENKJEDING

Feilen i E2 fører til at funksjonen viser #VERDI!-feil. For at den skal fungere riktig må du erstatte feilen med en annen verdi enn feilen. Du kan bygge en formel som ser etter feil i cellereferanser. Hvis den finner en feil, vises tekststrengen der 0 vises i stedet for feilen (eller du kan erstattet 0 med egen tekst, men da må du legge til anførselstegn, for eksempel «Din tekst».

En formel som dette vil fungere:

=HVIS(ERFEIL(E2),KJEDE.SAMMEN(D2,” “,0,” “,F2))

Hvis og ERFEIL-funksjoner som brukes som en løsning for å kjede sammen en streng med #VALUE! -feil

Hvordan fungerer det? Hvis-funksjonen bruker HVISFEIL-funksjonen til å fastslå om det er en feil i E2, og hvis det er tilfellet, kombinerer funksjonen kjede sammen verdiene i D2, E2 og F2 (funksjonen erstatter feilen med 0) og viser den resulterende tekst strengen. Vær oppmerksom på at formelen også bruker mellomrom ("") for å skille verdiene.

Rett #VALUE! feil med SAMMENKJEDING i Excel 2003 og eldre versjoner

Hvis du får #VALUE! feil i Office Excel 2003 eller eldre versjoner, må du fjerne merket for alternativet overgangs formel evaluering (TFE) i Excel. Følg Fremgangs måten i #VALUE! feil ved sammenkjeding av celler for å løse problemet.

Har du spørsmål om en bestemt funksjon?

Legg inn et spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

Rette en #VALUE! -feil

KJEDE.SAMMEN (funksjon)

KJED.SAMMEN-funksjonen

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Obs!:  Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig? Her er den engelske artikkelen for referanse.

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×