Slik retter du en #VERDI!-feil i funksjonene SUMMERHVIS/SUMMER.HVIS.SETT

Dette emnet inneholder de vanligste årsakene til #VERDI!-feil i funksjonene SUMMERHVIS og SUMMER.HVIS.SETT, og hvordan de kan løses.

Problem: Formelen refererer til celler i en lukket arbeidsbok

Funksjoner SUMMERHVIS/SUMMER.HVIS.SETT som refererer til en celle eller et område i en lukket arbeidsbok, vil føre til en #VERDI!-feil.

Obs! Dette er et kjent problem med flere andre Excel-funksjoner, for eksempel ANTALL.HVIS, ANTALL.HVIS.SETT og TELLBLANKE for å nevne noen. Se artikkelen Funksjonene SUMMERHVIS, ANTALL.HVIS og TELLBLANKE returnerer en «#VERDI!» -feil hvis du vil ha mer informasjon.

Løsning: Åpne arbeidsboken som er angitt i formelen, og trykk på F9 for å oppdatere formelen.

Du kan også omgå dette problemet ved å bruke funksjonene SUMMER og HVIS sammen i en matriseformel. Se artikkelen Funksjonene SUMMERHVIS, ANTALL.HVIS og TELLBLANKE returnerer en #VERDI!-feil hvis du vil ha mer informasjon.

Problem: Kriteriestrengen er på mer enn 255 tegn

Funksjonene SUMMERHVIS/ANTALL.HVIS.SETT returnerer uriktige resultater når du forsøker å sammenligne strenger som er lengre enn 255 tegn.

Løsning: Forkort strengen hvis det er mulig. Hvis du ikke kan forkorte den, kan du bruke funksjonen KJEDE.SAMMEN eller tegnet (&) for å dele opp verdien i flere strenger. Eksempel:

=SUMMERHVIS(B2:B12;"lang streng"&"enda en lang streng")

Problem: I SUMMER.HVIS.SETT samsvarer ikke argumentet kriterie_område med argumentet summeringsområde.

Områdeargumenter må alltid være de samme i SUMMER.HVIS.SETT. Dette betyr at argumentene kriterie_område og summeringsområde må referere til samme antall rader og kolonner.

I eksemplet nedenfor skal formelen returnere summen av daglige salg av epler i Bellevue. Argumentet summeringsområde (C2:C10) samsvarer imidlertid ikke med samme antall rader og kolonner i argumentet kriterie_område (A2:A12 & B2:B12). Hvis vi bruker syntaksen =SUMMER.HVIS.SETT(C2:C10;A2:A12;A14;B2:B12;B14), vil dette føre til en #VERDI!-feil.

Feil formel er =SUMMER.HVIS.SETT(C2:C10;A2:A12;A14;B2:B12;B14), der C2:C10 må være C2:C12
Kriterie_område må være i samsvar med summeringsområde i funksjonen SUMMER.HVIS.SETT.

Løsning: Hvis du følger dette eksemplet, endrer du summeringsområde til C2:C12 og prøver formelen på nytt.

Merknad:  SUMMERHVIS kan bruke andre størrelsesområder.

Har du spørsmål om en bestemt funksjon?

Legg inn spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

Rette en #VERDI-feil

SUMMERHVIS-funksjon

SUMMER.HVIS.SETT-funksjon

Videoer om avansert HVIS-funksjon

Oversikt over formler i Excel

Slik unngår du brutte formler

Bruke feilkontroll til å oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×