Slik retter du en #VERDI!-feil i funksjonene INDEKS/SAMMENLIGNE

Dette emnet beskriver de vanlige scenariene hvor du kan støte på #VERDI!-feil ved å bruke funksjonene INDEKS og SAMMENLIGNE sammen i en formel. En av de vanligeste grunnene til å bruke kombinasjonen av INDEKS og SAMMENLIGNE, er når du vil søke etter en verdi i en situasjon hvor FINN.RAD ikke fungerer for deg, for eksempel hvis oppslagsverdien er over 255 tegn.

Problem: Formelen er ikke angitt som en matrise

Hvis du bruker INDEKS som en matriseformel sammen med SAMMENLIGNE for å kunne innhente en verdi, må du konvertere formelen til en matriseformel, hvis ikke vil du se en #VERDI!-feil.

Løsning: INDEKS og SAMMENLIGNE må brukes som en matriseformel, noe som betyr at du må trykke på CTRL+SKIFT+ENTER. Dette bryter automatisk teksten i formelen med {}. Hvis du prøver å angi dem selv, viser Excel formelen som tekst.

Hvis du bruker INDEKS/SAMMENLIGNE når du har en oppslagsverdi som er større enn 255 tegn, må den legges inn som en matriseformel.  Formelen i celle F3 er =INDEKS(B2:B4;SAMMENLIGNE(SANN;A2:A4=F2;0);0), og den angis ved å trykke på CTRL+SKIFT+ENTER
INDEKS og SAMMENLIGNE må brukes som en matriseformel

Har du spørsmål om en bestemt funksjon?

Legg inn spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

Rette en #VERDI-feil

INDEKS-funksjon

SAMMENLIGNE-funksjon

Slå opp verdier med FINN.RAD, INDEKS eller SAMMENLIGNE

Oversikt over formler i Excel

Slik unngår du brutte formler

Bruke feilkontroll til å oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×