Slik retter du en #VERDI!-feil i funksjonen ANTALLHVIS/ANTALL.HVIS.SETT

Dette emnet inneholder de vanligste årsakene til #VALUE!-feil i funksjonene ANTALLHVIS og ANTALL.HVIS.SETT.

Problem: Formelen refererer til celler i en lukket arbeidsbok

Funksjonene ANTALL.HVIS/ANTALL.HVIS.SETT som refererer til en celle eller et område i en lukket arbeidsbok, vil føre til en #VERDI!-feil.

Obs! Dette er et kjent problem med flere andre Excel-funksjoner, for eksempel SUMMERHVIS, SUMMER.HVIS.SETT og TELLBLANKE for å nevne noen. Se funksjonene SUMMERHVIS, ANTALL.HVIS og TELLBLANKE returnerer en #VERDI!-feil hvis du vil ha mer informasjon.

Løsning: Åpne den tilkoblede arbeidsboken som er angitt i formelen, og trykk på F9 for å oppdatere formelen.

Du kan også omgå dette problemet ved å bruke funksjonene SUMMER og HVIS sammen i en matriseformel. Se funksjonene SUMMERHVIS, ANTALL.HVIS og TELLBLANKE returnerer en #VERDI!-feil hvis du vil ha mer informasjon.

Problem: Strengen er på mer enn 255 tegn

Løsning: Forkort strengen hvis det er mulig. Hvis du ikke kan forkorte den, kan du bruke funksjonen KJEDE.SAMMEN eller tegnet (&) for å dele opp verdien i flere strenger. Eksempel:

  • =ANTALL.HVIS(B2:B12;"lang streng"&"enda en lang streng")

Har du spørsmål om en bestemt funksjon?

Legg inn spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

Rette en #VERDI!-feil

ANTALL.HVIS-funksjon

ANTALL.HVIS.SETT-funksjon

HVIS-funksjon – arbeide med nestede formler og unngå feller

Se en video om hvordan du bruker avanserte HVIS-funksjoner

Oversikt over formler i Excel

Hvordan unngå brutte formler

Bruke feilkontroll til å oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×