Slik retter du en #VERDI!-feil i SUMMERPRODUKT-funksjonen

Dette emnet dekker de vanligste scenariene med #VERDI!-feil når du arbeider med SUMMERPRODUKT.

Problem: Matriseargumentene har ikke samme dimensjon.

Alle matriseargumentene må ha samme dimensjon. Hvis de ikke har det, får du en #VERDI!-feil. Hvis for eksempel matrise 1 refererer til et område med 3 rader og 2 kolonner, må matrise 2 ha et tilsvarende område.

SUMMERPRODUKT-formel som forårsaker en feil er =SUMMERPRODUKT(D2:D13;E2:E10) – E10 må endres til E13 for å samsvare med det første området.
  • =SUMMERPRODUKT(D2:D13;E2:E10)

Vil mislykkes fordi antall rader på de refererte områdene ikke stemmer overens (13 i det første området, men bare 10 i det andre).

Løsning: Endre formelen slik:

  • =SUMMERPRODUKT(D2:D13;E2:E13)

Begge områdene har nå samme nummer på start- og sluttradene. Prøv formelen på nytt.

Du må løse #VERDI!-feilen i dataene for å løse SUMMERPRODUKT-feilen

Problem: Én eller flere celler i området inneholder tekst

Hvis én eller flere celler i det refererte området inneholder tekst eller er formatert som datatypen tekst, får du en #VERDI!-feil. Teksten kan være et resultat fra en beregning som tilhører en annen formel, eller kanskje cellen rett og slett ikke er formatert riktig.

Formelen i celle E15 viser #VERDI!-feil fordi det finnes en #VERDI!-feil i kolonne E.

Løsning: Se etter en celle som inneholder tekst, eller som er formatert som tekst og angitt som riktig datatype.

Har du spørsmål om en bestemt funksjon?

Legg inn spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

Rette en #VERDI-feil

SUMMERPRODUKT-funksjon

Oversikt over formler i Excel

Slik unngår du brutte formler

Bruke feilkontroll til å oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×