Slik retter du en #VERDI!-feil i KJEDE.SAMMEN-funksjonen

Viktig: I Excel 2016, Excel Mobile og Excel Online har KJEDE.SAMMEN blitt erstattet av funksjonen KJED.SAMMEN. Selv om KJEDE.SAMMEN fremdeles er tilgjengelig for bakoverkompatibilitet, bør du vurdere å bruke KJED.SAMMEN som er en mer robust funksjon.

En av de vanligste scenariene der du kan støte på #VERDI!-feil med KJEDE.SAMMEN er når du prøver å bygge en streng som inkluderer cellereferanser med feil, som for eksempel #VERDI!.

I eksemplet nedenfor ønsker vi å kjede sammen D2, E2 og F2, der E2 har en #VERDI!-feil.

#VERDI!-feil i KJEDE.SAMMEN

Feilen i E2 fører til at funksjonen viser #VERDI!-feil. For at den skal fungere riktig må du erstatte feilen med en annen verdi enn feilen. Du kan bygge en formel som ser etter feil i cellereferanser. Hvis den finner en feil, vises tekststrengen der 0 vises i stedet for feilen (eller du kan erstattet 0 med egen tekst, men da må du legge til anførselstegn, for eksempel «Din tekst».

En formel som dette vil fungere:

=HVIS(ERFEIL(E2),KJEDE.SAMMEN(D2,” “,0,” “,F2))

Funksjonene HVIS og ERFEIL brukt som en midlertidig løsning til å kjede sammen en streng med #VERDI!-feil

Hvordan fungerer det? HVIS-funksjonen bruker funksjonen HVISFEIL til å avgjøre om det er en feil i E2. Hvis det er tilfelle, vil funksjonen KJEDE.SAMMEN kombinere verdiene D2, E2 og F2 (funksjonen erstatter feilene med en 0) og viser den resulterende tekststrengen. Vær oppmerksom på at formelen bruker mellomrom (“ “) for å skille mellom verdier.

Rette #VERDI!-feil med KJEDE.SAMMEN i Excel 2003 og eldre versjoner

Hvis du får #VERDI!-feil i Office Excel 2003 eller eldre versjoner, må du fjerne merket for Alternativ formelevaluering (TFE) i Excel. Følg fremgangsmåten i #VERDI!-feil når du skal kjede sammen celler for å løse problemet.

Har du spørsmål om en bestemt funksjon?

Legg inn spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

Rette en #VERDI!-feil

KJEDE.SAMMEN-funksjon

KJED.SAMMEN-funksjon

Oversikt over formler i Excel

Slik unngår du brutte formler

Bruke feilkontroll til å oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×