Slik retter du en #VERDI!-feil i KJEDE.SAMMEN-funksjonen

Obs!: Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

Viktig!: I Excel 2016, Excel Mobile og Excel Online har KJEDE.SAMMEN blitt erstattet av funksjonen KJED.SAMMEN. Selv om KJEDE.SAMMEN fremdeles er tilgjengelig for bakoverkompatibilitet, bør du vurdere å bruke KJED.SAMMEN som er en mer robust funksjon.

En av de vanligste scenariene der du kan støte på #VERDI!-feil med KJEDE.SAMMEN er når du prøver å bygge en streng som inkluderer cellereferanser med feil, som for eksempel #VERDI!.

I eksemplet nedenfor ønsker vi å kjede sammen D2, E2 og F2, der E2 har en #VERDI!-feil.

#VERDI!-feil i KJEDE.SAMMEN

Funksjonen til å vise #VALUE forårsaker feil i E2! feil. For at den skal lykkes, må du erstatte feilen med en verdi forskjellig fra feilen. Du kan bygge en formel som kontrollerer om det er en feil i cellereferansen, og hvis den finnes, vise tekststrengen der en 0 vises i stedet for feilen (eller du kan også bruke din egen tekst for 0, men du må bryte teksten i anførselstegn – "Your tekst").

En formel som dette vil fungere:

=HVIS(ERFEIL(E2),KJEDE.SAMMEN(D2,” “,0,” “,F2))

Funksjonene HVIS og ERFEIL brukt som en midlertidig løsning til å kjede sammen en streng med #VERDI!-feil

Hvordan fungerer som? Hvis-funksjonen bruker funksjonen HVISFEIL til å avgjøre om det er en feil i celle E2, og hvis det er, kjede.sammen-funksjonen kombinerer verdiene i D2, E2 og F2 (funksjonen erstatter feilen med 0), og viser den resulterende tekststrengen. Merk formelen bruker også mellomrom ("") til å skille verdiene.

Rette #VERDI!-feil med KJEDE.SAMMEN i Excel 2003 og eldre versjoner

Hvis du får #VALUE! feil i Office Excel 2003 eller eldre versjoner, må du fjerner merket for alternativet overgang formelen evaluering (TFE) i Excel. Følg fremgangsmåten i #VALUE! feil ved å slå sammen celler å løse problemet.

Har du spørsmål om en bestemt funksjon?

Legg inn et spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis du har det, kan du se emnene på Excel User Voice.

Se også

Rette en #VERDI!-feil

KJEDE.SAMMEN (funksjon)

KJED.SAMMEN-funksjonen

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×