Slik retter du en #VALUE!-feil i funksjonene GJENNOMSNITT eller SUMMER

Hvis GJENNOMSNITT eller SUMMER refererer til celler som inneholder #VERDI!-feil, vil formlene resultere i en #VERDI!-feil.

#VERDI!-feil i GJENNOMSNITT

Hvis du vil overse feilverdiene, utformer du en formel som ignorerer feilene i referanseområdet, samtidig som du beregner gjennomsnittet med de gjenværende «normale» verdiene.

Hvis du vil omgå dette scenariet, bruker du en kombinasjon av GJENNOMSNITT sammen med HVIS og ERFEIL for å avgjøre om det finnes en feil i det angitte området. Dette bestemt scenariet krever en matriseformel:

= GJENNOMSNITT(HVIS(ERFEIL(B2:D2);"";B2:D2))

Merknad: Dette er en matriseformel som må angis med CTRL+SKIFT+ENTER. Excel vil automatisk bryte formelen med klammeparenteser {}. Hvis du prøver å skrive dem inn selv, vil Excel vise formelen som tekst.

Matrise-funksjonen i GJENNOMSNITT for å løse #VERDI!-feil

Merknad: Funksjonen ovenfor vil ikke bare fungere for #VERDI!, men også for #I/T, #NULL, #DIV/0! og andre.

Du kan også bruke SUMMER på samme måte:

=SUMMER(HVIS(ERFEIL(B2:D2);"";B2:D2))

Har du spørsmål om en bestemt funksjon?

Legg inn spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

Rette en #VERDI-feil

GJENNOMSNITT-funksjon

SUMMER-funksjon

Oversikt over formler i Excel

Slik unngår du brutte formler

Bruke feilkontroll til å oppdage feil i formler

Alle Excel-funksjoner (alfabetisk)

Alle Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×