Slik retter du en #REF!-feilmelding

Slik retter du en #REF!-feilmelding

#REF!-feilen viser når en formel refererer til en celle som ikke er gyldig. Dette skjer oftest når celler som ble referert til i formler blir slettet eller limt over.

Eksempel – #REF!-feilen ble forårsaket ved å slette en kolonne

Følgende eksempel bruker formelen =SUM(B2,C2,D2) for kolonne E.

En formel som bruker eksplisitte cellereferanser, som =SUM(B2,C2,D2), kan føre til en #REF!-feil hvis en kolonne blir slettet.

Hvis du sletter kolonne B, C eller D vil det føre til en #REF!-feil. I dette tilfellet sletter vi kolonne C (2007 salg), og formelen leser nå =SUM(B2,#REF!,C2). Når du bruker eksplisitte cellereferanser som dette (der du refererer til hver celle enkeltvis, atskilt med komma), og sletter en referert rad eller kolonne, kan ikke Excel løse den og returnerer derfor #REF!-feilen. Dette er den viktigste grunnen til at det er anbefalt å ikke bruke eksplisitte cellereferanser i funksjoner.

Eksempel på en #REF!-feil forårsaket ved å slette en kolonne.

Løsning

  • Hvis du ved et uhell slettet rader eller kolonner, kan du umiddelbart klikke Angre-knappen på verktøylinjen for hurtigtilgang (eller trykke CTRL+Z) for å gjenopprette dem.

  • Juster formelen slik at den bruker en områdereferanse i stedet for enkeltceller, som for eksempel =SUM(B2:D2). Nå kan du slette en kolonne innenfor området for summen, og Excel vil automatisk justere formelen. Du kan også bruke =SUM(B2:B5) for en sum av rader.

Eksempel – FINN.RAD med feil områdereferanser

I eksemplet nedenfor vil =FINN.RAD(A8,A2:D5,5,USANN) returnere en #REF!-feil fordi den leter etter en verdi å returnere fra kolonne 5, men referanseområdet er A:D, som bare er 4 kolonner.

Eksempel på en FINN.RAD-formelen med feil område.  Formelen er =FINN.RAD(A8,A2:D5,5,USANN).  Det er ingen femte kolonne i området FINN.RAD, slik at 5 fører til en #REF!-feil.

Løsning

Juster området til å være større, eller reduser kolonnen for oppslagsverdien til å samsvare med referanseområdet. =FINN.RAD(A8,A2:E5,5,USANN) vil være et gyldig referanseområde, og det vil også =FINN.RAD(A8,A2:D5,4,USANN).

Eksempel – INDEKS med feil referanserad eller -kolonne

I dette eksemplet returnerer formelen =INDEKS(B2:E5,5,5) feilverdien #REF! fordi INDEKS-området er på 4 rader ved 4 kolonner, men formelen ber om å returnere hva som er i 5. rad og 5. kolonne.

Eksempel på en INDEKS-formel med en ugyldig områdereferanse.  Formelen er =INDEKS(B2:E5,5,5), men området er bare 4 rader ganger 4 kolonner.

Løsning

Juster referanseraden eller -kolonnen slik at de er i INDEKS-oppslagsområdet. =INDEKS(B2:E5,4,4) vil returnere et gyldig resultat.

Eksempel – refererer til en lukket arbeidsbok med INDIREKTE

I eksemplet nedenfor forsøker en INDIREKTE-funksjon å referere til en arbeidsbok som er lukket, noe som forårsaker en #REF!-feil.

Eksempel på en #REF!-feil forårsaket av indirekte refererer til en lukket arbeidsbok.

Løsning

Åpne den refererte arbeidsboken

OLE/DDE-problemer

Hvis du har brukt kobling og innebygging av objekter (OLE) som returnerer en #REF!-feil, og deretter starter programmet som koblingen kaller på.

Obs! OLE er en teknologi som du kan bruke til å dele informasjon mellom programmer.

Hvis du har brukt et dynamisk datautveksling-emne (DDE), som returnerer en #REF!-feil, kontroller at du refererer til det riktige emnet.

Obs! DDE er en etablert protokoll for utveksling av data mellom Microsoft Windows-baserte programmer.

Makro-problemer

Hvis en makro angir en funksjon på regnearket som refererer til en celle over funksjonen, og cellen som inneholder funksjonen er i rad 1, returnerer funksjonen #REF! fordi det ikke finnes noen celler over rad 1. Kontroller funksjonen for å se om et argument refererer til en celle eller et celleområde som ikke er gyldig. Dette kan kreve at du redigerer makroen i Visual Basic Editor (VBE), for å ta hensyn til situasjonen.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Oversikt over formler i Excel

Slik unngår du formler med feil

Bruke feilkontroll for å oppdage feil i formler

Excel-funksjoner (alfabetisk)

Funksjoner i Excel (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×