Slå opp verdier med FINN.RAD, INDEKS eller SAMMENLIGNE

Du har en liste med kontortall, og du trenger å vite hvilke arbeidstakere som er på hvert kontor. Men regnearket er kjempestort, så hva kan du gjøre? Bruk en oppslagsfunksjon. FINN.RAD og FINN.KOLONNE er de nyttigste funksjonene, og det er også INDEKS og SAMMENLIGN.

Merknad:  Vær oppmerksom på at oppslagsveiviseren ikke lenger er med i Excel.

Her er en rask repetisjon av hvordan du bruker FINN.RAD.

=FINN.RAD(B2;C2:E7;3;SANT)

Det første argumentet er verdien du vil finne. Det kan være en cellereferanse eller en fast verdi som «Olsen» eller 21 000. Det andre argumentet er celleområdet du tror inneholder verdiene du vil finne. I dette eksemplet er det C2–C7. Det tredje argumentet er kolonnen i celleområdet som inneholder verdien du vil se.

Det fjerde argumentet er valgfritt. Du kan angi Sant eller Usant. Hvis du skriver SANT eller la argumentet stå tomt, blir resultatet av funksjonen et omtrentlig samsvar med verdien du angir i det første argumentet. Hvis du skriver USANT, finner funksjonen verdien i det første argumentet. Hvis du lar det fjerde argumentet stå tomt, eller skriver SANT, får du altså mer fleksibilitet.

Dette eksempelet viser deg hvordan funksjonen fungerer. Når du skriver en verdi i celle B2 (første argument), søker FINN.RAD i celle C2 til E7 (andre argument) og finner det nærmeste omtrentlige samsvaret fra den tredje kolonnen i området, kolonne E (tredje argument).

Et typisk eksempel på bruk av FINN.RAD-funksjonen

Det fjerde argumentet er tomt, og dermed gir funksjonen et omtrentlig samsvar. Hvis den ikke gjorde det, ville du måtte skrive en av verdiene i kolonne C eller D for å få et resultat i det hele tatt.

Når du er blitt fortrolig med FINN.RAD, er det ganske lett å bruke FINN.KOLONNE-funksjonen. Du skriver de samme argumentene, men funksjonen finner verdier i rader i stedet for i kolonner.

Prøv det

Hvis du vil prøve oppslagsfunksjoner før du prøver dem med dine egne data, finner du en del eksempeldata her. Noen liker å bruke FINN.RAD og FINN.KOLONNE, andre foretrekker å bruke INDEKS og SAMMENLIGN sammen. Prøv hver metode og se hvilke du liker best.

FINN.RAD i bruk

Kopier alle cellene i denne tabellen, og lim dem inn i celle A1 i et tomt regneark i Excel.

Tips!    Angi bredden til kolonne A og B til 250 piksler før du limer inn dataene i Excel, og klikk Bryt tekst (Justering-gruppen i kategorien Hjem).

Tetthet

Viskositet

Temperatur

0,457

3,55

$ 500

0,525

3,25

04:00

0,606

2,93

300

0,675

2,75

kr 250

0,746

2,57

-200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50 %

1,29

1,71

0

Formel

Beskrivelse

Resultat

'=FINN.RAD(1;A2:C10;2)

Søker etter verdien 1 i kolonne A med bruk av tilnærmet samsvar, og finner den største verdien som er mindre enn eller lik 1 (0,946) i kolonne A, og returnerer deretter verdien fra kolonne B i samme rad.

=FINN.RAD(1;A2:C10;2)

'=FINN.RAD(1;A2:C10;3;SANN)

Søker etter verdien 1 i kolonne A med bruk av tilnærmet samsvar, og finner den største verdien som er mindre enn eller lik 1 i kolonne A, som er 0,946, og returnerer deretter verdien fra kolonne C i samme rad

=FINN.RAD(1;A2:C10;3;SANN)

'=FINN.RAD(0,7;A2:C10;3;USANN)

Søker etter verdien 0,7 i kolonne A med bruk av nøyaktig samsvar. Siden det ikke finnes noen nøyaktig samsvarende verdier i kolonne A, returneres en feil.

=FINN.RAD(0,7;A2:C10;3;USANN)

'=FINN.RAD(0,1;A2:C10;3;SANN)

Søker etter verdien 0,1 i kolonne A med bruk av tilnærmet samsvar. Ettersom 0,1 er mindre enn den minste verdien i kolonne A, returneres en feil.

=FINN.RAD(0,1;A2:C10;2;SANN)

'=FINN.RAD(2;A2:C10;3;SANN)

Søker etter verdien 2 i kolonne A med bruk av tilnærmet samsvar, finner den største verdien som er mindre enn eller lik 2 i kolonne A, som er 1, 29, og returnerer deretter verdien fra kolonne B i samme rad.

=FINN.RAD(2;A2:C10;2;SANN)

FINN.KOLONNE i bruk

Kopier alle cellene i denne tabellen, og lim dem inn i celle A1 i et tomt regneark i Excel.

Tips!    Angi bredden til kolonne A og B til 250 piksler før du limer inn dataene i Excel, og klikk Bryt tekst (Justering-gruppen i kategorien Hjem).

Aksler

Lagre

Bolter

4

4

9

5

7

10

6

8

11

Formel

Beskrivelse

Resultat

'=FINN.KOLONNE("Aksler";A1:C4;2;SANN)

Slår opp Aksler i rad 1, og returnerer verdien fra rad 2 i samme kolonne (kolonne A).

=FINN.KOLONNE("Aksler";A1:C4;2;SANN)

'=FINN.KOLONNE("Lagre";A1:C4;3;USANN)

Slår opp Lagre i rad 1, og returnerer verdien fra rad 3 i samme kolonne (kolonne B).

=FINN.KOLONNE("Maskinlagre";A1:C4;3;USANN)

'=FINN.KOLONNE("B";A1:C4;3;SANN)

Slår opp B i rad 1, og returnerer verdien fra rad 3 i samme kolonne. I og med at et eksakt samsvar med B ikke blir funnet, brukes den største verdien i rad 1 som er større enn B: Aksler i kolonne A.

=FINN.KOLONNE("B";A1:C4;3;SANN)

'=FINN.KOLONNE("Bolter";A1:C4;4)

Slår opp Bolter i rad 1, og returnerer verdien fra rad 4 i samme kolonne (kolonne C).

=FINN.KOLONNE("Bolter";A1:C4;4)

'=FINN.KOLONNE(3; {1;2;3\"a";"b";"c"\"d";"e";"f"}; 2; SANN)

Slår opp tallet 3 i den trerads matrisekonstanten, og returnerer verdien fra rad 2 i den samme (i dette tilfellet tredje) kolonnen. Det er tre rader med verdier i matrisekonstanten, og hver rad er atskilt med en omvendt skråstrek (\). Fordi c finnes i rad 2 og i samme kolonne som 3, returneres c.

=FINN.KOLONNE(3;{1;2;3\"a";"b";"c"\"d";"e";"f"};2;SANN)

INDEKS og SAMMENLIGN i bruk

Dette eksemplet bruker INDEKS- og SAMMENLIGN-funksjonene sammen for å returnere det tidligste fakturanummeret og den tilhørende datoen for hver av fem byer. I og med at datoen returneres som et tall, bruker vi TEKST-funksjonen til å formatere den som en dato. INDEKS-funksjonen bruker resultatet av SAMMENLIGN-funksjonen som sitt argument. Kombinasjonen av INDEKS- og SAMMENLIGN-funksjonene brukes to ganger i hver formel – først for å returnere fakturanummeret, og deretter for å returnere datore.

Kopier alle cellene i denne tabellen, og lim dem inn i celle A1 i et tomt regneark i Excel.

Tips!    Angi bredden til kolonne A og D til 250 piksler før du limer inn dataene i Excel, og klikk Bryt tekst (Justering-gruppen i kategorien Hjem).

Faktura

By

Fakturadato

Tidligste faktura etter by, med dato

3115

Atlanta

07.04.2012

="Atlanta = "&INDEKS($A$2:$C$33;SAMMENLIGN("Atlanta";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Atlanta";$B$2:$B$33;0);3);"dd.mm.yyyy")

3137

Atlanta

09.04.2012

="Austin = "&INDEKS($A$2:$C$33;SAMMENLIGN("Austin";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Austin";$B$2:$B$33;0);3);"dd.mm.yyyy")

3154

Atlanta

11.04.2012

="Dallas = "&INDEKS($A$2:$C$33;SAMMENLIGN("Dallas";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Dallas";$B$2:$B$33;0);3);"dd.mm.yyyy")

3191

Atlanta

21.04.2012

="New Orleans = "&INDEKS($A$2:$C$33;SAMMENLIGN("New Orleans";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("New Orleans";$B$2:$B$33;0);3);"dd.mm.yyyy")

3293

Atlanta

25.04.2012

="Tampa = "&INDEKS($A$2:$C$33;SAMMENLIGN("Tampa";$B$2:$B$33;0);1)& ", Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Tampa";$B$2:$B$33;0);3);"dd.mm.yyyy")

3331

Atlanta

27.04.2012

3350

Atlanta

28.04.2012

3390

Atlanta

01.05.2012

3441

Atlanta

02.05.2012

3517

Atlanta

08.05.2012

3124

Austin

09.04.2012

3155

Austin

11.04.2012

3177

Austin

19.04.2012

3357

Austin

28.04.2012

3492

Austin

06.05.2012

3316

Dallas

25.04.2012

3346

Dallas

28.04.2012

3372

Dallas

01.05.2012

3414

Dallas

01.05.2012

3451

Dallas

02.05.2012

3467

Dallas

02.05.2012

3474

Dallas

04.05.2012

3490

Dallas

05.05.2012

3503

Dallas

08.05.2012

3151

New Orleans

09.04.2012

3438

New Orleans

02.05.2012

3471

New Orleans

04.05.2012

3160

Tampa

18.04.2012

3328

Tampa

26.04.2012

3368

Tampa

29.04.2012

3420

Tampa

01.05.2012

3501

Tampa

06.05.2012

Mer om oppslagsfunksjoner

Til toppen av siden

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×