Office
Logg på

SUMMER, funksjon

Obs!: Vi ønsker å gi deg det nyeste hjelpeinnholdet så raskt som mulig, på ditt eget språk. Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig for deg nederst på denne siden? Her er den engelske artikkelen for enkel referanse.

Summer -funksjonen, en av matematiske og trigonometriske funksjoner, legger sammen verdiene. Du kan legge til enkeltverdier, cellereferanser eller områder eller en blanding av alle tre.

Eksempel:

  • =SUMMER(A2:A10)

  • =SUMMER(A2:A10, C2:C10)

Nettleseren støtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Denne videoen er en del av et opplæringskurs som heter Legge sammen tall i Excel 2013.

SUMMER(tall1;[tall2]; ...)

Argumentnavn

Beskrivelse

tall1    (obligatorisk)

Det første tallet du vil legge til. Nummeret kan være 4, en cellereferanse som B6, eller en celle område som B2:B8.

tall2-255    (valgfritt)

Dette er det andre tallet du legger til. Du kan angi opptil 255 tall på denne måten.

Denne delen inneholder informasjon om noen anbefalte fremgangsmåter for å arbeide med SUMMER-funksjonen. Mye av dette kan brukes til å arbeide med andre funksjoner som skal delta fysisk.

Metoden =1+2 eller =A+B – Selv om du kan legge inn =1+2+3 eller =A1+B1+C2 og få nøyaktige resultater, er disse metodene av forskjellige årsaker tilbøyelige til feil:

  1. Skrivefeil – Tenk deg at du skal skrive inn flere og/eller mye større verdier, som dette:

    • =14598,93+65437,90+78496,23

    Prøv å validere at oppføringene er riktige. Det er mye enklere å plassere disse verdiene i individuelle celler og bruke en SUMMER-formel. I tillegg kan du formatere verdiene når de er i celler, slik at de er mye enklere å lese og deretter når de er i en formel.

    Bruk SUMMER-funksjonen i stedet for hardkodede verdier i formler.  Formelen i celle D5 er =SUMMER(D2:D4)
  2. #VERDI!-feil som følge av tekstreferanse i stedet for tallreferanse

    Hvis du bruker en formel som:

    • =A1+B1+C1 eller =A1+A2+A3

    Eksempel på dårlig formelbygging.  Formelen i celle D2 er =A2+B2+C2

    Formelen kan bryte Hvis det er ikke-numerisk (tekst) verdier i de refererte cellene som returnerer en #VALUE! feil. SUMMER ignorerer tekstverdier og gir deg summen av de numeriske verdiene.

    Riktig formelbygging.  I stedet for =A2+B2+C2, er formelen i D2 =SUMMER(A2:C2)
  3. #REF!-feil som følge av sletting av rader eller kolonner

    #REF!-feil forårsakes ved sletting av en kolonne.  Formelen er endret til =A2+#REF!+B2

    Hvis du sletter en rad eller kolonne, oppdateres ikke formelen for å utelukke den slettede raden, og den returnerer en #REF!-feil der en SUMMER-funksjon ville blitt oppdatert automatisk.

    SUMMER-funksjonen justerer automatisk for innsatte eller slettede rader og kolonner
  4. Formler oppdaterer ikke referanser ved innsetting av rader eller kolonner

    = A+B+C-formler oppdateres ikke om du legger til rader

    Hvis du setter inn en rad eller kolonne, oppdateres ikke formelen Hvis du vil inkludere raden som legges til, der en SUMMER-funksjonen blir automatisk oppdatert (så lenge du ikke er utenfor området i formelen). Dette er spesielt viktige hvis du forventer at formelen skal oppdatere og ikke, når det kommer forlater du ufullstendig resultater som du ikke kan fange opp.

    Eksemplet viser en SUMMER-formel som automatisk utvides fra =SUMMER(A2:C2) til =SUMMMER(A2:D2) når det settes inn en kolonne
  5. SUMMER med enkeltvise cellereferanser kontra områder

    Bruk av en formel som:

    • =SUMMER(A1,A2,A3,B1,B2,B3)

    Er lik feil utsatt når å sette inn eller slette rader i det refereres til området av samme årsaker. Det er mye bedre å bruke individuelle områder, for eksempel:

    • =SUMMER(A1:A3,B1:B3),

    som oppdateres når du legger til eller sletter rader.

Problem

Hva gikk galt

SUMMER-funksjonen min viser ##### i stedet for resultatet.

Merk kolonnebreddene. ### betyr vanligvis at kolonnen er for smal til å vise formelresultatet.

SUMMER-funksjonen viser selve formelen som tekst, ikke resultatet.

Kontroller at cellen ikke er formatert som tekst. Merk cellen eller celleområdet aktuelle og bruke Ctrl + 1 til å vise dialogboksen Formater celler og deretter klikk tall-fanen , og velg ønsket format. Hvis cellen er formatert som tekst og endres ikke når du har endret formatet, må du kanskje bruke F2 > Enter tvinge formatet til å endre.

SUMMER-funksjonen min oppdateres ikke.

Kontroller at beregningen er satt til automatisk. Gå til Beregningsalternativeri kategorien formel . Du kan også bruke F9 for å tvinge regnearket til å beregne.

Kontroller at beregning er satt til Automatisk.  På Formel-fanen går du til Beregningsalternativer.

Enkelte verdier legges ikke til.

Bare tallverdier i funksjonsreferansen eller -området kan legges til. Tomme celler, logiske verdier som SANN eller tekst ignoreres.

Feilen #NAVN? vises i stedet for det forventede resultatet.

Dette betyr vanligvis at formelen er feilstavet, for eksempel =sume(A1:A10) i stedet for =SUMMER(A1:A10).

Min SUMMER-funksjon viser et helt tall, men det skal vise desimaler

Kontroller formateringen av cellen for å kontrollere at du viser desimaler. Merk den aktuelle cellen eller det aktuelle celleområdet, og bruk CTRL+1 for å åpne dialogboksen Formater celler. Klikk deretter Tall-fanen og velg ønsket format. Pass på å angi ønsket antall desimaler.

  1. Jeg vil bare legge til / trekke fra / multiplisere / dividere tall – Se denne videoserien om Enkle matematiske beregninger i Excel, eller Bruk Excel som kalkulator.

  2. Hvordan viser jeg flere/desimaler? Du kan endre ditt tallformat. Merk cellen eller celleområdet aktuelle og bruke Ctrl + 1 til å hente frem dialogboksen Formater celler og deretter klikker du tall-kategorien , og velg ønsket format, og Husk å angi antallet desimaler du vil bruke.

  3. Hvordan legge til eller trekke fra tid? Du kan legge til og trekke fra tid på et par forskjellige måter. For eksempel kan du finne forskjellen mellom 08:00 – 12:00 for lønnsformål ved på bruke =(«12:00»-«08:00»)*24, som tar sluttidspunktet minus starttidspunktet. Legg merke til at Excel beregner tidsrom som brøker av et døgn, så du må multiplisere med 24 å få totalt antall timer. I det første eksemplet bruker vi =((B2-A2)+(D2-C2))*24 for å få summen av timer fra start til slutt, minus en lunsjpause (8,50 timer totalt).

    Hvis du bare vil legge til timer og minutter og vil vise på denne måten, kan du summere og trenger ikke å multiplisere med 24, slik at vi i det andre eksemplet bruker =SUMMER(A6:C6) fordi vi trenger bare det totale antallet timer og minutter for tildelte aktiviteter (5:36 eller 5 timer, 36 minutter).

    Beregn tidsrom

    Hvis du vil ha mer informasjon, kan du se: Legge til eller trekke fra tid.

  4. Hvordan skaffer jeg meg forskjellen mellom datoer? I likhet med klokkeslett, kan du legge til og trekke fra datoer. Her er et veldig vanlig eksempel på å telle antall dager mellom to datoer. Det er like enkelt som = B2 A2. Nøkkelen til å arbeide med både datoer og klokkeslett er at du starter med det sluttdato /-klokkeslettet og trekke fra Start dato/klokkeslett.

    Beregn forskjeller mellom datoer

    Du finner flere måter å arbeide med datoer på i: Beregne antall dager mellom to datoer.

  5. Hvordan summerer jeg bare synlige celler? Noen ganger når du manuelt skjuler radene eller bruker AutoFilter for å vise bare bestemte data, vil du også bare summere de synlige cellene. Du kan bruke TOTALSUM-funksjonen. Hvis du bruker en totalrad i en Excel-tabell, legges funksjoner du velger fra Total-rullegardinlisten automatisk inn som en totalsum. Se mer informasjon om hvordan du summerer dataene i en Excel-tabell.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

Lær mer om summer

Se en video om hvordan du bruker SUMMER-funksjonen

SUMMERHVIS-funksjonen legger bare sammen verdiene som oppfyller ett enkelt vilkår

SUMMER.HVIS.SETT-funksjonen legger bare sammen verdiene som oppfyller flere vilkår

ANTALL.HVIS-funksjonen teller bare verdiene som oppfyller ett enkelt vilkår

ANTALL.HVIS.SETT -funksjonen teller bare verdiene som oppfyller flere vilkår

Oversikt over formler i Excel

Unngå formler med feil

Finne og rette feil i formler

Hurtigtaster i Excel for Windows

Hurtigtaster i Excel for Mac

Matematikk- og trigonometri-funksjoner

Funksjoner i Excel (alfabetisk)

Excel-funksjoner (etter kategori)

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×