Opprette en ekstern referanse (kobling) til et celleområde i en annen arbeidsbok

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

Du kan referere til innholdet i celler i en annen arbeidsbok ved å opprette en ekstern referanse. En ekstern referanse (også kalt kobling) er en referanse til en celle eller et område i et regneark i en annen Excel-arbeidsbok, eller en referanse til et definert navn i en annen arbeidsbok. Du kan referere til det bestemte celleområdet eller et definert navn for celleområdet, eller du kan definere et navn for den eksterne referansen.

Hva vil du gjøre?

Lær mer om eksterne referanser

Opprette en ekstern referanse mellom celler i ulike arbeidsbøker

Opprette en ekstern referanse til et definert navn i en annen arbeidsbok

Definere et navn som inneholder en ekstern referanse til celler i en annen arbeidsbok

Lære mer om eksterne referanser

Eksterne referanser ligner på cellereferanser, men det finnes også vesentlige forskjeller. Du bruker eksterne referanser når du arbeider med store datamengder eller komplekse formler som er spredt over flere arbeidsbøker. Du oppretter dem på en annen måte, og de vises på en annen måte i en celle eller på formellinjen.

Hvor eksterne referanser kan brukes effektivt

Eksterne referanser er spesielt nyttige når det ikke er praktisk å holde store regnearkmodeller samlet i den samme arbeidsboken.

  • Slå sammen data fra flere regneark    Du kan koble sammen arbeidsbøker fra flere brukere eller avdelinger og integrere de viktigste dataene i en sammendrag arbeidsbok. På denne måten når kildearbeidsbøker er endret, du trenger ikke endre manuelt sammendrag arbeidsboken.

  • Lage forskjellige visninger av dataene    Du kan angi alle dataene i én eller flere kildearbeidsbøker og deretter opprette en rapportarbeidsbok som inneholder eksterne referanser bare til de viktigste dataene.

  • Strømlinjeforme store, sammensatte modeller       Ved å bryte ned en komplisert modell i en rekke gjensidig avhengige arbeidsbøker, kan du arbeide med modellen uten å åpne alle de tilhørende regnearkene. Mindre arbeidsbøker er lettere å endre, de krever ikke så mye minne, og de er raskere å åpne, lagre og beregne.

Metoder for å opprette eksterne referanser

Hvis du bruker en cellereferanse til å opprette en ekstern referanse, kan du deretter også bruke formler i dataene. Ved å veksle mellom de ulike typene cellereferanser, kan du også angi hvilke celler som skal være tilkoblet hvis du flytter den eksterne referansen. Hvis du for eksempel bruker en relativ referanse og du flytter den eksterne referansen, endres cellen eller cellene den er koblet til, for å vise den nye plasseringen i regnearket.

Når du oppretter en ekstern referanse fra én arbeidsbok til en annen arbeidsbok, bør du bruke et navn til å referere til cellene du kobler til. Du kan opprette en ekstern referanse ved å bruke et navn som allerede er definert, eller du kan definere navnet når du oppretter den eksterne referansen. Ved å bruke et navn er det enklere å huske innholdet i cellene du kobler til. Eksterne referanser som bruker definert navn, endres ikke når du flytter dem, fordi et navn refererer til en bestemt celle eller et bestemt celleområde. Hvis du vil at en ekstern referanse som bruker et definert navn, skal endres når du flytter den, kan du endre navnet som brukes i den eksterne referansen, eller du kan endre cellene som navnet refererer til.

Hvordan en ekstern referanse til en annen arbeidsbok ser ut

Formler med eksterne referanser til andre arbeidsbøker vises på to måter, avhengig av om kildearbeidsboken – den ene arbeidsboken som leverer data til en formel – er åpen eller lukket.

Når kilden er åpen, inkluderer den eksterne referansen arbeidsboknavnet i hakeparenteser ([ ]), fulgt av regnearknavnet, et utropstegn (!) og cellene som formelen avhenger av. Følgende formel vil for eksempel legge til cellene C10:C25 fra arbeidsboken Budsjett.xls.

Ekstern referanse

=SUMMER([Budsjett.xlsx]Årlig!C10:C25)

Når kilden ikke er åpen, inkluderer den eksterne referansen hele banen.

Ekstern referanse

=SUMMER('C:\Rapporter\[Budsjett.xlsx]Årlig'!C10:C25)

Merknad: Hvis navnet på det andre regnearket eller arbeidsboken inneholder ikke-alfabetiske tegn, må du skrive inn navnet (eller banen) i enkle anførselstegn.

Formler som er koblet til et definert navn i en annen arbeidsbok, bruker arbeidsboknavnet, etterfulgt av et utropstegn (!) og navnet. Den følgende formelen vil for eksempel legge til cellene i området kalt Salg, fra arbeidsboken kalt Budsjett.xlsx.

Ekstern referanse

=SUMMER(Budsjett.xlsx!Salg)

Til toppen av siden

Opprette en ekstern referanse mellom celler i forskjellige arbeidsbøker

  1. Åpne arbeidsboken som skal inneholde den eksterne referansen (målarbeidsboken), og arbeidsboken som inneholder dataene du vil koble til (kildearbeidsboken).

  2. I kildearbeidsboken klikker du Lagre KnappesymbolVerktøylinjen for hurtigtilgang.

  3. Merk cellen eller cellene der du vil opprette den eksterne referansen.

  4. Skriv inn = (likhetstegn). Hvis du vil utføre beregninger eller funksjoner på verdien for ekstern referanse, skriver du inn operator eller funksjon som skal stå foran den eksterne referansen.

  5. Bytt til kildearbeidsboken, og klikk deretter regnearket som inneholder cellene du vil koble til.

  6. Merk cellen eller cellene du vil koble til.

  7. Gå tilbake til målarbeidsboken, og legg merke til at Excel legger til referansen i kildearbeidsboken og cellene du merket i forrige trinn.

  8. I målregnearket kan du også redigere eller endre formelen.

  9. Trykk CTRL+SKIFT+ENTER.

Til toppen av siden

Opprette en ekstern referanse til et definert navn i en annen arbeidsbok

  1. Åpne arbeidsboken som skal inneholde den eksterne referansen (målarbeidsboken), og arbeidsboken som inneholder dataene du vil koble til (kildearbeidsboken).

  2. I kildearbeidsboken klikker du Lagre KnappesymbolVerktøylinjen for hurtigtilgang.

  3. Merk cellen eller cellene der du vil opprette den eksterne referansen.

  4. Skriv inn = (likhetstegn). Hvis du vil utføre beregninger eller funksjoner på verdien for den eksterne referansen, skriver du inn operatoren eller funksjonen du vil foran den eksterne referansen.

  5. Klikk Bytt vinduer i Vindu-gruppen i kategorien Vis, klikk kildearbeidsboken, og klikk deretter regnearket som inneholder cellene du vil koble til.

    Vindu-gruppen på Visning-fanen

  6. Trykk F3, og merk deretter navnet du vil koble til.

Til toppen av siden

Definere et navn som inneholder en ekstern referanse til celler i en annen arbeidsbok

  1. Åpne målarbeidsboken og kildearbeidsboken.

  2. I kategorien Formler i målarbeidsboken klikker du Definer navn i Definerte navn-gruppen.

    Bilde av Excel-båndet

  3. Skriv inn et navn for området i Navn-boksen i dialogboksen Nytt navn.

  4. Slett innholdet i boksen Refererer til, slett innholdet og behold markøren i boksen.

    Hvis navnet inneholder en formel, skriver du inn formelen og plasserer markøren der du vil ha den eksterne referansen. Skriv for eksempel inn =SUMMER(), og plasser deretter markøren mellom parentesene.

  5. Klikk Bytt vinduer i Vindu-gruppen i kategorien Vis, klikk kildearbeidsboken, og klikk deretter regnearket som inneholder cellene du vil koble til.

    Vindu-gruppen på Visning-fanen

  6. Merk cellen eller celleområdet du vil koble til.

  7. Klikk OK i dialogboksen Nytt navn.

Til toppen av siden

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×