OG (funksjon)

Bruk OG-funksjonen, én av de logiske funksjonene, for å finne ut om alle vilkårene i en test er SANN.

Eksempel

Eksempler på OG-funksjon

OG-funksjonen returnerer SANN hvis alle argumentene evalueres til SANN, og USANN hvis ett eller flere argumenter evalueres til USANN.

Et vanlig bruksområde for funksjonen OG er å utvide nytten av andre funksjoner som utfører logiske tester. Funksjonen HVIS utfører for eksempel en logisk test, og deretter returneres én verdi hvis testen evalueres til SANN, og en annen verdi hvis testen evalueres til USANN. Ved å bruke funksjonen OG som argumentet logisk_test i funksjonenHVIS, kan du teste mange forskjellige tilstander i stedet for bare én.

Syntaks

OG(logisk1; [logisk2]; ...)

OG-funksjonens syntaks har følgende argumenter:

Argument

Beskrivelse

Logisk1

Obligatorisk. Den første betingelsen du vil teste som kan evalueres til SANN eller USANN.

Logisk2, ...

Valgfritt. Andre tilstander du vil teste som kan evalueres til SANN eller USANN, opptil maksimalt 255 betingelser.

Merknader

  • Argumentene må returnere logiske verdier som SANN eller USANN, eller de må være matriser eller referanser som inneholder logiske verdier.

  • Hvis et matrise- eller referanseargument inneholder tekst eller tomme celler, ignoreres disse verdiene.

  • Hvis det angitte området ikke inneholder noen logiske verdier, vil OG-funksjonen returnere en #VERDI!-feil.

Eksempler

Her er noen generelle eksempler på bruk av OG alene og i forbindelse med HVIS-funksjonen.

Eksempler på bruk av HVIS-funksjoner med OG

Formel

Beskrivelse

=OG(A2>1,A2<100)

Viser SANN hvis A2 er større enn 1 OG mindre enn 100, viser ellers USANN.

=HVIS(OG(A2<A3,A2<100),A2,"Verdien er utenfor området")

Viser verdien i celle A2 hvis den er mindre enn A3 OG mindre enn 100, ellers vises meldingen «Verdien er utenfor området».

=HVIS(OG(A3>1,A3<100),A3,"Verdien er utenfor området")

Viser verdien i celle A3 hvis den er større enn 1 OG mindre enn 100, ellers vises det en melding. Du kan angi meldingen selv.

Bonusberegning

Her er en ganske vanlig situasjon der må vi beregne om selgere kvalifiserer for en bonus ved hjelp av HVIS og OG.

Eksempel på å beregne salgsbonus med HVIS og OG-funksjoner.  Formelen i celle E14 er =HVIS(OG(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • =HVIS(OG(B14>=$B$7,C14>=$B$5),B14*$B$8,0)HVIS totalsalg er større enn eller lik (>=) salgsmålet OG kontoene er større enn eller lik (>=) kontomålet, multipliseres totalsalget med bonusprosenten – ellers returneres 0.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Beslektede emner

Video: Avanserte HVIS-funksjoner
Finn ut hvordan du bruker nestede funksjoner i en formel
HVIS-funksjonen
ELLER-funksjonen
IKKE-funksjonen
Oversikt over formler i Excel
Slik unngår du formler med feil
Bruk feilkontroll for å oppdage feil i formler
Hurtigtaster i Excel 2016 for Windows
Hurtigtaster i Excel 2016 for Mac
Logiske funksjoner (referanse)
Excel-funksjoner(alfabetisk)
Excel-funksjoner (etter kategori)

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×