Legge sammen tall

La oss anta at du vil beregne den totale prisen på lagerbeholdningen til en butikk eller de totale bruttofortjenestemarginene for alle avdelinger som er under budsjettet for året. Du kan bruke flere ulike metoder til å legge sammen tall.

Hva vil du gjøre?

Legge sammen tall i en celle

Legge sammen alle sammenhengende tall i en rad eller kolonne

Legge sammen tall som ikke er sammenhengende

Eksempel

Legge sammen tall basert på én betingelse

Eksempel

Legge sammen tall basert på flere vilkår

Eksempel

Hvordan funksjonene brukes i eksemplet over

Legge sammen tall basert på vilkår lagret i et eget område

Eksempel

Hva er skjedd med veiviserens for betinget summering?

Legge sammen bare unike verdier

Eksempel

Legge sammen tall i en celle

Bruk den aritmetiske operatoren + (plusstegn) i en formel.

Hvis du for eksempel skriver inn følgende formel i en celle:

=5+10

Vises følgende resultat i cellen:

15

Til toppen av siden

Legge sammen alle sammenhengende tall i en rad eller kolonne

Hvis du har et område med sammenhengende tall (det vil si at det ikke er noen tomme celler), kan du bruke Autosummer-knappen Knapp.

  1. Klikk i en celle nedenfor tallkolonnen eller til høyre for tallraden.

  2. Klikk Autosummer Knapp i Redigering-gruppen i kategorien Hjem, og trykk deretter ENTER.

Til toppen av siden

Legge sammen tall som ikke er sammenhengende

Hvis du har et område med tall som kan inneholde tomme celler eller celler som inneholder tekst i stedet for tall, bruker du SUMMER-funksjonen i en formel. Tomme celler og celler som inneholder tekst i stedet for tall, ignoreres hvis om de er inkludert i området som brukes i formelen.

Eksempel

Det kan være enklere å forstå dette eksemplet hvis du kopierer det til et tomt regneark.

Slik kopierer du et eksempel

  1. Opprett en tom arbeidsbok eller et tomt regneark.

  2. Merk eksemplet i hjelpeemnet.

    Obs!    Ikke merk rad- eller kolonneoverskriftene.

    Merke et eksempel fra Hjelp

    Merke et eksempel fra Hjelp

  3. Trykk CTRL+C.

  4. Merk celle A1 i regnearket, og trykk CTRL+V.

  5. Du bytter mellom å vise resultater og å vise formler som returnerer resultater, ved å trykke CTRL+J eller ved å klikke Vis formler i Formelrevisjon-gruppen i kategorien Formler.

1

2

3

4

5

6

7

A

B

Selger

Faktura

Berg

15 000

Berg

9 000

Steffensen

8 000

Steffensen

20 000

Berg

5 000

Larsen

22 500

Formel

Beskrivelse (resultat)

=SUMMER(B2:B3; B5)

Legger sammen to fakturaer fra Berg og én fra Steffensen (44 000)

=SUMMER(B2;B5;B7)

Legger sammen enkeltfakturaer fra Berg, Steffensen og Larsen (57 500)

Merknad   SUMMER-funksjonen kan inneholde en hvilken som helst kombinasjon av opptil 30 celle- eller områdereferanser. Formelen =SUMMER(B2:B3;B5) inneholder for eksempel én områdereferanse (B2:B3) og én celle (B5).

Til toppen av siden

Legge sammen tall basert på én betingelse

Du kan bruke SUMMERHVIS-funksjonen til å lage en totalverdi for ett område basert på en verdi i et annet område. I følgende eksempel vil du lage en totalverdi bare for verdiene i kolonne B (Faktura) som svarer til verdier i kolonne A (Selger) for selgeren som heter Berg.

Eksempel

Det kan være enklere å forstå dette eksemplet hvis du kopierer det til et tomt regneark.

Slik kopierer du et eksempel

  1. Opprett en tom arbeidsbok eller et tomt regneark.

  2. Merk eksemplet i hjelpeemnet.

    Obs!    Ikke merk rad- eller kolonneoverskriftene.

    Merke et eksempel fra Hjelp

    Merke et eksempel fra Hjelp

  3. Trykk CTRL+C.

  4. Merk celle A1 i regnearket, og trykk CTRL+V.

  5. Du bytter mellom å vise resultater og å vise formler som returnerer resultater, ved å trykke CTRL+J eller ved å klikke Vis formler i Formelrevisjon-gruppen i kategorien Formler.

1

2

3

4

5

6

7

A

B

Selger

Faktura

Berg

15 000

Berg

9 000

Steffensen

8 000

Steffensen

20 000

Berg

5 000

Larsen

22 500

Formel

Beskrivelse (resultat)

=SUMMERHVIS(A2:A7;"Berg";B2:B7)

Summen av fakturaer for Berg (29 000)

=SUMMERHVIS(B2:B7;">=9 000";B2:B7)

Summen av fakturaer som er større enn eller lik 9 000 (66 500)

=SUMMERHVIS(B2:B7;"<9 000";B2:B7)

Summen av fakturaer som er mindre enn 9 000 (13 000)

SUMMERHVIS-funksjonen bruker følgende argumenter.

Formel med SUMMERHVIS-funksjonen

Formel med SUMMERHVIS-funksjonen

1. Område som skal evalueres: Undersøk cellene for å finne ut om en rad oppfyller vilkårene.

2. Vilkår: Betingelsen de evaluerte cellene må oppfylle for at raden skal regnes med i sluttsummen.

3. Område som skal summeres: Legger sammen tallene i cellene hvis raden oppfyller vilkårene.

Til toppen av siden

Legge sammen tall basert på flere vilkår

Du kan gjøre dette ved å bruke SUMMER.HVIS.SETT-funksjonen.

Eksempel

Det kan være enklere å forstå dette eksemplet hvis du kopierer det til et tomt regneark.

Slik kopierer du et eksempel

  1. Opprett en tom arbeidsbok eller et tomt regneark.

  2. Merk eksemplet i hjelpeemnet.

    Obs!    Ikke merk rad- eller kolonneoverskriftene.

    Merke et eksempel fra Hjelp

    Merke et eksempel fra Hjelp

  3. Trykk CTRL+C.

  4. Merk celle A1 i regnearket, og trykk CTRL+V.

  5. Du bytter mellom å vise resultater og å vise formler som returnerer resultater, ved å trykke CTRL+J eller ved å klikke Vis formler i Formelrevisjon-gruppen i kategorien Formler.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

D

Region

Selger

Type

Salg

Sør

Berg

Drikkevarer

3571

Vest

Nielsen

Melk og smør

3338

Øst

Steffensen

Drikkevarer

5122

Nord

Steffensen

Melk og smør

6239

Sør

Larsen

Meieriprodukter

8677

Sør

Nielsen

Kjøtt

450

Sør

Nielsen

Kjøtt

7673

Øst

Steffensen

Meieriprodukter

664

Nord

Nielsen

Meieriprodukter

1500

Sør

Larsen

Kjøtt

6596

Formel

Beskrivelse (resultat)

=SUMMER.HVIS.SETT(D2:D11,A2:A11,"Sør",C2:C11,"Kjøtt")

Samlet salg av kjøtt i region Sør (14 719)

=SUMMER(HVIS((A2:A11="Sør")+(A2:A11="Øst");D2:D11))

Samlet salg der regionen er Sør eller Øst (32 753)

Merknad   Den andre formelen i eksemplet må angis som en matriseformel. Når du har kopiert eksemplet til et tomt regneark, merker du formelcellen. Trykk F2, og trykk deretter CTRL+SKIFT+ENTER. Hvis formelen ikke blir lagt inn som en matriseformel, returneres feilen #VERDI!.

Hvordan funksjonene brukes i eksemplet over

=SUMMER.HVIS.SETT(D2:D11,A2:A11,"Sør",C2:C11,"Kjøtt

SUMMER.HVIS.SETT-funksjonen brukes i den første formelen til å finne rader der "Sør" er i kolonne A og "Kjøtt" er i kolonne C. Det er tre forekomster av dette: i rad 7, 8 og 11. Funksjonen ser først på kolonne A, som inneholder områdene, for å finne et samsvar med Sør. Deretter ser den på kolonne C, som inneholder mattypen, for å finne et samsvar med Kjøtt. Til slutt ser funksjonen i området som inneholder verdiene som skal summeres, D2:D11, og summerer bare verdiene i kolonnen som oppfyller de to betingelsene..

=SUMMER(HVIS((A2:A11="Sør")+(A2:A11="Øst");D2:D11))

Den andre formelen, som bruker SUM- og HVIS-funksjonen, legges inn som en matriseformel (ved å trykke CTRL+SHIFT+ENTER) for å finne rader der enten "Sør" eller "Øst" eller begge er i kolonne A. Det er sju forekomster av dette: i rad 2, 4, 6, 7, 8, 9 og 11. Siden formelen er en matriseformel, brukes ikke operatoren + til å legge sammen verdier, men til å se etter to eller flere vilkår der minst ett må være oppfylt. Deretter brukes SUMMER-funksjonen til å legge sammen verdiene som oppfyller disse kriteriene.

Til toppen av siden

Legge sammen tall basert på vilkår lagret i et eget område

Du kan gjøre dette ved å bruke DSUMMER-funksjonen.

Eksempel

Det kan være enklere å forstå dette eksemplet hvis du kopierer det til et tomt regneark.

Slik kopierer du et eksempel

  1. Opprett en tom arbeidsbok eller et tomt regneark.

  2. Merk eksemplet i hjelpeemnet.

    Obs!    Ikke merk rad- eller kolonneoverskriftene.

    Merke et eksempel fra Hjelp

    Merke et eksempel fra Hjelp

  3. Trykk CTRL+C.

  4. Merk celle A1 i regnearket, og trykk CTRL+V.

  5. Du bytter mellom å vise resultater og å vise formler som returnerer resultater, ved å trykke CTRL+J eller ved å klikke Vis formler i Formelrevisjon-gruppen i kategorien Formler.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

D

Region

Selger

Type

Salg

Sør

Berg

Drikkevarer

3571

Vest

Nielsen

Melk og smør

3338

Øst

Steffensen

Drikkevarer

5122

Nord

Steffensen

Melk og smør

6239

Sør

Larsen

Meieriprodukter

8677

Sør

Nielsen

Kjøtt

450

Sør

Nielsen

Kjøtt

7673

Øst

Steffensen

Meieriprodukter

664

Nord

Nielsen

Meieriprodukter

1500

Sør

Larsen

Kjøtt

6596

Region

Selger

Type

Salg

Sør

Kjøtt

Meieriprodukter

Formel

Beskrivelse (resultat)

=DSUMMER(A1:D11; "Salg"; A12:D13)

Samlet salg av kjøtt i region Sør (14 719)

=DSUMMER(A1:D11; "Salg"; A12:D14)

Samlet salg av kjøtt og meieriprodukter i region Sør (25 560)

DSUMMER-funksjonen bruker følgende argumenter.

Formel med DSUMMER-funksjonen

1. Område som skal evalueres: Listen du vil summere.

2. Felt: Etiketten til kolonnen du vil summere.

3. Vilkår: Celleområdet som inneholder betingelsene.

Til toppen av siden

Hva er skjedd med veiviserens for betinget summering?

Dette tilleggsprogrammet er fjernet i Excel 2010. I tidligere versjoner av Excel kunne du bruke veiviseren for betinget summering til å skrive formler som beregnet summene av verdier som oppfylte bestemte betingelser. Denne funksjonaliteten er erstattet av dialogboksen Sett inn funksjon (kategorien Formler i Funksjonsbibliotek-gruppen) og andre eksisterende regnearkfunksjoner, slik som SUMMER.HVIS.SETT, og ved å bruke en kombinasjon av SUM og HVIS sammen i en formel. Hvis du vil ha mer informasjon om hvordan du bruker disse funksjonene til betinget summering av kolonner eller rader med data, kan du se delen Legge sammen tall basert på flere betingelser tidligere i denne artikkelen.

Til toppen av siden

Legge sammen bare unike verdier

Du gjør dette ved bruke SUMMER-, HVIS- og FREKVENS-funksjonen.

I følgende eksempel brukes følgende:

  • FREKVENS-funksjonen brukes til å identifisere de unike verdiene i et område. For den første forekomsten av en bestemt verdi returnerer denne funksjonen et tall som er likt antallet forekomster av den verdien. For hver etterfølgende forekomst med samme verdi som den første returnerer funksjonen 0 (null).

  • HVIS-funksjonen brukes til å tilordne en verdi på 1 til hver betingelse som er sann.

  • SUMMER-funksjonen brukes til å legge sammen de unike verdiene.

Tips!    Hvis du vil evaluere en funksjon trinn for trinn, merker du cellen som inneholder formelen. Deretter velger du kategorien Formler og klikker Evaluer formel i Formelrevisjon-gruppen.

Eksempel

Det kan være enklere å forstå dette eksemplet hvis du kopierer det til et tomt regneark.

Slik kopierer du et eksempel

  1. Opprett en tom arbeidsbok eller et tomt regneark.

  2. Merk eksemplet i hjelpeemnet.

    Obs!    Ikke merk rad- eller kolonneoverskriftene.

    Merke et eksempel fra Hjelp

    Merke et eksempel fra Hjelp

  3. Trykk CTRL+C.

  4. Merk celle A1 i regnearket, og trykk CTRL+V.

  5. Du bytter mellom å vise resultater og å vise formler som returnerer resultater, ved å trykke CTRL+J eller ved å klikke Vis formler i Formelrevisjon-gruppen i kategorien Formler.

1

2

3

4

5

6

7

8

9

10

A

Data

986

456

67

1

34

689

456

56

67

Formel

Beskrivelse (resultat)

=SUMMER(HVIS(FREKVENS(A2:A10;A2:A10)>0;A2:A10))

Legger sammen de unike verdiene i celle A2:A10 (2289)

Til toppen av siden

Gjelder for: Excel 2010



Var denne informasjonen nyttig?

Ja Nei

Hvordan kan vi forbedre det?

255 gjenstående tegn

Du må ikke inkludere kontaktinformasjon i tilbakemeldingen. Se gjennom våre retningslinjer for personvern.

Takk for tilbakemeldingen!

Støtteressurser

Endre språk