Legge sammen tall

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

La oss anta at du vil beregne den totale prisen på lagerbeholdningen til en butikk, eller de totale bruttofortjenestemarginene for alle avdelinger som er under budsjettet for året. Du kan bruke flere ulike metoder til å legge sammen tall. Hvis du på en rask måte vil legge til tall i celler, kan du bruke + (plusstegn) i en formel.

Hvis du for eksempel skriver inn = 5+10, viser cellen 15 som resultatet.

Legge sammen alle tall i en rad eller kolonne

Hvis du har et område med tilstøtende tall (det vil si at det ikke er noen tomme celler), kan du bruke Autosummer Knapp .

  1. Klikk i en celle nedenfor tallkolonnen eller til høyre for tallraden.

  2. Klikk Hjem > Autosummer, og trykk deretter Enter.

Legge til ikke-tilstøtende tall

Hvis du har et område med tall som inneholder tomme celler eller celler som inneholder tekst i stedet for tall, bruker du SUMMER-funksjonen i en formel. Tomme celler og celler som inneholder tekst i stedet for tall ignoreres selv om de er inkludert i området som brukes i formelen.

Eksempel

Arbeidsboken under viser eksempler på denne funksjonen. Undersøk dem, endre eksisterende formler eller skriv inn dine egne formler for å se hvordan funksjonen fungerer.

Merknad: SUMMER-funksjonen kan inneholde en hvilken som helst kombinasjon av opptil 30 celle- eller områdereferanser. Formelen =SUMMER(B2:B3;B5) inneholder for eksempel én områdereferanse (B2:B3) og én celle (B5).

Legge sammen tall basert på én betingelse

Du kan bruke SUMMERHVIS-funksjonen til å lage en totalverdi for ett område basert på en verdi i et annet område. I følgende eksempel vil du lage en totalverdi bare for verdiene i kolonne B (Faktura) som svarer til verdier i kolonne A (Selger) for selgeren som heter Berg.

Eksempel

Denne arbeidsboken viser eksempler på SUMMERHVIS-funksjonen. Undersøk dem, endre eksisterende formler eller skriv inn dine egne formler for å se hvordan funksjonen fungerer.

Legge sammen tall basert på flere vilkår

Du kan gjøre dette ved å bruke SUMMER.HVIS.SETT-funksjonen.

Eksempel

Arbeidsboken under viser eksempler på denne funksjonen. Undersøk dem, endre eksisterende formel eller skriv inn dine egne formler for å se hvordan funksjonen fungerer.

Hvordan funksjonene brukes i SUMMER.HVIS.SETT-eksempelet

=SUMMER.HVIS.SETT(D2:D11,A2:A11,"Sør",C2:C11,"Kjøtt")

SUMMER.HVIS.SETT-funksjonen brukes i den første formelen til å finne rader der "Sør" er i kolonne A og "Kjøtt" er i kolonne C. Det er tre forekomster av dette: i rad 7, 8 og 11. Funksjonen ser først på kolonne A, som inneholder områdene, for å finne et samsvar med Sør. Deretter ser den på kolonne C, som inneholder mattypen, for å finne et samsvar med Kjøtt. Til slutt ser funksjonen i området som inneholder verdiene som skal summeres, D2:D11, og summerer bare verdiene i kolonnen som oppfyller de to betingelsene..

=SUMMER(HVIS((A2:A11="Sør")+(A2:A11="Øst");D2:D11))

Den andre formelen, som bruker SUMMER- og HVIS-funksjonen, legges inn som en matriseformel (dersom du vil endre matrisene klikker du Åpne i Excel) for å finne rader der enten "Sør" eller "Øst" eller begge er i kolonne A. Det er sju forekomster av dette: i rad 2, 4, 6, 7, 8, 9 og 11. Siden formelen er en matriseformel, brukes ikke operatoren + til å legge sammen verdier, men til å se etter to eller flere vilkår der minst ett må være oppfylt. Deretter brukes SUMMER-funksjonen til å legge sammen verdiene som oppfyller disse kriteriene.

Legge sammen bare unike verdier

Du gjør dette ved bruke en kombinasjon av SUMMER-, HVIS- og FREKVENS-funksjonene.

I følgende eksempel brukes følgende:

  • FREKVENS-funksjonen brukes til å identifisere de unike verdiene i et område. For den første forekomsten av en bestemt verdi returnerer denne funksjonen et tall som er likt antallet forekomster av den verdien. For hver etterfølgende forekomst med samme verdi som den første returnerer funksjonen 0 (null).

  • HVIS-funksjonen brukes til å tilordne en verdi på 1 til hver betingelse som er sann.

  • SUMMER-funksjonen brukes til å legge sammen de unike verdiene.

Eksempel

Arbeidsboken under viser eksempler på disse funksjonene. Undersøk dem, endre eksisterende formel eller skriv inn dine egne formler for å se hvordan funksjonen fungerer.

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×