Lage betingede formler

Viktig: Denne artikkelen er maskinoversatt, se ansvarsfraskrivelsen. Du finner den engelske versjonen av artikkelen her som referanse.

Tester om betingelser er sanne eller usanne og foreta logiske sammenligninger mellom uttrykk er felles for mange aktiviteter. Du kan bruke den og, eller, ikkeog Hvis -funksjoner til å opprette betingede formler.

Hvis du for eksempel bruker Hvis -funksjonen følgende argumenter.

Formel med funksjonen hvis

Formel som bruker hvis-funksjonen

Knappesymbol logisk_test: betingelsen du vil kontrollere.

Bildeforklaring 2 verdi_hvis_sann: verdien som skal returneres hvis betingelsen er SANN.

Knappesymbol verdi_hvis_usann: verdien som skal returneres hvis betingelsen er USANN.

Hvis du vil ha mer informasjon om hvordan du oppretter formler, kan du se opprette eller slette en formel.

Hva du vil gjøre?

Lage en betinget formel som resulterer i en logisk verdi (SANN eller USANN)

Lage en betinget formel som resulterer i en annen beregning eller i verdier enn SANN eller USANN

Lage en betinget formel som resulterer en logisk verdi (SANN eller USANN)

Hvis du vil gjøre dette ved å bruke og, ellerog ikke funksjoner og operatorer som vist i eksemplet nedenfor.

Eksempel

Det kan være enklere å forstå dette eksemplet hvis du kopierer det til et tomt regneark.

Hvordan kopierer jeg et eksempel?

  1. Merk eksemplet i denne artikkelen.

    Viktig: Ikke merk rad- eller kolonneoverskriftene.

    velg et eksempel fra hjelp i Excel 2013 for Windows

    Merke et eksempel fra Hjelp

  2. Trykk CTRL+C.

  3. Opprett en tom arbeidsbok eller et tomt regneark i Excel.

  4. Velg celle A1 i regnearket, og trykk CTRL+V.

Viktig: For at eksemplet skal fungere riktig, må du lime det inn i celle A1 i regnearket.

  1. Du bytter mellom å vise resultater og å vise formler som returnerer resultater, ved å trykke CTRL+J eller ved å klikke Vis formler i Formelrevisjon-gruppen i kategorien Formler.

Når du har kopiert eksemplet til et tomt regneark, kan du tilpasse det etter behov.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Data

15

9

8

Tannhjul

Innretninger

Formel

Beskrivelse (Resultat)

=OG(A2>A3; A2<A4)

Finner ut om verdien i A2 er større enn verdien i A3, og finner også ut om verdien i A2 er mindre enn verdien i A4. (USANN)

=ELLER(A2>A3; A2<A4)

Finner ut om verdien i A2 er større enn verdien i A3 eller om verdien i A2 er mindre enn verdien i A4. (SANN)

=IKKE(A2+A3=24)

Finner ut om summen av verdiene i celle A2 og A3 ikke er lik 24. (USANN)

=IKKE(A5="Tannhjul")

Finner ut om verdien i celle A5 ikke er lik "Tannhjul". (USANN)

=ELLER(A5<>"Tannhjul";A6 = "Innretninger")

Finner ut om verdien i celle A5 ikke er lik "Tannhjul" eller om verdien i A6 er lik "Innretninger". (SANN)

Hvis du vil ha mer informasjon om hvordan du bruker disse funksjonene, kan du se og-funksjonen, eller-funksjonenog ikke (funksjon).

Til toppen av siden

Lage en betinget formel som resulterer i en annen beregning, eller i andre verdier enn SANN eller USANN.

Du gjør dette ved å bruke funksjonene HVIS, OG og ELLER og operatorer slik det er vist i følgende eksempel.

Eksempel

Det kan være enklere å forstå dette eksemplet hvis du kopierer det til et tomt regneark.

Hvordan kopierer jeg et eksempel?

  1. Merk eksemplet i denne artikkelen.

Viktig: Ikke merk rad- eller kolonneoverskriftene.

velg et eksempel fra hjelp i Excel 2013 for Windows

Merke et eksempel fra Hjelp

  1. Trykk CTRL+C.

  2. Opprett en tom arbeidsbok eller et tomt regneark i Excel.

  3. Velg celle A1 i regnearket, og trykk CTRL+V.

Viktig: For at eksemplet skal fungere riktig, må du lime det inn i celle A1 i regnearket.

  1. Du bytter mellom å vise resultater og å vise formler som returnerer resultater, ved å trykke CTRL+J eller ved å klikke Vis formler i Formelrevisjon-gruppen i kategorien Formler.

Når du har kopiert eksemplet til et tomt regneark, kan du tilpasse det etter behov.

1

2

3

4

5

6

7


8 %



9



10



11




12



13



14




15



16

A

B

Data

15

9

8

Tannhjul

Innretninger

Formel

Beskrivelse (Resultat)

=HVIS(A2=15, "OK", "Ikke OK")

Hvis verdien i celle A2 er lik 15, returneres "OK". Ellers returneres "Ikke OK". (OK)

=HVIS(A2<>15, "OK", "Ikke OK")

Hvis verdien i celle A2 ikke er lik 15, returneres "OK". Ellers returneres "Ikke OK". (Ikke OK)

=HVIS(IKKE(A2<=15), "OK", "Ikke OK")

Hvis verdien i celle A2 ikke er mindre enn 15, returneres "OK". Ellers returneres "Ikke OK". (Ikke OK)

=HVIS(A5<>"TANNHJUL", "OK", "Ikke OK")

Hvis verdien i celle A5 ikke er lik "TANNHJUL", returneres "OK". Ellers returneres "Ikke OK". (Ikke OK)

=HVIS(OG(A2>A3, A2<A4), "OK", "Ikke OK")

Hvis verdien i celle A2 er større enn verdien i A3 og verdien i A3 og verdien i A2 også er mindre enn verdien i A4, returneres "OK". Ellers returneres "Ikke OK". (Ikke OK)

=HVIS(OG(A2<>A3, A2<>A4), "OK", "Ikke OK")

Hvis verdien i celle A2 ikke er lik A3 og verdien i celle A2 heller ikke er lik verdien i A4, returneres "OK". Ellers returneres "Ikke OK". (OK)

=HVIS(ELLER(A2>A3, A2<A4), "OK", "Ikke OK")

Hvis verdien i celle A2 er større enn verdien i A3 og verdien i A3 eller verdien i A2 er mindre enn verdien i A4, returneres "OK". Ellers returneres "Ikke OK". (OK)

=HVIS(ELLER(A5<>"Tannhjul", A6<>"Innretninger"), "OK", "Ikke OK")

Hvis verdien i celle A5 ikke er lik "Tannhjul" eller verdien i A6 ikke er lik "Innretninger", returneres "OK". Ellers returneres "Ikke OK". (Ikke OK)

=HVIS(ELLER(A2<>A3, A2<>A4), "OK", "Ikke OK")

Hvis verdien i celle A2 ikke er lik verdien i A3 og verdien i A3 eller verdien i A2 ikke er lik verdien i A4, returneres "OK". Ellers returneres "Ikke OK". (OK)

Hvis du vil ha mer informasjon om hvordan du bruker disse funksjonene, kan du se Hvis-funksjonen, og-funksjonenog eller-funksjonen.

Til toppen av siden

Merknad: Ansvarsfraskrivelse for maskinoversettelse: Denne artikkelen er oversatt av et datasystem i stedet for en oversetter. Microsoft tilbyr disse maskinoversettelsene slik at brukere som ikke snakker engelsk, får tilgang til innhold om Microsoft-produkter, -tjenester og –teknologier. Ettersom artikkelen er maskinoversatt, kan den inneholde feil i vokabular, syntaks eller grammatikk.

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×